Gossamer Forum
Home : Products : Gossamer Links : PHP Front End :

Re: [brewt] problems after moving to new host

Quote Reply
Re: [brewt] problems after moving to new host In reply to
Quote:
Since it's an error with ADOdb, one thing you might try is to upgrade ADOdb:
Thanks, that seems worth a try. Getting rid of all those error log warnings would be nice!

Only problem is, that broke everything. Smile Blank category listings and error pages, with the logs filled up with stuff like:

PHP Notice: Undefined index: ID in /.../cgi-bin/links/admin/Links/PHP/Utils.inc.php on line 164
PHP Notice: Undefined index: Name in /.../cgi-bin/links/admin/Links/PHP/Utils.inc.php on line 166

Is there anything that needs to be done to tie in an upgraded ADOdb? I ran one of the recommended test scripts and ADOdb itself is working.

As for the fetchrow_one() fatal error in Jump.inc.php, I found the same thing happens when rating a link:

PHP Fatal error: Call to a member function fetchrow_one() on a non-object in /.../cgi-bin/links/admin/Links/PHP/Rate.inc.php on line 82

I haven't seen that happen with any of the other fetch* functions, so it appears to be specific to the fetchrow_one() behavior. I tried tweaking a few things with $this->$row type assignments but had no luck...

Dan
Subject Author Views Date
Thread problems after moving to new host Dan Kaplan 938999 Oct 13, 2010, 8:53 AM
Thread Re: [Dan Kaplan] problems after moving to new host
Andy 938583 Oct 14, 2010, 1:07 AM
Thread Re: [Andy] problems after moving to new host
Dan Kaplan 938591 Oct 14, 2010, 8:54 AM
Thread Re: [Dan Kaplan] problems after moving to new host
Andy 938568 Oct 14, 2010, 9:00 AM
Thread Re: [Andy] problems after moving to new host
Dan Kaplan 938574 Oct 14, 2010, 9:15 AM
Thread Re: [Dan Kaplan] problems after moving to new host
Andy 938575 Oct 14, 2010, 9:30 AM
Post Re: [Andy] problems after moving to new host
Dan Kaplan 938520 Oct 14, 2010, 12:19 PM
Thread Re: [Dan Kaplan] problems after moving to new host
brewt 938515 Oct 14, 2010, 4:06 PM
Thread Re: [brewt] problems after moving to new host
Dan Kaplan 938532 Oct 14, 2010, 6:58 PM
Thread Re: [Dan Kaplan] problems after moving to new host
brewt 938536 Oct 14, 2010, 7:22 PM
Thread Re: [brewt] problems after moving to new host
Dan Kaplan 938524 Oct 14, 2010, 7:30 PM
Thread Re: [Dan Kaplan] problems after moving to new host
Dan Kaplan 938530 Oct 14, 2010, 8:59 PM
Thread Re: [Dan Kaplan] problems after moving to new host
Dan Kaplan 938501 Oct 14, 2010, 9:09 PM
Thread Re: [Dan Kaplan] problems after moving to new host
brewt 938520 Oct 14, 2010, 11:55 PM
Thread Re: [brewt] problems after moving to new host
Dan Kaplan 938500 Oct 15, 2010, 10:08 AM
Thread Re: [Dan Kaplan] problems after moving to new host
brewt 938462 Oct 17, 2010, 3:18 PM
Post Re: [brewt] problems after moving to new host
Dan Kaplan 938382 Oct 21, 2010, 1:04 AM