Gossamer Forum
Home : Products : Gossamer Links : PHP Front End :

problems after moving to new host

Quote Reply
problems after moving to new host
I realize the PHP front end is no longer being supported (a true shame), but hopefully these errors and warnings ring a bell for someone. I couldn't find anything relevant in old posts.

After transferring the site to a new host, most stuff appears to be functioning correctly. One problem is this error log warning every time a page is loaded:

Only variable references should be returned by reference in /.../cgi-bin/links/admin/Links/PHP/adodb/drivers/adodb-mysql.inc.php on line 423

The bigger problem I discovered is the Jump links don't work.

PHP Fatal error: Call to a member function fetchrow_one() on a non-object in /.../cgi-bin/links/admin/Links/PHP/Jump.inc.php on line 120

Any ideas?

I'd much prefer salvaging the old install rather than upgrade to the new one, if at all possible. Integrating a CGI script into a PHP site and templates is never fun.

Dan
Subject Author Views Date
Thread problems after moving to new host Dan Kaplan 893167 Oct 13, 2010, 8:53 AM
Thread Re: [Dan Kaplan] problems after moving to new host
Andy 892824 Oct 14, 2010, 1:07 AM
Thread Re: [Andy] problems after moving to new host
Dan Kaplan 892822 Oct 14, 2010, 8:54 AM
Thread Re: [Dan Kaplan] problems after moving to new host
Andy 892808 Oct 14, 2010, 9:00 AM
Thread Re: [Andy] problems after moving to new host
Dan Kaplan 892815 Oct 14, 2010, 9:15 AM
Thread Re: [Dan Kaplan] problems after moving to new host
Andy 892812 Oct 14, 2010, 9:30 AM
Post Re: [Andy] problems after moving to new host
Dan Kaplan 892771 Oct 14, 2010, 12:19 PM
Thread Re: [Dan Kaplan] problems after moving to new host
brewt 892756 Oct 14, 2010, 4:06 PM
Thread Re: [brewt] problems after moving to new host
Dan Kaplan 892775 Oct 14, 2010, 6:58 PM
Thread Re: [Dan Kaplan] problems after moving to new host
brewt 892773 Oct 14, 2010, 7:22 PM
Thread Re: [brewt] problems after moving to new host
Dan Kaplan 892764 Oct 14, 2010, 7:30 PM
Thread Re: [Dan Kaplan] problems after moving to new host
Dan Kaplan 892770 Oct 14, 2010, 8:59 PM
Thread Re: [Dan Kaplan] problems after moving to new host
Dan Kaplan 892743 Oct 14, 2010, 9:09 PM
Thread Re: [Dan Kaplan] problems after moving to new host
brewt 892760 Oct 14, 2010, 11:55 PM
Thread Re: [brewt] problems after moving to new host
Dan Kaplan 892751 Oct 15, 2010, 10:08 AM
Thread Re: [Dan Kaplan] problems after moving to new host
brewt 892698 Oct 17, 2010, 3:18 PM
Post Re: [brewt] problems after moving to new host
Dan Kaplan 892635 Oct 21, 2010, 1:04 AM