Gossamer Forum
Home : Products : Gossamer Links : Discussions :

Problem with mod_perl

Quote Reply
Problem with mod_perl
Hi,

I’m interested in running the .cgi scripts of my web site under mod_perl.

I’m using:

Gossamer Links version: 3.2.0
Apache/2.2.3 (CentOS)
Perl version: 5.8.8


My http.conf has:

<Location /cgi-bin/>
SetHandler perl-script
PerlResponseHandler ModPerl::Registry
PerlOptions +ParseHeaders
Options +ExecCGI
Order allow, deny
Allow from all
</Location>

I restarted the apache. When I went to the “Gossamer Links Administration Panel” clicking:

/cgi-bin/admin/admin.cgi >> Setup >> Environment

I read:

Running under mod_perl: Yes (version 2.000002), mod_perl 2 detected

Then, I wrote the startup.pl file:

use lib '/var/www/cgi-bin/admin';
use Links::mod_perl;
1;

I restarted the apache but the libs and modules listed in mod_perl.pm didn´t preload and all the web site was inaccessible. Nothing shows up in the error log.

What could be happening? Is mod_perl 2.000002 the right version to run Gossamer Links version: 3.2.0? If mod_perl is running, why won´t the libs and mods listed in mod_perl.pm preload?

Thanks in advance,

joseML
Subject Author Views Date
Thread Problem with mod_perl JoseML 2360 Feb 23, 2009, 4:58 AM
Thread Re: [JoseML] Problem with mod_perl
aus_dave 2238 Feb 23, 2009, 7:57 PM
Thread Re: [aus_dave] Problem with mod_perl
JoseML 2205 Feb 25, 2009, 2:01 AM
Post Re: [JoseML] Problem with mod_perl
aus_dave 2192 Feb 25, 2009, 5:56 PM