Gossamer Forum
Home : Products : Gossamer Links : Discussions :

VArious template for add.cgi - error

Quote Reply
VArious template for add.cgi - error
Hi,

I want to have various templates for the add.cgi.

To do so I have modified the add.cgi
$PLG->dispatch('handle_add', \&Links::User::Add::handle('$section'));

In the Add.pm at the beginning of the handle function

I have add the following line
my ($section)=@_;

and at line 193
$section instead of add
print Links::SiteHTML::display($section, {
Category => sub { Links::Tools::category_list_html() },
main_title_loop => Links::Build::build('title', Links::language('LINKS_ADD'), "$CFG->{db_cgi_url}/add.cgi" . ($ids ? "?ID=$ids" : '')),
%$category
});

The form is well displayed and information inserted but when the form is displayed I have the following message:
Links (8223): Links::environment called at /home/cybion1rm/cgi/links_caseonet/admin/Links.pm line 700 with no arguments.
Links (8223): Links::fatal called at /home/cybion1rm/cgi/links_caseonet/admin/GT/Plugins.pm line 133 with arguments
(Not a CODE reference at /home/cybion1rm/cgi/links_caseonet/admin/GT/Plugins.pm line 133.
).
Links (8223): GT::Plugins::dispatch called at /home/cybion1rm/cgi/links_caseonet/add_leggi.cgi line 26 with arguments
(GT::Plugins=HASH(0x82d3178), handle_add, SCALAR(0x860a678)).

Is anybody knows what is the problem and how can it be solved

Thanks in advance for your answers,

Vercyb
Subject Author Views Date
Post VArious template for add.cgi - error vercyb 1017 Apr 29, 2005, 9:24 AM