Gossamer Forum
Home : General : Internet Technologies :

HTML Validating .. how to use "special" charachters?

Quote Reply
HTML Validating .. how to use "special" charachters?
Hi,

I'm trying to make one of our sites XHTML 1.0 compitent. I'm running it through w3.org's validator, but its giving me errors :(

My header lines are;

Code:
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

... and then alongside the other <meta> tags;

Code:
<meta http-equiv="Content-Language" content="en-gb" />
<meta http-equiv="Content-Type" content="text/html; charset=windows-1252" />

..and then inside the "body" tag;

Code:
The Firm&#146;s

for some reason, although &#146; should equate to a ' , the validator is going mad about it.

Is there an easy way around this? The whole reason we are escaping every non-standard (a-z or 0-9) into its HTML value.

TIA

Andy (mod)
andy@ultranerds.co.uk
Want to give me something back for my help? Please see my Amazon Wish List
GLinks ULTRA Package | GLinks ULTRA Package PRO
Links SQL Plugins | Website Design and SEO | UltraNerds | ULTRAGLobals Plugin | Pre-Made Template Sets | FREE GLinks Plugins!
Subject Author Views Date
Thread HTML Validating .. how to use "special" charachters? Andy 4382 Mar 7, 2005, 7:49 AM
Thread Re: [Andy] HTML Validating .. how to use "special" charachters?
Wil 4248 Mar 7, 2005, 7:52 AM
Thread Re: [Wil] HTML Validating .. how to use "special" charachters?
Andy 4238 Mar 7, 2005, 7:56 AM
Thread Re: [Andy] HTML Validating .. how to use "special" charachters?
Andy 4271 Mar 7, 2005, 8:33 AM
Thread Re: [Andy] HTML Validating .. how to use "special" charachters?
Andy 4235 Mar 8, 2005, 1:53 AM
Post Re: [Andy] HTML Validating .. how to use "special" charachters?
Payooo 4175 Mar 8, 2005, 9:46 AM