Gossamer Forum
Home : Gossamer Threads Inc. : Official Bug Fixes :

[GForum 1.2.1] - mod_perl memory leak

Quote Reply
[GForum 1.2.1] - mod_perl memory leak
Gossamer Forum 1.2.1 as originally released contains a memory leak that can eventually cause the mod_perl server (or any other persistent environment) to consume all a server's memory. I've attached a replacement for the admin/GForum/Post.pm file to this post, and also updated the 1.2.1 package available for download. If you are running Gossamer Forum in a persistent environment, you should replace the admin/GForum/Post.pm file immediately and restart your mod_perl server. Alternatively, you can download a new copy of the gforum-1.2.1.tar.gz package and "upgrade" your existing installation, then restart your mod_perl server.

Users running Gossamer Forum under non-persistent environments (i.e. under normal CGI) are not affected.

Jason Rhinelander
Gossamer Threads
jason@gossamer-threads.com
Subject Author Views Date
Thread [GForum 1.2.1] - mod_perl memory leak Jagerman 6183 Feb 13, 2004, 5:58 PM