Gossamer Forum
Home : Products : Links 2.0 : Discussions :

jump.cgi errors galore - newbie needs help please

Quote Reply
jump.cgi errors galore - newbie needs help please
Hi everyone,

I had a running copy of Links 2.0 on my Linux server. Worked great on several domains, never had any problems with it. Moved it over to a Windows 2000 server and it up and died. Installed newest version of Perl, set permissions, etc. Have been banging my head against this for weeks now. Had it on 2 domains, decided to try to do it on a new domain to see if that would fix it, using the db from one of the other domains. Now getting the following error:

Error including libraries: Can't locate X:/D Sites/www/122wallstreet.com/cgi-bin/links/admin/db_utils.pl in @INC (@INC contains: X:\Dawns Sites\www\122wallstreet.com\cgi-bin\links /usr/lib/perl5/5.8.2/cygwin-thread-multi-64int /usr/lib/perl5/5.8.2 /usr/lib/perl5/site_perl/5.8.2/cygwin-thread-multi-64int /usr/lib/perl5/site_perl/5.8.2 /usr/lib/perl5/site_perl .) at X:\D Sites\www\122wallstreet.com\cgi-bin\links\jump.cgi line 36.

Make sure they exist, permissions are set properly, and paths are set correctly.


I'm not sure what to do now! I've tried everything, or at least thought I have. But obviously I'm overlooking something and can't see the forest through the trees.

Here is my jump.cgi:

#!X:\CGYWIN\bin\perl
#
# -------------
# Links
# -------------
# Links Manager
#
# File: X:\D Sites\www\122wallstreet.com\cgi-bin\links\links.cfg
# Description: Increments the number of hits for the specified link,
# and sends the user off to the appropriate page.
# Author: Alex Krohn
# Email:
alex@gossamer-threads.com
# Web: http://www.gossamer-threads.com/
# Version: 2.01
#
# (c) 1998 Gossamer Threads Inc.
#
# This script is not freeware! Please read the README for full details
# on registration and terms of use.
# =====================================================================
#
# Form Input:
# '$db_key' = key number # Send as form input the key name and key value
# # of the link you want to go to.
#
# Setup:
# Make sure the require statement below points to the config file.


# Required Librariers
# --------------------------------------------------------
eval {
($0 =~ m,(.*)/[^/]+,) && unshift (@INC, "$1"); # Get the script location: UNIX /
($0 =~ m,(.*)\\[^\\]+,) && unshift (@INC, "$1"); # Get the script location: Windows \


require "admin/links.cfg"; # Change this to full path to links.cfg if you have problems.
require "$db_lib_path/db_utils.pl";
require "$db_lib_path/links.def";
};
if ($@) {
print "Content-type: text/plain\n\n";
print "Error including libraries:
$@\n[/url]";
print "Make sure they exist, permissions are set properly, and paths are set correctly.";
}


# ========================================================



And here is my links.cfg:

#!X:\CGYWIN\bin\perl
# -------------
# Links
# -------------
# Links Manager
#
# File: X:\D Sites\www\122wallstreet.com\cgi-bin\links\admin\links.cfg
# Description: Contains all the setup variables.
# Author: Alex Krohn
# Email:
alex@gossamer-threads.com
# Web: http://www.gossamer-threads.com/
# Version: 2.01
#
# (c) 1998 Gossamer Threads Inc.
#
# This script is not freeware! Please read the README for full details
# on registration and terms of use.
# =====================================================================


# Paths and URL's to Important Stuff
# --------------------------------------------------------
# PATH and URL of Admin CGI directory. No Trailing Slash.
$db_script_path = "X:/D Sites/www/122wallstreet.com/cgi-bin/links/admin";
$db_dir_url = "
http://www.122wallstreet.com/cgi-bin/links/admin";

# URL of User CGI directory. No Trailing Slash.
$db_cgi_url = "
http://www.sunsetangel.com/cgi-bin";

# PATH and URL of Pages to be built. No Trailing Slash.
$build_root_path = "X:/D Sites/www/122wallstreet.com/Links";
$build_root_url = "
http://www.122wallstreet.com/Links";

# PATH and URL of What's New page. No Trailing slash.
$build_new_path = "$build_root_path/New";
$build_new_url = "$build_root_url/New";


# PATH and URL of What's Cool page. No Trailing slash.
$build_cool_path = "$build_root_path/Cool";
$build_cool_url = "$build_root_url/Cool";


# PATH and URL of What's Rating page. No Trailing slash.
$build_ratings_path = "$build_root_path/Ratings";
$build_ratings_url = "$build_root_url/Ratings";


# Database Options
# --------------------------------------------------------
# You really need to use flock(). However if your system doesn't support it (Win95),
# then turn this off at your own risk!
$db_use_flock = 1;
# Use Pragma: no-cache to stop browsers from caching output? (0 = cache, 1 = nocache)
$db_nocache = 0;
# Use IIS headers? Set this to 1 if your web server needs the full headers (HTTP/1.0 etc.)
$db_iis = 1;
# Field number of category in category.db
$db_main_category = 1;
# Referers -- which hosts are allowed to add to your database.
@db_referers = ();


# Email Options
# --------------------------------------------------------




I've tried / and \ I've checked and double-checked the paths. I need a fresh pair of eyes to look at this please. I am clueless.
Subject Author Views Date
Thread jump.cgi errors galore - newbie needs help please sunsetangel 6359 Jan 18, 2004, 5:42 PM
Thread Re: [sunsetangel] jump.cgi errors galore - newbie needs help please
Andy 6276 Jan 19, 2004, 6:37 AM
Thread Re: [Andy] jump.cgi errors galore - newbie needs help please
PerlFlunkie 6234 Jan 19, 2004, 9:15 AM
Thread Re: [PerlFlunkie] jump.cgi errors galore - newbie needs help please
Andy 6277 Jan 19, 2004, 9:19 AM
Thread Re: [Andy] jump.cgi errors galore - newbie needs help please
sunsetangel 6248 Jan 19, 2004, 10:29 AM
Thread Re: [sunsetangel] jump.cgi errors galore - newbie needs help please
Andy 6256 Jan 19, 2004, 10:32 AM
Thread Re: [Andy] jump.cgi errors galore - newbie needs help please
sunsetangel 6247 Jan 19, 2004, 10:44 AM
Thread Re: [sunsetangel] jump.cgi errors galore - newbie needs help please
Andy 6286 Jan 19, 2004, 10:48 AM
Thread Re: [Andy] jump.cgi errors galore - newbie needs help please
sunsetangel 6263 Jan 19, 2004, 10:51 AM
Thread Re: [sunsetangel] jump.cgi errors galore - newbie needs help please
sunsetangel 6229 Jan 19, 2004, 11:03 AM
Thread Re: [sunsetangel] jump.cgi errors galore - newbie needs help please
PerlFlunkie 6244 Jan 19, 2004, 11:59 AM
Thread Re: [PerlFlunkie] jump.cgi errors galore - newbie needs help please
Andy 6216 Jan 20, 2004, 1:52 AM
Post Re: [Andy] jump.cgi errors galore - newbie needs help please
PerlFlunkie 6218 Jan 20, 2004, 9:25 AM