Gossamer Forum
Home : Products : Gossamer Links : Development, Plugins and Globals :

Can't use string ("1") as a HASH ref while "strict refs" in use at (eval 27) line 7.

Quote Reply
Can't use string ("1") as a HASH ref while "strict refs" in use at (eval 27) line 7.
Anyone got any ideas why I'm getting this error;

Quote:
Can't use string ("1") as a HASH ref while "strict refs" in use at (eval 27) line 7.


The code is;

Code:
my $tags = shift;
my $CatID = $tags->{ID};

If I comment out the second line, it works fine (well, it doesn't, but I don't get an error).

I'm sure I've had this problem before... but I can't seem to work out how to fix it Frown

Any help is much appreciated.

Cheers

Andy (mod)
andy@ultranerds.co.uk
Want to give me something back for my help? Please see my Amazon Wish List
GLinks ULTRA Package | GLinks ULTRA Package PRO
Links SQL Plugins | Website Design and SEO | UltraNerds | ULTRAGLobals Plugin | Pre-Made Template Sets | FREE GLinks Plugins!
Subject Author Views Date
Thread Can't use string ("1") as a HASH ref while "strict refs" in use at (eval 27) line 7. Andy 1931 Aug 22, 2003, 4:53 AM
Thread Re: [Andy] Can't use string ("1") as a HASH ref while "strict refs" in use at (eval 27) line 7.
yogi 1850 Aug 22, 2003, 8:06 AM
Thread Re: [yogi] Can't use string ("1") as a HASH ref while "strict refs" in use at (eval 27) line 7.
Andy 1850 Aug 22, 2003, 8:11 AM
Thread Re: [Andy] Can't use string ("1") as a HASH ref while "strict refs" in use at (eval 27) line 7.
yogi 1844 Aug 22, 2003, 8:15 AM
Post Re: [yogi] Can't use string ("1") as a HASH ref while "strict refs" in use at (eval 27) line 7.
Andy 1849 Aug 22, 2003, 8:29 AM