Gossamer Forum
Home : Products : Gossamer Forum : Discussion :

Re: [jmar] Problem with Mass Mailer sending email

Quote Reply
Re: [jmar] Problem with Mass Mailer sending email In reply to
In the setup section "Email" mail_path was empty and smtp_server was localhost.

I tried to use mail_path /usr/sbin/sendmail and empty smtp_server.

Than I started a mailing. Now there is the following error:

Code:

Started at Mon Jun 16 17:25:19 2003.

Sending emails ...

A fatal error has occurred:Could not reestablish connection at GT::Mail::BulkMail::_smtp_send line 818.
Please enable debugging in setup for more details.
Stack Trace
======================================
GForum (28098): CGI::Carp::realdie called at /usr/lib/perl5/5.8.0/CGI/Carp.pm line 386 with arguments
(Could not reestablish connection at GT::Mail::BulkMail::_smtp_send line 818.
).
GForum (28098): CGI::Carp::die called at GT::Mail::BulkMail::_smtp_send line 818 with arguments
(Could not reestablish connection).
GForum (28098): GT::Mail::BulkMail::_smtp_send called at /home/xxxx/public_html/forum/gossamer/admin/GT/Mail/BulkMail.pm line 682 with arguments
(GT::Mail::BulkMail=HASH(0x9d5f5a4), test@xxxxx.de, testversuch@xxxxx.de, "test", test test, nur ein test
).
GForum (28098): GT::Mail::BulkMail::_send_one called at GT::Mail::BulkMail::_send_coderef line 624 with arguments
(GT::Mail::BulkMail=HASH(0x9d5f5a4)).
GForum (28098): GT::Mail::BulkMail::_send_coderef called at /home/xxxx/public_html/forum/gossamer/admin/GT/Mail/BulkMail.pm line 600 with arguments
(GT::Mail::BulkMail=HASH(0x9d5f5a4), CODE(0x9d28bdc)).
GForum (28098): GT::Mail::BulkMail::send called at /home/xxxx/public_html/forum/gossamer/admin/nph-email.cgi line 130 with arguments
(GT::Mail::BulkMail=HASH(0x9d5f5a4), CODE(0x9d28bdc)).
GForum (28098): Apache::ROOTforum_2exxxx_2ede::admin::nph_2demail_2ecgi::main called at /home/xxxx/public_html/forum/gossamer/admin/nph-email.cgi line 32 with no arguments.
GForum (28098): Apache::ROOTforum_2exxxx_2ede::admin::nph_2demail_2ecgi::handler called at /usr/lib/perl5/site_perl/5.8.0/i586-linux-thread-multi/Apache/Registry.pm line 149 with arguments
(Apache=SCALAR(0x9d11bdc)).
GForum (28098): (eval) called at /usr/lib/perl5/site_perl/5.8.0/i586-linux-thread-multi/Apache/Registry.pm line 149 with arguments
(Apache=SCALAR(0x9d11bdc)).
GForum (28098): Apache::Registry::handler called at /dev/null line 0 with arguments
(Apache=SCALAR(0x9d11bdc)).
GForum (28098): (eval) called at /dev/null line 0 with arguments
(Apache=SCALAR(0x9d11bdc)).


System Information
======================================
Perl Version: v5.8.0
Gossamer Forum Version: 1.1.8
GForum.pm version: 1.118
GT::SQL Version: 1.099
GT::Template Version: 2.084
DBI.pm Version: 1.32
mod_perl Version: 1.27
@INC =
/home/xxxx/public_html/forum/gossamer/admin
/var/www/perllib
/usr/lib/perl5/5.8.0/i586-linux-thread-multi
/usr/lib/perl5/5.8.0
/usr/lib/perl5/site_perl/5.8.0/i586-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.0
/usr/lib/perl5/site_perl
.
/srv/www/
/srv/www/lib/perl
$!: Broken pipe

CGI INPUT
======================================
emailsto => 3


ENVIRONMENT
======================================
AUTH_TYPE => Basic
DOCUMENT_ROOT => /home/xxxx/public_html/forum/gossamer/
GATEWAY_INTERFACE => CGI-Perl/1.1
GT_TMPDIR => /home/xxxx/public_html/forum/gossamer/admin/tmp
HTTP_ACCEPT => image/gif, image/x-xbitmap, image/jpeg, image/pjpeg, application/vnd.ms-excel, application/vnd.ms-powerpoint, application/msword, */*
HTTP_ACCEPT_ENCODING => gzip, deflate
HTTP_ACCEPT_LANGUAGE => de
HTTP_CONNECTION => Keep-Alive
HTTP_HOST => forum.xxxx.de
HTTP_REFERER => http://forum.xxxx.de/admin/admin.cgi?action=mailings
HTTP_USER_AGENT => Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)
MOD_PERL => mod_perl/1.27
PATH => /sbin:/usr/sbin:/usr/local/sbin:/root/bin:/usr/local/bin:/usr/bin:/usr/X11R6/bin:/bin:/usr/games:/opt/gnome/bin:/opt/kde3/bin:/usr/lib/java/bin
PERL_SEND_HEADER => On
QUERY_STRING => emailsto=3
REMOTE_ADDR => 217.82.xxx.x
REMOTE_PORT => 34xx
REMOTE_USER => jxxx
REQUEST_METHOD => GET
REQUEST_URI => /admin/nph-email.cgi?emailsto=3
SCRIPT_FILENAME => /home/xxxx/public_html/forum/gossamer/admin/nph-email.cgi
SCRIPT_NAME => /admin/nph-email.cgi
SERVER_ADDR => 213.133.xxx.xxx
SERVER_ADMIN => webmaster@linux.local
SERVER_NAME => forum.xxxx.de
SERVER_PORT => 80
SERVER_PROTOCOL => HTTP/1.1
SERVER_SIGNATURE => Apache/1.3.26 Server at forum.xyzasdf.de Port 80

SERVER_SOFTWARE => Apache/1.3.26 (Linux/SuSE) PHP/4.3.1 mod_perl/1.27
UNIQUE_ID => Pu3hX9WFxxx...




OK
The server encountered an internal error or
misconfiguration and was unable to complete
your request.
Please contact the server administrator,
webmaster@linux.local and inform them of the time the error occurred,
and anything you might have done that may have
caused the error.
More information about this error may be available
in the server error log.



???
Subject Author Views Date
Thread Problem with Mass Mailer sending email jmar 3037 Jun 6, 2003, 7:43 AM
Post Re: [jmar] Problem with Mass Mailer sending email
jmar 2971 Jun 9, 2003, 2:36 PM
Post Re: [jmar] Problem with Mass Mailer sending email
jmar 2917 Jun 16, 2003, 2:40 AM
Thread Re: [jmar] Problem with Mass Mailer sending email
jmar 2916 Jun 16, 2003, 8:57 AM
Thread Re: [jmar] Problem with Mass Mailer sending email
Jagerman 2905 Jun 17, 2003, 1:21 PM
Post Re: [Jagerman] Problem with Mass Mailer sending email
jmar 2888 Jun 18, 2003, 8:31 AM