Gossamer Forum
Home : Products : Gossamer Links : Development, Plugins and Globals :

add.cgi problem (link not added to catlinks table)

Quote Reply
add.cgi problem (link not added to catlinks table)
I'm almost sure it is not bug, because many of you are using LSQL link add without problems... But something is strange.
My problem is, that I add a link to the DB, it is not added to the catlinks table.

Could somebody tell me, where & how the link is added to catlinks table?

I feel something is wrong... When I add a link to the DB, it is not added to the catlinks table (LSQL v2.1.1).

In Add.pm/add_link function:
Code:
# Validate the form input..
my $db = $DB->table ('Links');
my $cdb = $DB->table ('Category');
my $cat_links = $DB->table ('CatLinks');
$db is used. $cdb is used.
BUT $cat_links is never used!

There should be a line in Add.pm/add_link function, similar to this:
$CatLinks->insert({ LinkID => $link_id, CategoryID => $cat_id });

But there is not. Shocked
Anybody knows or has idea, where the link category id is added to the 'CatLinks' table? (within Add.pm)

Best regards,
Webmaster33


Paid Support
from Webmaster33. Expert in Perl programming & Gossamer Threads applications. (click here for prices)
Webmaster33's products (upd.2004.09.26) | Private message | Contact me | Was my post helpful? Donate my help...
Subject Author Views Date
Thread add.cgi problem (link not added to catlinks table) webmaster33 2091 Aug 22, 2002, 7:00 AM
Thread Re: [webmaster33] add.cgi problem (link not added to catlinks table)
yogi 1946 Aug 22, 2002, 7:05 AM
Post Re: [yogi] add.cgi problem (link not added to catlinks table)
webmaster33 1943 Aug 22, 2002, 7:19 AM