Gossamer Forum
Home : Products : Gossamer Links : Discussions :

page.cgi Bug Report - Fix Anyone?

Quote Reply
page.cgi Bug Report - Fix Anyone?
hiya,

if you call page.cgi with:

page.cgi?p=template-that-doesnt-exist

it causes a fatal error.

can anyone supply a fix (posted here) that will stop the error happening? What I imagine is that if it's called with a p templtate name that doesn't exist it defaults to the error page.

Just so you know, what I'm doing is calling some additional information pages (templates) through the page.cgi script, so to get them I'm doing page.cgi?p=infopage - as an example. So it would need to default to the error page rather than just present the home page.

cheers,

regan.

Last edited by:

ryel01: Jul 25, 2002, 2:57 AM
Subject Author Views Date
Thread; hot thread page.cgi Bug Report - Fix Anyone? ryel01 3549 Jul 25, 2002, 2:55 AM
Thread; hot thread Re: [ryel01] page.cgi Bug Report - Fix Anyone?
yogi 3474 Jul 25, 2002, 3:03 AM
Thread; hot thread Re: [yogi] page.cgi Bug Report - Fix Anyone?
pugdog 3449 Jul 25, 2002, 4:38 AM
Thread; hot thread Re: [pugdog] page.cgi Bug Report - Fix Anyone?
yogi 3489 Jul 25, 2002, 4:42 AM
Thread; hot thread Re: [yogi] page.cgi Bug Report - Fix Anyone?
, 3474 Jul 25, 2002, 5:32 AM
Thread; hot thread Re: [TLA] page.cgi Bug Report - Fix Anyone?
Paul 3521 Jul 25, 2002, 5:34 AM
Post; hot thread Re: [Paul] page.cgi Bug Report - Fix Anyone?
, 3435 Jul 25, 2002, 6:22 AM
Thread; hot thread Re: [TLA] page.cgi Bug Report - Fix Anyone?
yogi 3451 Jul 25, 2002, 5:34 AM
Thread; hot thread Re: [yogi] page.cgi Bug Report - Fix Anyone?
, 3482 Jul 25, 2002, 6:21 AM
Post; hot thread Re: [TLA] page.cgi Bug Report - Fix Anyone?
pugdog 3451 Jul 25, 2002, 6:23 AM
Post; hot thread Re: [TLA] page.cgi Bug Report - Fix Anyone?
yogi 3493 Jul 25, 2002, 6:26 AM
Thread; hot thread Re: [pugdog] page.cgi Bug Report - Fix Anyone?
Paul 3509 Jul 25, 2002, 4:50 AM
Thread; hot thread Re: [Paul] page.cgi Bug Report - Fix Anyone?
pugdog 3484 Jul 25, 2002, 5:05 AM
Post; hot thread Re: [pugdog] page.cgi Bug Report - Fix Anyone?
Paul 3479 Jul 25, 2002, 5:07 AM