Gossamer Forum
Home : Products : DBMan : Discussions :

Form Submit Problem Inside *.pl

Quote Reply
Form Submit Problem Inside *.pl
I am trying to do something that I think should work but it doesn't seem to. I have added to the sub html_record_long section a form button to send the Address and Zip code to Mapblast so the user can get directions.

<TR><TD ALIGN="Left" VALIGN="CENTER"><$font_color>Driving Directions:</FONT></TD>
<TD><FORM name=mapbl method=get action="http://www.mapblast.com/mblast/map.mb" target="_blank">
<input type="hidden" name="AD2" value="$rec('Address')">
<input type="hidden" name="AD3" value="$rec('Zip')">
<INPUT type=hidden name="loc" value="us">
<INPUT type=hidden name="worldres" value=>
<INPUT type=hidden name="CMD" value="GEO">
<input type="submit" value="Map It!"></TD></TR>

The Submit or Map It! button appears in the form, is clickable and works however the data from $rec('Address') and $rec('Zip') is not being written in. When the MapBlast Page comes up it shows in the Street Address field as ('Address') and in the Zip Code Field ('Zip). Is what I am trying to do possible? In the above code I realize the form tag is not closed and in theory is shouldn't work but it does. The same thing happens whether it is closed or not. Actually with the form tag closed the button is offset top right inside the table.

Any help would be appriciated. It is probably something simple I am missing cause I have been working at this to long.

L. Bishop
Subject Author Views Date
Thread Form Submit Problem Inside *.pl lab99 3939 Jun 27, 2002, 5:46 PM
Thread Re: [lab99] Form Submit Problem Inside *.pl
Watts 3894 Jun 27, 2002, 6:21 PM
Post Re: [Watts] Form Submit Problem Inside *.pl
lab99 3868 Jun 28, 2002, 11:42 AM
Thread Re: [lab99] Form Submit Problem Inside *.pl
LoisC 3884 Jun 28, 2002, 12:47 AM
Post Re: [LoisC] Form Submit Problem Inside *.pl
Paul 3875 Jun 28, 2002, 2:13 AM