Gossamer Forum
Home : Products : Gossamer Forum : Development, Plugins and Globals :

Re: [backdream] [bug]debug_level set to 1

Quote Reply
Re: [backdream] [bug]debug_level set to 1 In reply to
When use IIS + Perl 5.6.1 :

It show some confused code like this:

from GForum::Post::Write::post at d:/sxforum/admin/GForum/Post/Write.pm line 630
GT::SQL::Table (1556): Creating new GT::SQL::Tree object for table sxforum_Category at GT::SQL::Table::tree line 1476.
GT::SQL::Driver::MYSQL::sth (1556): Executing query: SELECT cat_id,cat_name FROM sxforum_Category WHERE ( cat_id = 1 ) from GForum::Category::_full_name_cache at d:/sxforum/admin/GForum/Category.pm line 141
GT::SQL::Driver::MYSQL::sth (1556): Executing query:
SELECT sxforum_Category.cat_id, sxforum_Category.cat_name, sxforum_Category_tree.tree_id_fk, sxforum_Category.cat_depth
FROM sxforum_Category, sxforum_Category_tree
WHERE sxforum_Category_tree.tree_anc_id_fk = sxforum_Category.cat_id AND (sxforum_Category_tree.tree_id_fk = '1')

from GForum::Category::_full_name_cache at d:/sxforum/admin/GForum/Category.pm line 143
GT::SQL::Driver::MYSQL::sth (1556): Executing query: SELECT post_id FROM sxforum_Post WHERE post_unique_id = 'efce6048a3808c6f144f229e9ae62112' from GForum::Post::Write::post at d:/sxforum/admin/GForum/Post/Write.pm line 682
GForum::Table::Post (1556): Creating new GT::SQL::Tree object for table sxforum_Post at GT::SQL::Table::tree line 1476.
GT::SQL::Driver::MYSQL::sth (1556): Executing query: INSERT INTO sxforum_Post (post_last_edit_time,post_time,post_anonymous_email,post_unique_id,forum_id_fk,post_reply_notify,post_depth,user_id_fk,post_ip,post_message,post_latest_poster,post_father_id,post_subject,post_icon,post_last_edit_username,post_locked,post_root_id,post_style,post_latest_reply,post_username,post_id) VALUES (NULL,1025075402,NULL,'efce6048a3808c6f144f229e9ae62112',2,0,0,2,'86.0.191.9','xixi
','λ',0,'xixi',NULL,NULL,0,0,1,974924598,'λ',NULL) from GForum::Table::Post::_plg_insert at GForum::Table::Post::_plg_insert line 60
GT::SQL::Driver::MYSQL::sth (1556): Executing query: SELECT COUNT(*) FROM sxforum_PostView WHERE post_id_fk = 2432 from GForum::Table::Post::_plg_insert at GForum::Table::Post::_plg_insert line 71
GT::SQL::Driver::MYSQL::sth (1556): Executing query: INSERT INTO sxforum_PostView (post_views,post_thread_views,post_id_fk) VALUES (0,0,2432) from GForum::Table::Post::_plg_insert at GForum::Table::Post::_plg_insert line 71
GT::SQL::Driver::MYSQL::sth (1556): Executing query: SELECT COUNT(*) FROM sxforum_Post WHERE forum_id_fk = 2 from GForum::Table::Forum::rebuild at GForum::Table::Forum::rebuild line 247
GT::SQL::Driver::MYSQL::sth (1556): Executing query: SELECT COUNT(*) FROM sxforum_Post WHERE forum_id_fk = 2 AND post_root_id = 0 from GForum::Table::Forum::rebuild at GForum::Table::Content-type: text/html



<p><font face='Tahoma,Arial,Helvetica' size=2>A fatal error has occurred:</font></p><blockquote><pre>Failed to execute query: 'UPDATE sxforum_Post SET WHERE post_id = ?' Reason: You have an error in your SQL syntax near 'WHERE post_id = '2432'' at line 1 at d:/sxforum/admin/Plugins/GForum/Poll.pm line 135.
</pre></blockquote><p><font face='Tahoma,Arial,Helvetica' size=2>Please enable debugging in setup for more details.</font></p>
<pre><b>Stack Trace</b>
======================================
GForum (1556): Plugins::GForum::Poll::post_post called at d:/sxforum/admin/GT/Plugins.pm line 118 with arguments
&nbsp; &nbsp; (post_post.html, HASH(0x204e510)).
GForum (1556): GT::Plugins::dispatch called at d:/sxforum/admin/GForum.pm line 241 with arguments
&nbsp; &nbsp; (GT::Plugins, d:/sxforum/admin/Plugins/GForum, do_post_post, CODE(0x1ab42fc), post_post).
GForum (1556): GForum::_plg_do_func called at d:/sxforum/admin/GForum.pm line 232 with arguments
&nbsp; &nbsp; (post_post).
GForum (1556): GForum::__ANON__ called at d:/sxforum/admin/GT/Plugins.pm line 108 with arguments
&nbsp; &nbsp; (post_post).
GForum (1556): GT::Plugins::dispatch called at d:/sxforum/admin/GForum.pm line 232 with arguments
&nbsp; &nbsp; (GT::Plugins, d:/sxforum/admin/Plugins/GForum, do_func, CODE(0x1ab4110), post_post).
GForum (1556): GForum::do_func called at D:\sxforum\gforum.cgi line 106 with arguments
&nbsp; &nbsp; (post_post).
GForum (1556): main::main called at d:/sxforum/admin/GT/Plugins.pm line 108 with no arguments.
GForum (1556): GT::Plugins::dispatch called at D:\sxforum\gforum.cgi line 22 with arguments
&nbsp; &nbsp; (GT::Plugins, d:/sxforum/admin/Plugins/GForum, main, CODE(0x23e238c)).


<b>System Information</b>
======================================
Perl Version: v5.6.1
Gossamer Forum Version: 1.1.6
GForum.pm version: 1.116
GT::SQL Version: 1.099
GT::Template Version: 2.078
DBI.pm Version: 1.15
@INC =
d:/sxforum/admin
D:/Perl/lib
D:/Perl/site/lib
.
GT::SQL::error = Failed to execute query: 'UPDATE sxforum_Post SET WHERE post_id = ?' Reason: You have an error in your SQL syntax near 'WHERE post_id = '2432'' at line 1

<b>CGI INPUT</b>
======================================
advanced_editor => 1
do => post_post
do=post_post =>
forum => 2
forum_id => 2
num_poll_answers => 5
poll => write
poll_answer_answer_1 => hehe
poll_answer_answer_2 => haha
poll_answer_answer_3 =>
poll_answer_answer_4 =>
poll_answer_answer_5 =>
poll_answer_votes_1 => 0
poll_answer_votes_2 => 0
poll_answer_votes_3 => 0
poll_answer_votes_4 => 0
poll_answer_votes_5 => 0
post_append_signature => 1
post_attachment =>
post_icon =>
post_message => xixi
post_message_html =>
post_style => 1
post_subject => xixi
temp_id => efce6048a3808c6f144f229e9ae62112


<b>CGI Cookies</b>
======================================
gforum_1006370746_session => 491fa53d67bfccfe50a9806ea2eb251c
gforum_1022870964_remember => b17dab5975cff63630a1630b771c2c79
sxforum_session => 52d6730042665d563c4b6da87016bebe


<b>ENVIRONMENT</b>
======================================
ALLUSERSPROFILE => C:\Documents and Settings\All Users
COMMONPROGRAMFILES => C:\Program Files\Common Files
COMPUTERNAME => SA-LIU
COMSPEC => C:\WINNT\system32\cmd.exe
CONTENT_LENGTH => 2638
CONTENT_TYPE => multipart/form-data; boundary=---------------------------7d2801100250
GATEWAY_INTERFACE => CGI/1.1
GT_TMPDIR => d:/sxforum/admin/tmp
HOME => D:\
HTTPS => off
HTTP_ACCEPT => image/gif, image/x-xbitmap, image/jpeg, image/pjpeg, application/vnd.ms-excel, application/vnd.ms-powerpoint, application/msword, */*
HTTP_ACCEPT_ENCODING => gzip, deflate
HTTP_ACCEPT_LANGUAGE => zh-cn
HTTP_CACHE_CONTROL => no-cache
HTTP_CONNECTION => Keep-Alive
HTTP_CONTENT_LENGTH => 2638
HTTP_CONTENT_TYPE => multipart/form-data; boundary=---------------------------7d2801100250
HTTP_COOKIE => gforum_1022870964_remember=b17dab5975cff63630a1630b771c2c79; gforum_1006370746_session=491fa53d67bfccfe50a9806ea2eb251c; sxforum_session=52d6730042665d563c4b6da87016bebe
HTTP_HOST => 86.0.191.9:88
HTTP_REFEForum::rebuild line 248
GT::SQL::Driver::MYSQL::sth (1556): Executing query: SELECT post_id,post_username,post_time FROM sxforum_Post WHERE forum_id_fk = 2
ORDER BY post_time DESC
LIMIT 1 from GForum::Table::Forum::rebuild at GForum::Table::Forum::rebuild line 251
GT::SQL::Driver::MYSQL::sth (1556): Executing query: UPDATE sxforum_Forum SET forum_total_threads = 52 , forum_last_poster = 'λ' , forum_last = 1025075402 , forum_total = 197 , forum_last_id = 2432 WHERE forum_id = 2 from GForum::Table::Forum::rebuild at GForum::Table::Forum::rebuild line 252
GT::SQL::Driver::MYSQL::sth (1556): Executing query: SELECT user_id,user_username,user_posts FROM sxforum_User WHERE user_id = 2 from GForum::Table::User::_plg_update at d:/sxforum/admin/GForum/Table/User.pm line 349
GT::SQL::Driver::MYSQL::sth (1556): Executing query: UPDATE sxforum_User SET user_posts = user_posts + 1 WHERE user_id = 2 from GForum::Table::User::_plg_update at d:/sxforum/admin/GForum/Table/User.pm line 349
GT::SQL::Driver::MYSQL::sth (1556): Executing query: SELECT tempatt_id FROM sxforum_TempAttachment WHERE tempatt_msg_id = 'efce6048a3808c6f144f229e9ae62112' from GForum::Post::Write::post at d:/sxforum/admin/GForum/Post/Write.pm line 722
GT::SQL::Driver::MYSQL::sth (1556): Executing query: SELECT COUNT(*) FROM sxforum_Post WHERE post_unique_id IS NULL from Plugins::GForum::Poll::post_post at d:/sxforum/admin/Plugins/GForum/Poll.pm line 95
GT::SQL::Driver::MYSQL::sth (1556): Executing query: INSERT INTO sxforum_Poll (poll_question,poll_votes,forum_id_fk,poll_type,poll_enabled,post_id_fk,poll_id) VALUES ('xixi',0,2,0,1,2432,NULL) from Plugins::GForum::Poll::post_post at d:/sxforum/admin/Plugins/GForum/Poll.pm line 115
GT::SQL::Driver::MYSQL::sth (1556): Executing query: INSERT INTO sxforum_PollAnswer (poll_answer_answer,poll_id_fk,poll_answer_votes,post_id_fk,poll_answer_id) VALUES ('hehe',25,0,2432,NULL) from Plugins::GForum::Poll::post_post at d:/sxforum/admin/Plugins/GForum/Poll.pm line 129
GT::SQL::Driver::MYSQL::sth (1556): Executing query: INSERT INTO sxforum_PollAnswer (poll_answer_answer,poll_id_fk,poll_answer_votes,post_id_fk,poll_answer_id) VALUES ('haha',25,0,2432,NULL) from Plugins::GForum::Poll::post_post at d:/sxforum/admin/Plugins/GForum/Poll.pm line 129
GForum::Table::Post (1556): Returning GT::SQL::Tree object for table sxforum_Post from cache at GT::SQL::Table::tree line 1471.
GT::SQL::Driver::MYSQL::sth (1556): Executing query: UPDATE sxforum_Post SET WHERE post_id = 2432 from GForum::Table::Post::_plg_update at GForum::Table::Post::_plg_update line 137
GT::SQL::Table (1556): Failed to execute query: 'UPDATE sxforum_Post SET WHERE post_id = ?' Reason: You have an error in your SQL syntax near 'WHERE post_id = '2432'' at line 1 at d:/sxforum/admin/GT/SQL/Driver/MYSQL.pm line 117.
Failed to execute query: 'UPDATE sxforum_Post SET WHERE post_id = ?' Reason: You have an error in your SQL syntax near 'WHERE post_id = '2432'' at line 1 at d:/sxforum/admin/Plugins/GForum/Poll.pm line 135.
RER => http://86.0.191.9:88/...F0%D0%C2%B5%F7%B2%E9
HTTP_USER_AGENT => Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)
INSTANCE_ID => 1
LOCAL_ADDR => 86.0.191.9
NUMBER_OF_PROCESSORS => 1
OS => Windows_NT
OS2LIBPATH => C:\WINNT\system32\os2\dll;
PATH => D:\Perl\bin\;d:\perl;d:\apache;C:\WINNT\system32;C:\WINNT;C:\WINNT\System32\Wbem
PATHEXT => .COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH
PATH_INFO => /gforum.cgi
PATH_TRANSLATED => D:\sxforum\gforum.cgi
PROCESSOR_ARCHITECTURE => x86
PROCESSOR_IDENTIFIER => x86 Family 6 Model 7 Stepping 3, GenuineIntel
PROCESSOR_LEVEL => 6
PROCESSOR_REVISION => 0703
PROGRAMFILES => C:\Program Files
REMOTE_ADDR => 86.0.191.9
REMOTE_HOST => 86.0.191.9
REQUEST_METHOD => POST
SCRIPT_NAME => /gforum.cgi
SERVER_NAME => 86.0.191.9
SERVER_PORT => 88
SERVER_PORT_SECURE => 0
SERVER_PROTOCOL => HTTP/1.1
SERVER_SOFTWARE => Microsoft-IIS/5.0
SYSTEMDRIVE => C:
SYSTEMROOT => C:\WINNT
TEMP => e:\Temp
TERM => dumb
TMP => e:\Temp
USERPROFILE => C:\Documents and Settings\Default User
WINDIR => C:\WINNT
</pre>

Last edited by:

backdream: Jun 26, 2002, 2:34 AM
Subject Author Views Date
Thread [bug]debug_level set to 1 backdream 4017 Jun 25, 2002, 5:03 PM
Post Re: [backdream] [bug]debug_level set to 1
backdream 3887 Jun 26, 2002, 2:32 AM
Thread Re: [backdream] [bug]debug_level set to 1
backdream 3922 Jun 26, 2002, 2:33 AM
Thread Re: [backdream] [bug]debug_level set to 1
Jagerman 3894 Jun 26, 2002, 5:53 PM
Post Re: [Jagerman] [bug]debug_level set to 1
yogi 3882 Jun 26, 2002, 10:06 PM
Post Re: [Jagerman] [bug]debug_level set to 1
backdream 3854 Jul 3, 2002, 5:31 PM