Gossamer Forum
Home : Products : Gossamer Mail : Discussion :

[BUG REPORT - 2.1.0] ?? Incoming.pl does not work! U R G E N T ! ! !

Quote Reply
[BUG REPORT - 2.1.0] ?? Incoming.pl does not work! U R G E N T ! ! !
Hello!

After upgrading from 2.0.2 ? 2.1.0, the incoming.pl did not work. Checked the forum and upgraded the script version 1.59 to 1.61! (Is this the latest?)

The following error:

Code:
GMail (71215): Parsing the header of message number 1. at incoming.pl line 483.
GT::Mail::POP3 (71215): Getting head of message 1 ... at /email/admin/GT/Mail/POP3.pm line 392.
GT::Mail::POP3 (71215): --? TOP 1 0 at /email/admin/GT/Mail/POP3.pm line 152.
GT::Mail::POP3 (71215): ?-- +OK at /email/admin/GT/Mail/POP3.pm line 178.
GT::Mail::POP3 (71215): Top of message 1 retrieved. at /email/admin/GT/Mail/POP3.pm line 407.
GT::SQL::Driver::MYSQL::sth (71215): Executing query: SELECT password FROM email_users WHERE email = 'com-user@domain.com' at /email/admin/GT/SQL/Driver/MYSQL.pm line 114.
GT::SQL::Driver::MYSQL::sth (71215): Executing query: SELECT password FROM email_users WHERE email = 'user@domain.com' at /email/admin/GT/SQL/Driver/MYSQL.pm line 114.
GMail (71215): Looking at (user@domain.com) from the 'To' line at incoming.pl line 609.
GT::SQL::Driver::MYSQL::sth (71215): Executing query: SELECT * FROM email_users WHERE email = 'user@domain.com' at /email/admin/GT/SQL/Driver/MYSQL.pm line 114.
GT::SQL::Driver::MYSQL::sth (71215): Executing query: SELECT * FROM email_dgraph WHERE ( dgraph_userid = 007 ) at /email/admin/GT/SQL/Driver/MYSQL.pm line 114.
GT::SQL::Driver::MYSQL::sth (71215): Executing query: SELECT COUNT(*) FROM email_dgraph WHERE dgraph_userid = 007 at /email/admin/GT/SQL/Driver/MYSQL.pm line 114.
GT::SQL::Driver::MYSQL::sth (71215): Executing query: SELECT COUNT(*) FROM email_dgraph WHERE dgraph_email IS NULL at /email/admin/GT/SQL/Driver/MYSQL.pm line 114.
GT::SQL::Driver::MYSQL::sth (71215): Executing query: SELECT COUNT(*) FROM email_dgraph WHERE dgraph_userid = 007 at /email/admin/GT/SQL/Driver/MYSQL.pm line 114.
GT::SQL::Driver::MYSQL::sth (71215): Executing query: INSERT INTO email_dgraph (dgraph_userid) VALUES (007) at /email/admin/GT/SQL/Driver/MYSQL.pm line 114.
DBD::mysql::st execute failed: Duplicate entry '' for key 2 at /email/admin/GT/SQL/Driver/MYSQL.pm line 117.
GT::Mail::POP3 (71215): --? QUIT at /email/admin/GT/Mail/POP3.pm line 152.
GT::Mail::POP3 (71215): ?-- +OK at /email/admin/GT/Mail/POP3.pm line 178.

Note that earlier it had ?user@domain.com?! But after the upgrade it produces ?com-user@domain.com?!!! This is ofcourse because Adrian added

my $m = $POP-?parse_message($num);

but what I do not understand is where does com- gets added?

Last edited by:

rajani: Jun 25, 2002, 12:47 PM
Subject Author Views Date
Thread [BUG REPORT - 2.1.0] ?? Incoming.pl does not work! U R G E N T ! ! ! dearnet 2942 Jun 25, 2002, 12:45 PM
Thread Re: [rajani] [BUG REPORT - 2.1.0] ?? Incoming.pl does not work! U R G E N T ! ! !
brewt 2867 Jun 25, 2002, 2:32 PM
Thread Re: [brewt] [BUG REPORT - 2.1.0] ?? Incoming.pl does not work! U R G E N T ! ! !
dearnet 2860 Jun 25, 2002, 2:56 PM
Thread Re: [rajani] [BUG REPORT - 2.1.0] ?? Incoming.pl does not work! U R G E N T ! ! !
brewt 2837 Jun 25, 2002, 9:28 PM
Post Re: [brewt] [BUG REPORT - 2.1.0] ?? Incoming.pl does not work! U R G E N T ! ! !
dearnet 2822 Jun 27, 2002, 6:49 AM
Post Re: [brewt] [BUG REPORT - 2.1.0] ?? Incoming.pl does not work! U R G E N T ! ! !
dearnet 2804 Jun 27, 2002, 11:01 AM
Post Re: [brewt] [BUG REPORT - 2.1.0] ?? Incoming.pl does not work! U R G E N T ! ! !
dearnet 2791 Jul 8, 2002, 8:16 AM
Post Re: [brewt] [BUG REPORT - 2.1.0] ?? Incoming.pl does not work! U R G E N T ! ! !
dearnet 2827 Jun 25, 2002, 2:58 PM
Thread Re: [brewt] [BUG REPORT - 2.1.0] ?? Incoming.pl does not work! U R G E N T ! ! !
dearnet 2861 Jun 25, 2002, 3:19 PM
Thread Re: [rajani] [BUG REPORT - 2.1.0] ?? Incoming.pl does not work! U R G E N T ! ! !
brewt 2852 Jun 25, 2002, 9:22 PM
Post Re: [brewt] [BUG REPORT - 2.1.0] ?? Incoming.pl does not work! U R G E N T ! ! !
dearnet 2814 Jun 27, 2002, 6:40 AM
Post Re: [brewt] [BUG REPORT - 2.1.0] ?? Incoming.pl does not work! U R G E N T ! ! !
dearnet 2801 Jul 8, 2002, 9:01 AM