Gossamer Forum
Home : Products : Others : Fileman :

Re: [sven h] error when uploading

Quote Reply
Re: [sven h] error when uploading In reply to
I seem to remember that some people had a problem with version 1 where if there wasn't enough space for CGI.pm to make a tmp file, they would get a 0 byte upload. Version 2 uses GT::CGI and GT::TempFile so this might not be the problem but here is a snippit of the POD for GT::TempFile:

Quote:
TempFile borrows heavily from the tempfile used in CGI.pm.

TempFile picks a temp directory based on the following:

1. ENV{GT_TMPDIR}
2. ~/tmp
3. ENV{TMPDIR}, ENV{TEMP}, ENV{TMP}
4. /usr/tmp, /var/tmp, c:/temp, /tmp, /temp,
/WWW_ROOT, c:/windows/temp, c:/winnt/temp

I would start by checking the disk usage in the directories listed above. To find out what ENV{GT_TMPDIR} is, open your ConfigData.pm file and look for 'CGI_path' => '/path/to/www/cgi-bin/fileman' and add a /tmp to it. It woud be something like /path/to/www/cgi-bin/fileman/tmp.

This is a real shot in the dark but it's the only thing I can come up with.

Regards,
Charlie
Subject Author Views Date
Thread error when uploading sven h 4052 Nov 7, 2001, 5:02 AM
Thread Re: [sven h] error when uploading
Wil 3987 Nov 7, 2001, 6:38 AM
Thread Re: [Wil] error when uploading
sven h 3977 Nov 7, 2001, 8:05 AM
Thread Re: [sven h] error when uploading
604 3996 Nov 7, 2001, 9:34 AM
Post Re: [TheStone] error when uploading
sven h 3969 Nov 7, 2001, 9:40 AM
Thread Re: [sven h] error when uploading
Chaz 3944 Nov 7, 2001, 10:35 AM
Thread Re: [CP] error when uploading
sven h 3944 Nov 7, 2001, 10:51 AM
Thread Re: [sven h] error when uploading
Chaz 3930 Nov 7, 2001, 11:43 AM
Post Re: [CP] error when uploading
sven h 3945 Nov 7, 2001, 11:54 AM