Gossamer Forum
Home : Products : Gossamer Links : Version 1.x :

SMTP Error: transmission of message failed

Quote Reply
SMTP Error: transmission of message failed
I have not come across this error after using LINKS SQL v.1.X for the past ten months:

In Reply To:

SMTP: Transmission of message failed. at /path/to/www/bin/admin/AG/HTML_Templates.pm line 2482.


This is line 2482 in HTML_Templates.pm:

In Reply To:

$mailer->send or die $AG::Mailer::error;


The complete SEND EMAIL ERROR sub in the HTML_Templates file looks like the following:

Code:

sub send_error {
#------------------------------------------------------
# Sends email message to Administrator

# Check to make sure that there is an admin email address defined.
$AG{db_admin_email} or die ("Admin Email Address Not Defined in config file!");
my ($in) = @_;
my ($to, $from, $subject, $msg, $mailer);
my %in = %{$in};
my $remote_address = $ENV{'REMOTE_ADDR'};
my $check_host = scalar(gethostbyaddr(inet_aton($remote_address), AF_INET));
my $shortdom = scalar(gethostbyaddr(inet_aton($remote_address), AF_INET));
$shortdom = $1 if ($shortdom =~ /.*\.([^.]*\.[^.]*)/);
my $check_sd = qq|$shortdom|;
$to = $AG{db_admin_email};
$from = $AG{db_support_email};
$subject = "Alert! Error Encountered!\n";
$msg = qq|Alert! The following error has occurred:

==================================================
Error: $in{'error'}
Script Name: $ENV{'SCRIPT_NAME'}
==================================================

ENVIRONMENTAL VARIABLES
==================================================
Referring Page: $ENV{'HTTP_REFERER'}
Domain: $check_sd
Remote Host: $check_host
Remote Address: $remote_address
==================================================

Sincerely,
Automated AG Alert Manager
|;

# Then mail it away!
require AG::Mailer;
$mailer = new AG::Mailer ( {
smtp => $AG{db_smtp_server},
sendmail => $AG{db_mail_path},
from => $from,
subject => $subject,
to => $to,
msg => $msg
} ) or die $AG::Mailer::error;
$mailer->send or die $AG::Mailer::error;
}


The subroutine call in the CGI script looks like the following:

In Reply To:

&AG::HTML_Templates::send_error ({error => "Unknown Review ID: $id"}, $in);


To see an example of this ERROR, go to:

http://anthro-globe.com/...etail.cgi?ID=1939349

Keep in mind that I have re-named Links folder to AG.

The exact same codes work just fine on two other UNIX servers. The server where this problem is occurring is a Linux:RedHat, using SMTP rather than SENDMAIL.

Thanks in advance for any direction or suggestions you can give...thanks!

Regards,

Eliot Lee
Subject Author Views Date
Thread SMTP Error: transmission of message failed Stealth 3017 Jun 13, 2001, 5:49 PM
Thread Re: SMTP Error: transmission of message failed
Alex 2957 Jun 14, 2001, 6:32 PM
Thread Re: SMTP Error: transmission of message failed
Stealth 2930 Jun 14, 2001, 7:45 PM
Post Re: SMTP Error: transmission of message failed
Stealth 2907 Jun 23, 2001, 7:56 PM