Gossamer Forum
Home : Products : Links 2.0 : Installation -- Unix :

nph-build fails on New

Quote Reply
nph-build fails on New
I have looked for the answer to this question on the forum, but can't find it. I am not very familiar with scripts and I apoligize in advance if a similar problem has been covered elsewhere.

I have been running nph-build.cgi from telenet and it has been working fine. Last weekend my web host did some "upgrading" of the server and now the nph-build.cgi file runs until it trys to build the new.shtml file in the New directory, resulting in an error message saying Permission Denied. The chmod on the New directory is 777 and on the index.shtml file is 777. The .cgi files are 755.

I have asked the web host what "upgrade" they did on the server, but cannot get an answer. I suspect that they installed a newer version of Perl.

Here is the message I get:

Error Message : unable to open what's new page: /usr/home27/amenkart/publi
c_html/New/index.shtml. Reason: Permission denied
Script Location : nph-build.cgi
Perl Version : 5.00503

Form Variables
-------------------------------------------

Environment Variables
-------------------------------------------
BLOCKSIZE : K
EDITOR : vi
HOME : /usr/home27/amenkart
LOGNAME : amenkart
MAIL : /var/mail/amenkart
MANPATH : /usr/share/man:/usr/X11R6/man:/usr/local/man
PAGER : more
PATH : /sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/bin:/u
sr/X11R6/bin:/usr/home27/amenkart/bin:/usr/local/java/bin
PWD : /usr/home27/amenkart/public_html/cgi-bin/links/admin
SHELL : /bin/csh
TERM : ansi
USER : amenkart

</PRE>%

Any help would be appreciated.

Regards,
Andrew

Subject Author Views Date
Thread nph-build fails on New amenkart 2055 Feb 12, 2001, 9:00 PM
Thread Re: nph-build fails on New
Nicky 2008 Feb 13, 2001, 4:10 AM
Thread Re: nph-build fails on New
amenkart 1992 Feb 13, 2001, 9:10 AM
Thread Re: nph-build fails on New
Nicky 1988 Feb 14, 2001, 12:57 PM
Post Re: nph-build fails on New
amenkart 1965 Feb 14, 2001, 7:43 PM