Gossamer Forum
Home : Products : Links 2.0 : Installation -- Windows :

Solution for Win2000 and IIS 5.0 and Active Perl

Quote Reply
Solution for Win2000 and IIS 5.0 and Active Perl
Hi,

I managed to install links 2.0 on a windows 2000 server running IIS 5.0 and ActivePerl. What a huge head ache it was.
Before I begin I should say, if you have the option to intall on a UNIX machine you will save yourself hours.

Here is what I did to make it work, (I hope I don't leave anything out) I used a search and replace program to do all the changes below, otherwise it would be impossible. I used BBedit on the mac.

- I found another program that was running perl on the server and simply copied that path to perl and added it in all the files. I used "#!c:\program files\perl\bin\perl.exe"

- i renamed all the files that were .cgi to .pl so that active perl could read them properly. i don't know why this works, but it does. i also had to do a huge search and replace in all the code to change every occurance of .cgi to .pl

- I changed the link.cfg file accordingly and had to use double back slashes becuase perl thinks you are excaping the character. Now maybe there is a way to turn this off in Perl but I don't have access to the server. here is what I used: "D:\\mysite\\cgi-bin\\links\\admin" for the $db_script_path.

- keeping with this idea i had to change every single hard reference to the path to \\ instead of /. There were over 200+ changes in multiple files. For example, "$db_script_path/data/links.db" had to change to "$db_script_path\\data\\links.db".

- Everything seemed to work at that point except builds would stall at what's new. So I manually created the New, Cool and Ratings directory in the pages directery. Then I commented out (by adding a #) this code in each of the new, cool and ratings subroutines:
if ($build_new_path =~ m,^$build_root_path\\(.*)$,) {
&build_dir ($1);
}

- i am still having some problems with deleting files but I think changing the permissions might help. Otherwise links works like a charm.

Best of luch to you all.

By the way, never use the installers dotmatrix.

-Deryk (the hard way)

Subject Author Views Date
Thread Solution for Win2000 and IIS 5.0 and Active Perl dwenaus 4255 Oct 12, 2000, 4:30 PM
Thread Re: Solution for Win2000 and IIS 5.0 and Active Perl
dwenaus 4062 Oct 12, 2000, 5:09 PM
Post Re: Solution for Win2000 and IIS 5.0 and Active Perl
Stealth 4062 Oct 12, 2000, 5:15 PM
Post Re: Solution for Win2000 and IIS 5.0 and Active Perl
adnbox 4019 Oct 17, 2000, 12:22 PM
Thread Re: Solution for Win2000 and IIS 5.0 and Active Perl
ennovator 4019 Oct 25, 2000, 5:36 AM
Post Re: Solution for Win2000 and IIS 5.0 and Active Perl
rotovegas 3954 Dec 6, 2000, 3:38 AM
Post Re: IIS 5.0 and mapping .cgi
jayelder 3897 Dec 22, 2000, 6:55 AM