Home : Products : DBMan SQL : Discussion :

Products: DBMan SQL: Discussion: Re: [kjellkk] Problems using import: Edit Log

Here is the list of edits for this post
Re: [kjellkk] Problems using import
I would like to contribute another example of what appears to be the same problem.

I have been regularly importing from uploaded tab delimited text files via the 'import' function offered by the DBMan SQL 2.10 interface. It has been working very well UNTIL last week. This is what I did before it broke down:

I wanted to rename my Main table.
With option Load, I selected my table Main and saved it as New, and filled the Setup options parameters. I checked by displaying properties: all columns present.
I then dropped Main.

If I manually Add data to a new record in New, I of course see with List that I have the data placed in the correct fields.

But When I then tried importing a tab delimited text file into New, the data was placed in the wrong fields. For instance for five columns (of which the first is the INT Primary key), the data is entered in the reverse order.

In attempts to understand what was occuring, I dropped New and recreated it (with the same table name New) and all its columns manually. New import attempt : same problem.

I tried creating another table with different name, 'Pictures'. Again with first column as INT Primary key. It works correctly !!!!! (I really am baffled here!!)

I then imagined and tried an import of the same (5 field) text file into the table New using the MySQL interface. Checking the result with MySQL (Browse), the data IS entered into the correct fields. I then returned to the GT interface, to List my record, and the data displays correctly. BUT BUT: if I resync the table, the data again reappears in the wrong fields.

Finally, my provider and I have checked our SQL database, (notably with the OPTIMISE TABLE New; command in case it had been defragmented). This has no effect.

I would appreciate some fairly rapid investigation into this question by GT. We have spent a fair time adapting our site templates to change over to version 2.10. One web site has been taken off line because of this difficulty and a second site also using DBMan SQL v 2.10 is about to open and we want to avoid similar problems cropping up.

I have supplied TheStone with a copy of this contribution and private details so that GT can check my site and configs themselves.
Thanks for any contributions helping to square-out this major issue with (for me at least) what is a fine product.

Last edited by:

charly: Apr 14, 2003, 2:25 AM

Edit Log: