Home : Products : Gossamer Forum : Discussion :

Products: Gossamer Forum: Discussion: [BUG REPORT 1.1.4] Upgrade problems @INC GForum::Table::Category: Edit Log

Here is the list of edits for this post
[BUG REPORT 1.1.4] Upgrade problems @INC GForum::Table::Category
Hello!

While upgrading 1.0.0 to 1.1.4 with the latest binary, I get the following error.

Performing Gossamer Forum 1.0.0 -? 1.1.0 upgrades...
Removing 'user_cookies' column from the User table ...
Could not drop column user_cookies: Failed to execute query: 'ALTER TABLE forum_User DROP user_cookies' Reason: Can't DROP 'user_cookies'. Check that column/key exists
Adding column cat_depth to Category table...

This would be because I have tried couple of times now and most probably it does not exits. But further:


Error

An error occured:

GT::SQL (17641): Unable to load subclass: 'GForum::Table::Category'
Reason: Can't locate GForum/Table/Category.pm in @INC (@INC
contains: /cgi-bin/forum/admin
/usr/local/lib/perl5/5.6.0/i386-freebsd /usr/local/lib/perl5/5.6.0
/usr/local/lib/perl5/site_perl/5.6.0/i386-freebsd
/usr/local/lib/perl5/site_perl/5.6.0 /usr/local/lib/perl5/site_perl .) at
/cgi-bin/forum/admin/GT/SQL/Base.pm
line 547. , Can't locate GForum/Table.pm in @INC (@INC contains:
/cgi-bin/forum/admin
/usr/local/lib/perl5/5.6.0/i386-freebsd /usr/local/lib/perl5/5.6.0
/usr/local/lib/perl5/site_perl/5.6.0/i386-freebsd
/usr/local/lib/perl5/site_perl/5.6.0 /usr/local/lib/perl5/site_perl .) at
/cgi-bin/forum/admin/GT/SQL/Base.pm
line 547. at GT::Base::_format_err line 931.

The modules Category, Table and Base are there. After the second try it made a bak.

After upgrade it does not work.

Last edited by:

rajani: May 9, 2002, 12:22 PM

Edit Log: