Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: Zope: XML

straw poll: ParsedXML requirements

 

 

Zope xml RSS feed   Index | Next | Previous | View Threaded


faassen at vet

Oct 24, 2001, 8:35 AM

Post #1 of 8 (2402 views)
Permalink
straw poll: ParsedXML requirements

Hi there,

I'd like to hold an informal poll on requirements for any new release of
ParsedXML. There was some discussion on whether it should continue to
support Zope 2.3 and Python 1.5.2, or if it would be okay if it supported
Zope 2.4 and Python 2.1 only. The latter option would make life easier
on the developers, but if there are a lot of users who want to upgrade
ParsedXML but not their Zope yet, we should continue to support
Python 1.5.2 for a while longer.

So, what do people think? I'm especially interested in hearing from current
users of ParsedXML, though input from others would be interesting as well.
Please send your replies to the list also so we can discuss things further.

Regards,

Martijn


dethe at burningtiger

Oct 24, 2001, 8:44 AM

Post #2 of 8 (2372 views)
Permalink
Re: straw poll: ParsedXML requirements [In reply to]

+1 Zope 2.4/Python 2.1

Burning Tiger is hoping to use ParsedXML extensively as the basis for
supporting a whole slew of XML document types. We've already made the
move to Zope 2.4 and Python 2.1, so only supporting those levels and
above is OK with us.


And I'm looking forward to a new release, as I'm currently having
trouble with ParsedXML and Zope 2.4...

I'm sure the answer is in the archives, but I haven't had the time
lately for archive mining, and my headlamp is busted. %-)

--Dethe

--

Dethe Elza (delza [at] burningtiger)
Chief Mad Scientist
Burning Tiger Technologies (http://burningtiger.com)
Living Code Weblog (http://livingcode.ca)


sean.upton at uniontrib

Oct 24, 2001, 9:09 AM

Post #3 of 8 (2345 views)
Permalink
RE: straw poll: ParsedXML requirements [In reply to]

You will get conservative-implementation folks who have a lot of production
infrastructure still on Zope 2.3.x and Python 1.5.2 (like me, right now);
that said, I think the best approach is to release an 2.3.x/1.5.2 compatible
interim release with your proxy speedups, see if the expat leak bug (is that
fixed yet, and better yet, what is the nature of the problem?) can be fixed.
Label that release as the 'last' ParsedXML release supporting Python 1.5.2
and Zope 2.3.x. I think that is fair, then move on, supporting only new
releases of Zope/Python.

Sean

-----Original Message-----
From: Martijn Faassen [mailto:faassen [at] vet]
Sent: Wednesday, October 24, 2001 8:35 AM
To: zope-xml [at] zope
Subject: [Zope-xml] straw poll: ParsedXML requirements


Hi there,

I'd like to hold an informal poll on requirements for any new release of
ParsedXML. There was some discussion on whether it should continue to
support Zope 2.3 and Python 1.5.2, or if it would be okay if it supported
Zope 2.4 and Python 2.1 only. The latter option would make life easier
on the developers, but if there are a lot of users who want to upgrade
ParsedXML but not their Zope yet, we should continue to support
Python 1.5.2 for a while longer.

So, what do people think? I'm especially interested in hearing from current
users of ParsedXML, though input from others would be interesting as well.
Please send your replies to the list also so we can discuss things further.

Regards,

Martijn


_______________________________________________
Zope-xml mailing list
Zope-xml [at] zope
http://lists.zope.org/mailman/listinfo/zope-xml


jmax at h24-76-105-229

Oct 24, 2001, 9:29 AM

Post #4 of 8 (2406 views)
Permalink
Re: straw poll: ParsedXML requirements [In reply to]

Martijn Faassen wrote:

> I'd like to hold an informal poll on requirements

> Zope 2.4 and Python 2.1 only

> So, what do people think?

We're using ParsedXML to hold large-ish XML documents (10-100k) and provide a
number of different renderings on the fly (it's a Learning Management System,
different users get different views.

Python 2 and Zope 2.4 is what we're using, and the closer we get to Unicode
support, the easier our jobs will be (as we're trying to support a whole
external authoring cycle in this.) Performance is a big issue for us.

-----------------------------
- John Maxwell
http://www.entity-x.ca
jmax [at] portal


webmaven at lvcm

Oct 24, 2001, 10:37 AM

Post #5 of 8 (2379 views)
Permalink
RE: straw poll: ParsedXML requirements [In reply to]

On Wed, 2001-10-24 at 09:09, sean.upton [at] uniontrib wrote:
> You will get conservative-implementation folks who have a lot of production
> infrastructure still on Zope 2.3.x and Python 1.5.2 (like me, right now);

And me.

> that said, I think the best approach is to release an 2.3.x/1.5.2 compatible
> interim release with your proxy speedups, see if the expat leak bug (is that
> fixed yet, and better yet, what is the nature of the problem?) can be fixed.
> Label that release as the 'last' ParsedXML release supporting Python 1.5.2
> and Zope 2.3.x. I think that is fair, then move on, supporting only new
> releases of Zope/Python.

This sounds like a good plan, except that the 1.5.2/2.3.x compatible
branch should still get bugfixes if bugs are found (unlikely, I know).
In short, the release/branching strategy should take it's cue from
Zope's.

Michael Bernstein
(past user of XMLDocument and XMLWidgets, future user of ParsedXML)


wade at lightlink

Oct 24, 2001, 10:54 AM

Post #6 of 8 (2379 views)
Permalink
Re: straw poll: ParsedXML requirements [In reply to]

+1 Zope 2.4 & Python 2.1
Between Unicode support and overall better XML tools in Python 2+, I think it would be a real drain on resources to be backwards-compatible.

Wade Leftwich
Ithaca, NY


faassen at vet

Oct 24, 2001, 12:23 PM

Post #7 of 8 (2354 views)
Permalink
Re: straw poll: ParsedXML requirements [In reply to]

sean.upton [at] uniontrib wrote:
> You will get conservative-implementation folks who have a lot of production
> infrastructure still on Zope 2.3.x and Python 1.5.2 (like me, right now);
> that said, I think the best approach is to release an 2.3.x/1.5.2 compatible
> interim release with your proxy speedups, see if the expat leak bug (is that
> fixed yet, and better yet, what is the nature of the problem?)

I know there's an expat segfault bug, but what is this expat leak bug?

> can be fixed.
> Label that release as the 'last' ParsedXML release supporting Python 1.5.2
> and Zope 2.3.x. I think that is fair, then move on, supporting only new
> releases of Zope/Python.

The main sticking point would be the unicode support. I know some code
in ParsedXML currently works with both non-unicode strings and unicode
strings, but some obviously doesn't. Not resolving this issue and
fixing all the unit tests would be releasing a buggy version of
ParsedXML (for Zope 2.3 or Zope 2.4 or worse, both :).

Anyway, something like this would be my own preference if we can't move
on to Zope 2.4 directly. (now you know my agenda if it wasn't obvious
anyway :)

Regards,

Martijn


sean.upton at uniontrib

Oct 24, 2001, 12:43 PM

Post #8 of 8 (2362 views)
Permalink
RE: straw poll: ParsedXML requirements [In reply to]

Well, I would think that slightly non-compliant (i.e. no unicode support)
for old releases of Zope would have to do.

I'm not sure about the expat bug; perhaps I am mistaken... just remember
hearing something about something like that a while back...

Sean

-----Original Message-----
From: Martijn Faassen [mailto:faassen [at] vet]
Sent: Wednesday, October 24, 2001 12:23 PM
To: sean.upton [at] uniontrib
Cc: zope-xml [at] zope
Subject: Re: [Zope-xml] straw poll: ParsedXML requirements


sean.upton [at] uniontrib wrote:
> You will get conservative-implementation folks who have a lot of
production
> infrastructure still on Zope 2.3.x and Python 1.5.2 (like me, right now);
> that said, I think the best approach is to release an 2.3.x/1.5.2
compatible
> interim release with your proxy speedups, see if the expat leak bug (is
that
> fixed yet, and better yet, what is the nature of the problem?)

I know there's an expat segfault bug, but what is this expat leak bug?

> can be fixed.
> Label that release as the 'last' ParsedXML release supporting Python 1.5.2
> and Zope 2.3.x. I think that is fair, then move on, supporting only new
> releases of Zope/Python.

The main sticking point would be the unicode support. I know some code
in ParsedXML currently works with both non-unicode strings and unicode
strings, but some obviously doesn't. Not resolving this issue and
fixing all the unit tests would be releasing a buggy version of
ParsedXML (for Zope 2.3 or Zope 2.4 or worse, both :).

Anyway, something like this would be my own preference if we can't move
on to Zope 2.4 directly. (now you know my agenda if it wasn't obvious
anyway :)

Regards,

Martijn

Zope xml RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.