Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: Zope: Users

Urgend help needed: Error migrating Zope Data.fs from 2.10 to 2.13: object.__new__(Args) is not safe

 

 

Zope users RSS feed   Index | Next | Previous | View Threaded


fkauff at biologie

Oct 14, 2011, 6:03 AM

Post #1 of 2 (324 views)
Permalink
Urgend help needed: Error migrating Zope Data.fs from 2.10 to 2.13: object.__new__(Args) is not safe

Sorry for the repost, but I'm lost, and really need to solve this problem...

When trying to move Data.fs from Zope 2.10 to 2.13, I first ran into the
"version problem", but I successfully stripped versions out of my
Data.fs (thanks to this mailing list).
Now Zope starts up properly and displays the manage page, but when I try
to access the various folders of the site, I get the error below.

Any ideas about how to overcome this? How have others convrted their
data? Should I move Data.fs in small stepss from 2.10 to 2.11, then to
2.12, and then to 2.13? Is this a common compatibility issue, or some
other error in Data.fs?

Any help would be greatly appreciated!

Thanks, Frank




Zope Error

Zope has encountered an error while publishing this resource.

Error Type: TypeError
Error Value: (', use Persistence.Persistent.__new__()', , ())

Traceback (innermost last):

Module ZPublisher.Publish, line 126, in publish
Module ZPublisher.mapply, line 77, in mapply
Module ZPublisher.Publish, line 46, in call_object
Module Shared.DC.Scripts.Bindings, line 322, in __call__
Module Shared.DC.Scripts.Bindings, line 359, in _bindAndExec
Module App.special_dtml, line 185, in _exec
Module DocumentTemplate.DT_Let, line 77, in render
Module DocumentTemplate.DT_In, line 647, in renderwob
Module DocumentTemplate.DT_In, line 772, in sort_sequence
Module ZODB.Connection, line 860, in setstate
Module ZODB.Connection, line 914, in _setstate
Module ZODB.serialize, line 612, in setGhostState
Module ZODB.serialize, line 605, in getState
Module ZODB.broken, line 106, in __new__

TypeError: ('object.__new__(Args) is not safe, use
Persistence.Persistent.__new__()', <class
'Shared.DC.ZRDB.Aqueduct.Args'>, ())

_______________________________________________
Zope maillist - Zope [at] zope
https://mail.zope.org/mailman/listinfo/zope
** No cross posts or HTML encoding! **
(Related lists -
https://mail.zope.org/mailman/listinfo/zope-announce
https://mail.zope.org/mailman/listinfo/zope-dev )


lukesh at seznam

Oct 14, 2011, 6:07 AM

Post #2 of 2 (312 views)
Permalink
Re: Urgend help needed: Error migrating Zope Data.fs from 2.10 to 2.13: object.__new__(Args) is not safe [In reply to]

Did you try export 2.10 to ZEXP and on 2.13 import that zexp file?


----- Puvodní zpráva -----
Od: "Frank Kauff" <fkauff [at] biologie>


> Sorry for the repost, but I'm lost, and really need to solve this
> problem...
>
> When trying to move Data.fs from Zope 2.10 to 2.13, I first ran into the
> "version problem", but I successfully stripped versions out of my
> Data.fs (thanks to this mailing list).
> Now Zope starts up properly and displays the manage page, but when I try
> to access the various folders of the site, I get the error below.
>
> Any ideas about how to overcome this? How have others convrted their
> data? Should I move Data.fs in small stepss from 2.10 to 2.11, then to
> 2.12, and then to 2.13? Is this a common compatibility issue, or some
> other error in Data.fs?

_______________________________________________
Zope maillist - Zope [at] zope
https://mail.zope.org/mailman/listinfo/zope
** No cross posts or HTML encoding! **
(Related lists -
https://mail.zope.org/mailman/listinfo/zope-announce
https://mail.zope.org/mailman/listinfo/zope-dev )

Zope users RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.