Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: Zope: Coders

[ZC] 152/ 3 Comment "Zope 2.5.0b4 linux binary can't install"

 

 

Zope coders RSS feed   Index | Next | Previous | View Threaded


zope-coders at zope

Jan 16, 2002, 1:34 PM

Post #1 of 1 (90 views)
Permalink
[ZC] 152/ 3 Comment "Zope 2.5.0b4 linux binary can't install"

Issue #152 Update (Comment) "Zope 2.5.0b4 linux binary can't install"
Status Deferred, Zope/bug medium
To followup, visit:
http://collector.zope.org/Zope/152

==============================================================
= Comment - Entry #3 by efge on Jan 16, 2002 3:34 pm

Okay but 2.5.0b4 stops right there (after "There were errors") and doesn't finish building Zope. 2.5.0b3 worked ok.

________________________________________
= Defer - Entry #2 by matt on Jan 16, 2002 3:30 pm

Status: Pending => Deferred

These are known issues with the actual Python 2.1 test suite having errors when they compile. The problem is one of packaging; the Zope code should not include these tests suites and the error will not be raised.

At some time, it is expected that the Python test suite used will not contain errors. Failure of these test modules for python itself to compile though, are not failures of Zope.
________________________________________
= Request - Entry #1 by efge on Jan 16, 2002 3:13 pm

Using Zope-2.5.0b4-linux2-x86.tgz when I try to install I get:

debian$ ./install

------------------------------------------------------------------------------
Compiling python modules
File "/home/zope/test-zope/lib/python2.1/test/nocaret.py", line 2
[x for x in x] = x
SyntaxError: can't assign to list comprehension
SyntaxError: from __future__ imports must occur at the beginning of the file (t\
est_future3.py, line 3)
SyntaxError: from __future__ imports must occur at the beginning of the file (t\
est_future4.py, line 3)
SyntaxError: from __future__ imports must occur at the beginning of the file (t\
est_future5.py, line 4)
SyntaxError: from __future__ imports must occur at the beginning of the file (t\
est_future6.py, line 3)
SyntaxError: from __future__ imports must occur at the beginning of the file (t\
est_future7.py, line 3)

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
There were errors during Python module compilation.
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

==============================================================

Zope coders RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.