Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: Zope: CMF

[dev] five.localsitemanager: 1.0 branch dependencies

 

 

Zope cmf RSS feed   Index | Next | Previous | View Threaded


y.2009 at wcm-solutions

Mar 12, 2009, 5:06 AM

Post #1 of 9 (1563 views)
Permalink
[dev] five.localsitemanager: 1.0 branch dependencies

Hi!


setup.py says:

install_requires=[
'setuptools',
'zope.component < 3.5dev',
],

But CHANGES.txt says:

* Rewrite PersistentComponents.registeredUtilities to not use
internal methods. This makes it compatible with both zope.component
<3.5.0dev
and >3.5.0dev.
[wichert]

AFAICS the 1.0 branch works fine with zope.component 3.5. Two tests are
currently failing, but they just show different, not broken behavior.


I'd like to change install_requires to 'zope.component < 3.6dev' and
make tests work with zope.component 3.5.1 and older versions.

Any objections?


Cheers,

Yuppie

_______________________________________________
Zope-CMF maillist - Zope-CMF [at] lists
http://mail.zope.org/mailman/listinfo/zope-cmf

See https://bugs.launchpad.net/zope-cmf/ for bug reports and feature requests


wichert at wiggy

Mar 12, 2009, 5:19 AM

Post #2 of 9 (1509 views)
Permalink
Re: [dev] five.localsitemanager: 1.0 branch dependencies [In reply to]

Previously yuppie wrote:
> Hi!
>
>
> setup.py says:
>
> install_requires=[
> 'setuptools',
> 'zope.component < 3.5dev',
> ],
>
> But CHANGES.txt says:
>
> * Rewrite PersistentComponents.registeredUtilities to not use
> internal methods. This makes it compatible with both zope.component
> <3.5.0dev
> and >3.5.0dev.
> [wichert]
>
> AFAICS the 1.0 branch works fine with zope.component 3.5. Two tests are
> currently failing, but they just show different, not broken behavior.
>
>
> I'd like to change install_requires to 'zope.component < 3.6dev' and
> make tests work with zope.component 3.5.1 and older versions.
>
> Any objections?

+1

Wichert.

--
Wichert Akkerman <wichert [at] wiggy> It is simple to make things.
http://www.wiggy.net/ It is hard to make things simple.
_______________________________________________
Zope-CMF maillist - Zope-CMF [at] lists
http://mail.zope.org/mailman/listinfo/zope-cmf

See https://bugs.launchpad.net/zope-cmf/ for bug reports and feature requests


wichert at wiggy

Mar 12, 2009, 5:19 AM

Post #3 of 9 (1521 views)
Permalink
Re: [dev] five.localsitemanager: 1.0 branch dependencies [In reply to]

Previously yuppie wrote:
> Hi!
>
>
> setup.py says:
>
> install_requires=[
> 'setuptools',
> 'zope.component < 3.5dev',
> ],
>
> But CHANGES.txt says:
>
> * Rewrite PersistentComponents.registeredUtilities to not use
> internal methods. This makes it compatible with both zope.component
> <3.5.0dev
> and >3.5.0dev.
> [wichert]
>
> AFAICS the 1.0 branch works fine with zope.component 3.5. Two tests are
> currently failing, but they just show different, not broken behavior.
>
>
> I'd like to change install_requires to 'zope.component < 3.6dev' and
> make tests work with zope.component 3.5.1 and older versions.
>
> Any objections?

+1

Wichert.

--
Wichert Akkerman <wichert [at] wiggy> It is simple to make things.
http://www.wiggy.net/ It is hard to make things simple.
_______________________________________________
Zope-CMF maillist - Zope-CMF [at] lists
http://mail.zope.org/mailman/listinfo/zope-cmf

See https://bugs.launchpad.net/zope-cmf/ for bug reports and feature requests


tseaver at palladion

Mar 12, 2009, 5:25 AM

Post #4 of 9 (1508 views)
Permalink
Re: [dev] five.localsitemanager: 1.0 branch dependencies [In reply to]

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Wichert Akkerman wrote:
> Previously yuppie wrote:
>> Hi!
>>
>>
>> setup.py says:
>>
>> install_requires=[
>> 'setuptools',
>> 'zope.component < 3.5dev',
>> ],
>>
>> But CHANGES.txt says:
>>
>> * Rewrite PersistentComponents.registeredUtilities to not use
>> internal methods. This makes it compatible with both zope.component
>> <3.5.0dev
>> and >3.5.0dev.
>> [wichert]
>>
>> AFAICS the 1.0 branch works fine with zope.component 3.5. Two tests are
>> currently failing, but they just show different, not broken behavior.
>>
>>
>> I'd like to change install_requires to 'zope.component < 3.6dev' and
>> make tests work with zope.component 3.5.1 and older versions.
>>
>> Any objections?

I would just rip out the version requirement altogether (I did this the
other day when testing CMFCore against the Zope2 trunk).



Tres.
- --
===================================================================
Tres Seaver +1 540-429-0999 tseaver [at] palladion
Palladion Software "Excellence by Design" http://palladion.com
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFJuP9J+gerLs4ltQ4RAojUAJ9RDMq/LXZGtKsIyEQgj0ACrkDwKgCeMyoV
v9KMIrY0j7IlEcQmSVOSSTU=
=Gk/8
-----END PGP SIGNATURE-----
_______________________________________________
Zope-CMF maillist - Zope-CMF [at] lists
http://mail.zope.org/mailman/listinfo/zope-cmf

See https://bugs.launchpad.net/zope-cmf/ for bug reports and feature requests


tseaver at palladion

Mar 12, 2009, 5:25 AM

Post #5 of 9 (1507 views)
Permalink
Re: [dev] five.localsitemanager: 1.0 branch dependencies [In reply to]

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Wichert Akkerman wrote:
> Previously yuppie wrote:
>> Hi!
>>
>>
>> setup.py says:
>>
>> install_requires=[
>> 'setuptools',
>> 'zope.component < 3.5dev',
>> ],
>>
>> But CHANGES.txt says:
>>
>> * Rewrite PersistentComponents.registeredUtilities to not use
>> internal methods. This makes it compatible with both zope.component
>> <3.5.0dev
>> and >3.5.0dev.
>> [wichert]
>>
>> AFAICS the 1.0 branch works fine with zope.component 3.5. Two tests are
>> currently failing, but they just show different, not broken behavior.
>>
>>
>> I'd like to change install_requires to 'zope.component < 3.6dev' and
>> make tests work with zope.component 3.5.1 and older versions.
>>
>> Any objections?

I would just rip out the version requirement altogether (I did this the
other day when testing CMFCore against the Zope2 trunk).



Tres.
- --
===================================================================
Tres Seaver +1 540-429-0999 tseaver [at] palladion
Palladion Software "Excellence by Design" http://palladion.com
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFJuP9J+gerLs4ltQ4RAojUAJ9RDMq/LXZGtKsIyEQgj0ACrkDwKgCeMyoV
v9KMIrY0j7IlEcQmSVOSSTU=
=Gk/8
-----END PGP SIGNATURE-----

_______________________________________________
Zope-CMF maillist - Zope-CMF [at] lists
http://mail.zope.org/mailman/listinfo/zope-cmf

See https://bugs.launchpad.net/zope-cmf/ for bug reports and feature requests


y.2009 at wcm-solutions

Mar 12, 2009, 5:50 AM

Post #6 of 9 (1508 views)
Permalink
Re: [dev] five.localsitemanager: 1.0 branch dependencies [In reply to]

Tres Seaver wrote:
> Wichert Akkerman wrote:
>> Previously yuppie wrote:
>>> setup.py says:
>>>
>>> install_requires=[
>>> 'setuptools',
>>> 'zope.component < 3.5dev',
>>> ],
>>>
>>> But CHANGES.txt says:
>>>
>>> * Rewrite PersistentComponents.registeredUtilities to not use
>>> internal methods. This makes it compatible with both zope.component
>>> <3.5.0dev
>>> and >3.5.0dev.
>>> [wichert]
>>>
>>> AFAICS the 1.0 branch works fine with zope.component 3.5. Two tests are
>>> currently failing, but they just show different, not broken behavior.
>>>
>>>
>>> I'd like to change install_requires to 'zope.component < 3.6dev' and
>>> make tests work with zope.component 3.5.1 and older versions.
>>>
>>> Any objections?
>
> I would just rip out the version requirement altogether (I did this the
> other day when testing CMFCore against the Zope2 trunk).

Some fixes in GenericSetup 1.5 just work with zope.component >= 3.5.0,
so there is a need for a five.localsitemanager version that works with
zope.component 3.5 *and* Zope 2.10/2.11.

I haven't tested if zope.component trunk can be used with Zope 2.10 and
I can't see a need for supporting that combination.

For Zope 2.12 we will have five.localsitemanager 2.0, so I can't see a
need to use five.localsitemanager 1.x with Zope >= 2.12.

five.localsitemanager trunk (2.0) has no version requirement specified.

Cheers, Yuppie

_______________________________________________
Zope-CMF maillist - Zope-CMF [at] lists
http://mail.zope.org/mailman/listinfo/zope-cmf

See https://bugs.launchpad.net/zope-cmf/ for bug reports and feature requests


hannosch at hannosch

Mar 12, 2009, 7:39 AM

Post #7 of 9 (1507 views)
Permalink
Re: [dev] five.localsitemanager: 1.0 branch dependencies [In reply to]

Wichert Akkerman wrote:
> Previously yuppie wrote:
>> I'd like to change install_requires to 'zope.component < 3.6dev' and
>> make tests work with zope.component 3.5.1 and older versions.
>>
>> Any objections?

I'd just remove the version number altogether. If this version works
with a yet unreleased version or not is speculation.

The recommendation for using the 2.0 version with Zope 2.12 is a KGS
information and not a requirement in my view.

Hanno

_______________________________________________
Zope-CMF maillist - Zope-CMF [at] lists
http://mail.zope.org/mailman/listinfo/zope-cmf

See https://bugs.launchpad.net/zope-cmf/ for bug reports and feature requests


y.2009 at wcm-solutions

Mar 12, 2009, 8:57 AM

Post #8 of 9 (1504 views)
Permalink
Re: [dev] five.localsitemanager: 1.0 branch dependencies [In reply to]

Hanno Schlichting wrote:
> Wichert Akkerman wrote:
>> Previously yuppie wrote:
>>> I'd like to change install_requires to 'zope.component < 3.6dev' and
>>> make tests work with zope.component 3.5.1 and older versions.
>>>
>>> Any objections?
>
> I'd just remove the version number altogether. If this version works
> with a yet unreleased version or not is speculation.
>
> The recommendation for using the 2.0 version with Zope 2.12 is a KGS
> information and not a requirement in my view.

I doubt you can satisfy the requirements for five.localsitemanager 2.0
in a Zope version older than 2.12. That's why Zope2 >= 2.12.dev is
specified as dependency. I thought you were fine with that.

five.localsitemanager 1.x doesn't depend on eggified Zope versions, so
we need different ways to make recommendations.

That said, I don't care much about the solution for older packages.
Removing just the version number doesn't seem to make sense because no
other unrestricted dependencies are specified. But I'm not familiar with
the consequences for fake-egg based installations. So feel free to make
any changes you like.

Cheers, Yuppie

_______________________________________________
Zope-CMF maillist - Zope-CMF [at] lists
http://mail.zope.org/mailman/listinfo/zope-cmf

See https://bugs.launchpad.net/zope-cmf/ for bug reports and feature requests


hannosch at hannosch

Mar 12, 2009, 9:10 AM

Post #9 of 9 (1516 views)
Permalink
Re: [dev] five.localsitemanager: 1.0 branch dependencies [In reply to]

yuppie wrote:
> I doubt you can satisfy the requirements for five.localsitemanager 2.0
> in a Zope version older than 2.12. That's why Zope2 >= 2.12.dev is
> specified as dependency. I thought you were fine with that.
>
> five.localsitemanager 1.x doesn't depend on eggified Zope versions, so
> we need different ways to make recommendations.
>
> That said, I don't care much about the solution for older packages.
> Removing just the version number doesn't seem to make sense because no
> other unrestricted dependencies are specified. But I'm not familiar with
> the consequences for fake-egg based installations. So feel free to make
> any changes you like.

Right, sorry.

Just ignore me, bad day syndrome ;)

Hanno

_______________________________________________
Zope-CMF maillist - Zope-CMF [at] lists
http://mail.zope.org/mailman/listinfo/zope-cmf

See https://bugs.launchpad.net/zope-cmf/ for bug reports and feature requests

Zope cmf RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.