Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: Xen: Users

xcp-xapi console problems with xencenter

 

 

Xen users RSS feed   Index | Next | Previous | View Threaded


davidkierz at gmail

Jul 21, 2012, 11:52 AM

Post #1 of 2 (697 views)
Permalink
xcp-xapi console problems with xencenter

running xen cloud on my ubuntu12.04 box
connecting with xencenter - i can create delete and monitor VM's
when i connect to the console i can see the console output but none of
my keypresses or mouse clicks are registered in the VM
everything i hit a key i get this in my xcp-xapi log

[20120721T17:17:20.330Z|debug|xen|509 INET 127.0.0.1:80|Connection to
VM console R:73c96b23cdd8|console] Proxy exited
[20120721T17:17:20.484Z|debug|xen|675 INET 127.0.0.1:80|Connection to
VM console R:d4603aa93052|console] VM
OpaqueRef:29595b00-e209-bb8a-c093-cccfc3f57746 console port: Some 5901
[20120721T17:17:20.485Z|debug|xen|675 INET 127.0.0.1:80|Connection to
VM console R:d4603aa93052|console] Connected; running proxy (between
fds: 26 and 27)

Any Ideas? I can't figure out any other way to connect to a console.

_______________________________________________
Xen-users mailing list
Xen-users [at] lists
http://lists.xen.org/xen-users


davidkierz at gmail

Jul 22, 2012, 9:43 AM

Post #2 of 2 (699 views)
Permalink
xcp-xapi console problems with xencenter [In reply to]

I completely uninstalled and reinstalled ubuntu 12.04 2 times last night
each time i get stuck on the part where keypresses are not getting sent to xen
i applied the workaround for the ubuntu qemu keymap locations, has no effect
i tried both the ubuntu packages and the PPA packages, no difference.

I installed the xcp-xapi-debug, but im not sure how to execute these
programs. Does xe execute them?

trying to get other consoles working
(http://wiki.xensource.com/xenwiki/Xen_Cloud_Platform%3A_Access_to_VM_console)

OpenXenManager looks like a bunch of python no cygwin here.

XVP appears to run inside domU ? not interested in that...

trying the custom SSH tunnel method
i get stuck at

david [at] xe:~$ sudo xenstore-ls /local/domain/2/serial/0
limit = "65536"
tty = "/dev/pts/6"
david [at] xe:~$

vncterm-pid and vnc-port are not listed here???


my xcp-xapi.log
http://pastebin.com/3MSQXtmY

my syslog
http://pastebin.com/aHyDmNx6

my xe vm-param-list
http://pastebin.com/1ZGHkY98

my xe console-param-list
http://pastebin.com/ECmSruVZ

_______________________________________________
Xen-users mailing list
Xen-users [at] lists
http://lists.xen.org/xen-users

Xen users RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.