Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: Xen: Users

Installer hanging HVM Solaris 11 or OpenIndiana 151a

 

 

Xen users RSS feed   Index | Next | Previous | View Threaded


halcyon1981 at gmail

Jul 13, 2012, 2:28 PM

Post #1 of 5 (1101 views)
Permalink
Installer hanging HVM Solaris 11 or OpenIndiana 151a

Hi-
I'm wondering if anyone has had success installing Solaris 11 or
OpenIndiana 151a on an HVM VM? I'm not doing anything fancy, but as
soon as the kernel starts to load it just hangs on "Probing for device
nodes ..." (or resets when I try to pass through my m1015 HBA). I've
tried both the live and text only installers for Solaris, no
difference. I'm using Ubuntu 12.04, with Xen 4.1.2. Here is my
config file:

kernel="/usr/lib/xen-4.1/boot/hvmloader"
builder='hvm'
memory = 4096
vcpus=4
name = "solaris"
vif = ['bridge=xenbr0']
disk = ['phy:/dev/xen/solaris,hda,w','file:/home/user/sol-11-1111-text-x86.iso,hdc:cdrom,r']
device_model = 'qemu-dm'
boot="d"
serial='pty'
vnc=1
vnclisten="0.0.0.0"
vncdisplay=1
vncpasswd=""

Any help is greatly appreciated.

Thanks,
David

_______________________________________________
Xen-users mailing list
Xen-users [at] lists
http://lists.xen.org/xen-users


roger.pau at citrix

Jul 16, 2012, 3:21 AM

Post #2 of 5 (1042 views)
Permalink
Re: Installer hanging HVM Solaris 11 or OpenIndiana 151a [In reply to]

David Erickson wrote:
> Hi-
> I'm wondering if anyone has had success installing Solaris 11 or
> OpenIndiana 151a on an HVM VM?

Why are you trying to use HVM? From what I've read both Solaris 11 [1]
and OpenIndiana [2] have PV support. I've never tried it though, so I
have no idea in what shape is the Solaris/OI PV support. You could also
try to use HVM PV if you are interested in using HVM for some reason.

[1]
http://www.gnulinux.mu/2010/11/15/oracle-solaris-11-express-you-may-not-use-the-programs-for-your-own-internal-business-purposes/#comment-51
[2] http://wiki.openindiana.org/oi/Creating+OpenIndiana+EC2+image

> I'm not doing anything fancy, but as
> soon as the kernel starts to load it just hangs on "Probing for device
> nodes ..." (or resets when I try to pass through my m1015 HBA). I've
> tried both the live and text only installers for Solaris, no
> difference. I'm using Ubuntu 12.04, with Xen 4.1.2. Here is my
> config file:
>
> kernel="/usr/lib/xen-4.1/boot/hvmloader"
> builder='hvm'
> memory = 4096
> vcpus=4
> name = "solaris"
> vif = ['bridge=xenbr0']
> disk = ['phy:/dev/xen/solaris,hda,w','file:/home/user/sol-11-1111-text-x86.iso,hdc:cdrom,r']
> device_model = 'qemu-dm'
> boot="d"
> serial='pty'
> vnc=1
> vnclisten="0.0.0.0"
> vncdisplay=1
> vncpasswd=""
>
> Any help is greatly appreciated.
>
> Thanks,
> David
>
> _______________________________________________
> Xen-users mailing list
> Xen-users [at] lists
> http://lists.xen.org/xen-users


_______________________________________________
Xen-users mailing list
Xen-users [at] lists
http://lists.xen.org/xen-users


halcyon1981 at gmail

Jul 16, 2012, 12:17 PM

Post #3 of 5 (1038 views)
Permalink
Re: Installer hanging HVM Solaris 11 or OpenIndiana 151a [In reply to]

Thanks for the pointers Roger, the main reason is because I need to do
PCI pass thru of my SAS HBA and it isn't clear to me that Solaris has
the appropriate support for pass through with PV drivers.

On Mon, Jul 16, 2012 at 3:21 AM, Roger Pau Monne <roger.pau [at] citrix> wrote:
> David Erickson wrote:
>> Hi-
>> I'm wondering if anyone has had success installing Solaris 11 or
>> OpenIndiana 151a on an HVM VM?
>
> Why are you trying to use HVM? From what I've read both Solaris 11 [1]
> and OpenIndiana [2] have PV support. I've never tried it though, so I
> have no idea in what shape is the Solaris/OI PV support. You could also
> try to use HVM PV if you are interested in using HVM for some reason.
>
> [1]
> http://www.gnulinux.mu/2010/11/15/oracle-solaris-11-express-you-may-not-use-the-programs-for-your-own-internal-business-purposes/#comment-51
> [2] http://wiki.openindiana.org/oi/Creating+OpenIndiana+EC2+image
>
>> I'm not doing anything fancy, but as
>> soon as the kernel starts to load it just hangs on "Probing for device
>> nodes ..." (or resets when I try to pass through my m1015 HBA). I've
>> tried both the live and text only installers for Solaris, no
>> difference. I'm using Ubuntu 12.04, with Xen 4.1.2. Here is my
>> config file:
>>
>> kernel="/usr/lib/xen-4.1/boot/hvmloader"
>> builder='hvm'
>> memory = 4096
>> vcpus=4
>> name = "solaris"
>> vif = ['bridge=xenbr0']
>> disk = ['phy:/dev/xen/solaris,hda,w','file:/home/user/sol-11-1111-text-x86.iso,hdc:cdrom,r']
>> device_model = 'qemu-dm'
>> boot="d"
>> serial='pty'
>> vnc=1
>> vnclisten="0.0.0.0"
>> vncdisplay=1
>> vncpasswd=""
>>
>> Any help is greatly appreciated.
>>
>> Thanks,
>> David
>>
>> _______________________________________________
>> Xen-users mailing list
>> Xen-users [at] lists
>> http://lists.xen.org/xen-users
>

_______________________________________________
Xen-users mailing list
Xen-users [at] lists
http://lists.xen.org/xen-users


roger.pau at citrix

Jul 17, 2012, 3:29 AM

Post #4 of 5 (1052 views)
Permalink
Re: Installer hanging HVM Solaris 11 or OpenIndiana 151a [In reply to]

David Erickson wrote:
> Thanks for the pointers Roger, the main reason is because I need to do
> PCI pass thru of my SAS HBA and it isn't clear to me that Solaris has
> the appropriate support for pass through with PV drivers.

I've successfully created a Solaris 11 HVM using the following config file:

builder='hvm'
memory = 2048
vcpus=2
name = "solaris"
vif = ['bridge=br0, type=ioemu']
disk = [
'file:/root/solaris.img,ioemu:hda,w',
'file:/root/sol-11-1111-text-x86.iso,ioemu:hdc:cdrom,r'
]
boot="d"
vnc=1
vnclisten="0.0.0.0"
vncdisplay=1

I'm using xen-unstable, but I think there haven't been any changes that
could affect Solaris as a HVM. I haven't tried to perform any
PCI-passthrough. Both Solaris and the installer take some time to boot
up, and the installer seems to be frozen for some time (like 1-2min) on
"Probing for device nodes ...", but it eventually succeeds.

_______________________________________________
Xen-users mailing list
Xen-users [at] lists
http://lists.xen.org/xen-users


halcyon1981 at gmail

Jul 17, 2012, 9:56 AM

Post #5 of 5 (1047 views)
Permalink
Re: Installer hanging HVM Solaris 11 or OpenIndiana 151a [In reply to]

Thanks Roger, I too was able to get it to boot temporarily (then it
mysteriously stopped working and I couldn't get it back, no clue what
happened) with a very similar config to above. Also of note, if you
try to export a phy LVM based backend to Solaris it will just hang and
never boot, you must use a file like you did in your config. However
for the brief time I was able to get it work I had a problem where the
option ROM on the SAS card would fail being executed (see
http://marc.info/?l=xen-devel&m=133417413911332&w=2), which looked
like it left the card in a broken state causing the kernel to panic
during boot. Any suggestions on how to deal with a problem like that?

On Tue, Jul 17, 2012 at 3:29 AM, Roger Pau Monne <roger.pau [at] citrix> wrote:
> David Erickson wrote:
>> Thanks for the pointers Roger, the main reason is because I need to do
>> PCI pass thru of my SAS HBA and it isn't clear to me that Solaris has
>> the appropriate support for pass through with PV drivers.
>
> I've successfully created a Solaris 11 HVM using the following config file:
>
> builder='hvm'
> memory = 2048
> vcpus=2
> name = "solaris"
> vif = ['bridge=br0, type=ioemu']
> disk = [
> 'file:/root/solaris.img,ioemu:hda,w',
> 'file:/root/sol-11-1111-text-x86.iso,ioemu:hdc:cdrom,r'
> ]
> boot="d"
> vnc=1
> vnclisten="0.0.0.0"
> vncdisplay=1
>
> I'm using xen-unstable, but I think there haven't been any changes that
> could affect Solaris as a HVM. I haven't tried to perform any
> PCI-passthrough. Both Solaris and the installer take some time to boot
> up, and the installer seems to be frozen for some time (like 1-2min) on
> "Probing for device nodes ...", but it eventually succeeds.

_______________________________________________
Xen-users mailing list
Xen-users [at] lists
http://lists.xen.org/xen-users

Xen users RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.