Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: Xen: Research

Fwd: Error: xc_dom_boot_mem_init: can't allocate low memory for domain

 

 

Xen research RSS feed   Index | Next | Previous | View Threaded


Omer.Khalid at cern

Dec 2, 2009, 11:41 AM

Post #1 of 1 (2010 views)
Permalink
Fwd: Error: xc_dom_boot_mem_init: can't allocate low memory for domain

Hi,

We have Xen 3.1.2 installed on RHEL5 machine and the dom0 have 1GB RAM where
as the available memory available on the server is 8GB.

I am having a problem in starting up a VM with the following configuration:
name = "slc5Test"
ip = "xxx.xxx.xxx.xxx"
hostname = "some.domain.somewhere"
memory = "1024"
disk =
['phy:/dev/VolGroup00/slc4TestRoot,xvda1,w','phy:/dev/VolGroup00/slc4TestSwap,xvda2,w']
root= "/dev/xvda1 ro"
vif = [ '' ]
gateway= "xxx.xxx.1.1"
netmask = "255.255.0.0"
on_reboot = 'restart'
on_crash = 'restart'
on_poweroff = 'restart'
bootloader = '/usr/bin/pygrub'

The error I am getting with "xm create -f config_file" is the following:
Error: (4, 'Out of memory', "xc_dom_boot_mem_init: can't allocate low memory
for domain\n")

I looked up in some of the mailing list archives and found that some people
had problems but didn't come across how to fix this.

Any help would be much appreciated.

Many thanks,
Omer

Xen research RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.