Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: Xen: Devel

error in creating another domain

 

 

Xen devel RSS feed   Index | Next | Previous | View Threaded


qhuang at cs

Mar 19, 2004, 3:13 AM

Post #1 of 12 (272 views)
Permalink
error in creating another domain

Being a newbie of Xen, I am probably asking a question previously raised,
if so, please point me to the answer.
I made a hard drive installation of Xen1.2 from the CD. It runs perfect
with domain0. But I encountered some problems when I was tring to create
a second domain. Basically, I followed the instruction at
http://www.csc.liv.ac.uk/~u2ycc/xen/xen-install-domain-fs-howto.txt, I
built a new partition and populated the partition w/ the RH9 from the CD,
customized the configuration file.

Here is the output of xc_dom_create.py:

#xc_dom_create.py -fmyvm1.conf -Dvmid=1
Parsing config file '/etc/xc/myvm1.conf'
VM image : "/boot/xenolinux.gz"
VM ramdisk : ""
VM memory (MB) : "32"
VM IP address(es) : "169.254.1.1"
VM block device(s) : "phy:hdc1,hdc1,w"
VM cmdline :
"ip=169.254.1.1:169.254.1.0:169.254.1.0:255.255.0.0::eth0:off
root=/dev/hdc1 ro 4 VMID=1
Error creating domain.

What could be possilbe wrong in this case? Where can I get detailed info
about this error? Is there a "debug mode" to look into?

Thanks

--qian


-------------------------------------------------------
This SF.Net email is sponsored by: IBM Linux Tutorials
Free Linux tutorial presented by Daniel Robbins, President and CEO of
GenToo technologies. Learn everything from fundamentals to system
administration.http://ads.osdn.com/?ad_id=1470&alloc_id=3638&op=click
_______________________________________________
Xen-devel mailing list
Xen-devel [at] lists
https://lists.sourceforge.net/lists/listinfo/xen-devel


qhuang at cs

Mar 19, 2004, 3:13 AM

Post #2 of 12 (222 views)
Permalink
error in creating another domain [In reply to]

Being a newbie of Xen, I am probably asking a question previously raised,
if so, please point me to the answer.
I made a hard drive installation of Xen1.2 from the CD. It runs perfect
with domain0. But I encountered some problems when I was tring to create
a second domain. Basically, I followed the instruction at
http://www.csc.liv.ac.uk/~u2ycc/xen/xen-install-domain-fs-howto.txt, I
built a new partition and populated the partition w/ the RH9 from the CD,
customized the configuration file.

Here is the output of xc_dom_create.py:

#xc_dom_create.py -fmyvm1.conf -Dvmid=1
Parsing config file '/etc/xc/myvm1.conf'
VM image : "/boot/xenolinux.gz"
VM ramdisk : ""
VM memory (MB) : "32"
VM IP address(es) : "169.254.1.1"
VM block device(s) : "phy:hdc1,hdc1,w"
VM cmdline :
"ip=169.254.1.1:169.254.1.0:169.254.1.0:255.255.0.0::eth0:off
root=/dev/hdc1 ro 4 VMID=1
Error creating domain.

What could be possilbe wrong in this case? Where can I get detailed info
about this error? Is there a "debug mode" to look into?

Thanks

--qian


-------------------------------------------------------
This SF.Net email is sponsored by: IBM Linux Tutorials
Free Linux tutorial presented by Daniel Robbins, President and CEO of
GenToo technologies. Learn everything from fundamentals to system
administration.http://ads.osdn.com/?ad_id=1470&alloc_id=3638&op=click
_______________________________________________
Xen-devel mailing list
Xen-devel [at] lists
https://lists.sourceforge.net/lists/listinfo/xen-devel


qhuang at cs

Mar 19, 2004, 4:02 AM

Post #3 of 12 (224 views)
Permalink
Re: error in creating a second domain [In reply to]

Being a newbie of Xen, I am probably asking a question previously raised,
if so, please point me to the answer.
I made a hard drive installation of Xen1.2 from the CD. It runs perfect
with domain0. But I encountered some problems when I was tring to create
a second domain. Basically, I followed the instruction at
http://www.csc.liv.ac.uk/~u2ycc/xen/xen-install-domain-fs-howto.txt, I
built a new partition and populated the partition w/ the RH9 from the CD,
customized the configuration file.

Here is the output of xc_dom_create.py:

#xc_dom_create.py -fmyvm1.conf -Dvmid=1
Parsing config file '/etc/xc/myvm1.conf'
VM image : "/boot/xenolinux.gz"
VM ramdisk : ""
VM memory (MB) : "32"
VM IP address(es) : "169.254.1.1"
VM block device(s) : "phy:hdc1,hdc1,w"
VM cmdline :
"ip=169.254.1.1:169.254.1.0:169.254.1.0:255.255.0.0::eth0:off
root=/dev/hdc1 ro 4 VMID=1
Error creating domain.

What could be possilbe wrong in this case? Where can I get detailed info
about this error? Is there a "debug mode" to look into?

Thanks

--qian


-------------------------------------------------------
This SF.Net email is sponsored by: IBM Linux Tutorials
Free Linux tutorial presented by Daniel Robbins, President and CEO of
GenToo technologies. Learn everything from fundamentals to system
administration.http://ads.osdn.com/?ad_id=1470&alloc_id=3638&op=click
_______________________________________________
Xen-devel mailing list
Xen-devel [at] lists
https://lists.sourceforge.net/lists/listinfo/xen-devel


qhuang at cs

Mar 19, 2004, 4:02 AM

Post #4 of 12 (222 views)
Permalink
Re: error in creating a second domain [In reply to]

Being a newbie of Xen, I am probably asking a question previously raised,
if so, please point me to the answer.
I made a hard drive installation of Xen1.2 from the CD. It runs perfect
with domain0. But I encountered some problems when I was tring to create
a second domain. Basically, I followed the instruction at
http://www.csc.liv.ac.uk/~u2ycc/xen/xen-install-domain-fs-howto.txt, I
built a new partition and populated the partition w/ the RH9 from the CD,
customized the configuration file.

Here is the output of xc_dom_create.py:

#xc_dom_create.py -fmyvm1.conf -Dvmid=1
Parsing config file '/etc/xc/myvm1.conf'
VM image : "/boot/xenolinux.gz"
VM ramdisk : ""
VM memory (MB) : "32"
VM IP address(es) : "169.254.1.1"
VM block device(s) : "phy:hdc1,hdc1,w"
VM cmdline :
"ip=169.254.1.1:169.254.1.0:169.254.1.0:255.255.0.0::eth0:off
root=/dev/hdc1 ro 4 VMID=1
Error creating domain.

What could be possilbe wrong in this case? Where can I get detailed info
about this error? Is there a "debug mode" to look into?

Thanks

--qian


-------------------------------------------------------
This SF.Net email is sponsored by: IBM Linux Tutorials
Free Linux tutorial presented by Daniel Robbins, President and CEO of
GenToo technologies. Learn everything from fundamentals to system
administration.http://ads.osdn.com/?ad_id=1470&alloc_id=3638&op=click
_______________________________________________
Xen-devel mailing list
Xen-devel [at] lists
https://lists.sourceforge.net/lists/listinfo/xen-devel


cs0u210a at liverpool

Mar 19, 2004, 5:37 AM

Post #5 of 12 (224 views)
Permalink
Re: Re: error in creating a second domain [In reply to]

Hi Qian,

Seems I should at least say something regarding to my howto, sorry I
haven't got time updating it even after Demo CD 1.2 is released. (Hi Ian, is
the ISO updated with the new bi-directional console feature in it? I bet I
should try the new features and update my howto soon)

Are you sure you have umounted the partition before you start the
domain? Some error messages aren't enough specific yet.

I suggest you to download the new 1.2 DemoCD from

http://www.cl.cam.ac.uk/Research/SRG/netos/xen/downloads.html

and follow the new readme inside first.

Let us know if you have any problems.

Cheers,
Yan-Ching CHU




----- Original Message -----
From: "Qian Huang" <qhuang [at] cs>
To: <xen-devel [at] lists>
Sent: Friday, March 19, 2004 11:02 AM
Subject: [Xen-devel] Re: error in creating a second domain


>
> Being a newbie of Xen, I am probably asking a question previously raised,
> if so, please point me to the answer.
> I made a hard drive installation of Xen1.2 from the CD. It runs perfect
> with domain0. But I encountered some problems when I was tring to create
> a second domain. Basically, I followed the instruction at
> http://www.csc.liv.ac.uk/~u2ycc/xen/xen-install-domain-fs-howto.txt, I
> built a new partition and populated the partition w/ the RH9 from the CD,
> customized the configuration file.
>
> Here is the output of xc_dom_create.py:
>
> #xc_dom_create.py -fmyvm1.conf -Dvmid=1
> Parsing config file '/etc/xc/myvm1.conf'
> VM image : "/boot/xenolinux.gz"
> VM ramdisk : ""
> VM memory (MB) : "32"
> VM IP address(es) : "169.254.1.1"
> VM block device(s) : "phy:hdc1,hdc1,w"
> VM cmdline :
> "ip=169.254.1.1:169.254.1.0:169.254.1.0:255.255.0.0::eth0:off
> root=/dev/hdc1 ro 4 VMID=1
> Error creating domain.
>
> What could be possilbe wrong in this case? Where can I get detailed info
> about this error? Is there a "debug mode" to look into?
>
> Thanks
>
> --qian
>
>
> -------------------------------------------------------
> This SF.Net email is sponsored by: IBM Linux Tutorials
> Free Linux tutorial presented by Daniel Robbins, President and CEO of
> GenToo technologies. Learn everything from fundamentals to system
> administration.http://ads.osdn.com/?ad_id=1470&alloc_id=3638&op=click
> _______________________________________________
> Xen-devel mailing list
> Xen-devel [at] lists
> https://lists.sourceforge.net/lists/listinfo/xen-devel
>



-------------------------------------------------------
This SF.Net email is sponsored by: IBM Linux Tutorials
Free Linux tutorial presented by Daniel Robbins, President and CEO of
GenToo technologies. Learn everything from fundamentals to system
administration.http://ads.osdn.com/?ad_id=1470&alloc_id=3638&op=click
_______________________________________________
Xen-devel mailing list
Xen-devel [at] lists
https://lists.sourceforge.net/lists/listinfo/xen-devel


cs0u210a at liverpool

Mar 19, 2004, 5:37 AM

Post #6 of 12 (223 views)
Permalink
Re: Re: error in creating a second domain [In reply to]

Hi Qian,

Seems I should at least say something regarding to my howto, sorry I
haven't got time updating it even after Demo CD 1.2 is released. (Hi Ian, is
the ISO updated with the new bi-directional console feature in it? I bet I
should try the new features and update my howto soon)

Are you sure you have umounted the partition before you start the
domain? Some error messages aren't enough specific yet.

I suggest you to download the new 1.2 DemoCD from

http://www.cl.cam.ac.uk/Research/SRG/netos/xen/downloads.html

and follow the new readme inside first.

Let us know if you have any problems.

Cheers,
Yan-Ching CHU




----- Original Message -----
From: "Qian Huang" <qhuang [at] cs>
To: <xen-devel [at] lists>
Sent: Friday, March 19, 2004 11:02 AM
Subject: [Xen-devel] Re: error in creating a second domain


>
> Being a newbie of Xen, I am probably asking a question previously raised,
> if so, please point me to the answer.
> I made a hard drive installation of Xen1.2 from the CD. It runs perfect
> with domain0. But I encountered some problems when I was tring to create
> a second domain. Basically, I followed the instruction at
> http://www.csc.liv.ac.uk/~u2ycc/xen/xen-install-domain-fs-howto.txt, I
> built a new partition and populated the partition w/ the RH9 from the CD,
> customized the configuration file.
>
> Here is the output of xc_dom_create.py:
>
> #xc_dom_create.py -fmyvm1.conf -Dvmid=1
> Parsing config file '/etc/xc/myvm1.conf'
> VM image : "/boot/xenolinux.gz"
> VM ramdisk : ""
> VM memory (MB) : "32"
> VM IP address(es) : "169.254.1.1"
> VM block device(s) : "phy:hdc1,hdc1,w"
> VM cmdline :
> "ip=169.254.1.1:169.254.1.0:169.254.1.0:255.255.0.0::eth0:off
> root=/dev/hdc1 ro 4 VMID=1
> Error creating domain.
>
> What could be possilbe wrong in this case? Where can I get detailed info
> about this error? Is there a "debug mode" to look into?
>
> Thanks
>
> --qian
>
>
> -------------------------------------------------------
> This SF.Net email is sponsored by: IBM Linux Tutorials
> Free Linux tutorial presented by Daniel Robbins, President and CEO of
> GenToo technologies. Learn everything from fundamentals to system
> administration.http://ads.osdn.com/?ad_id=1470&alloc_id=3638&op=click
> _______________________________________________
> Xen-devel mailing list
> Xen-devel [at] lists
> https://lists.sourceforge.net/lists/listinfo/xen-devel
>



-------------------------------------------------------
This SF.Net email is sponsored by: IBM Linux Tutorials
Free Linux tutorial presented by Daniel Robbins, President and CEO of
GenToo technologies. Learn everything from fundamentals to system
administration.http://ads.osdn.com/?ad_id=1470&alloc_id=3638&op=click
_______________________________________________
Xen-devel mailing list
Xen-devel [at] lists
https://lists.sourceforge.net/lists/listinfo/xen-devel


Ian.Pratt at cl

Mar 19, 2004, 6:48 AM

Post #7 of 12 (266 views)
Permalink
Re: Re: error in creating a second domain [In reply to]

> Hi Qian,
>
> Seems I should at least say something regarding to my howto, sorry I
> haven't got time updating it even after Demo CD 1.2 is released. (Hi Ian, is
> the ISO updated with the new bi-directional console feature in
> it?

No, the XenDemoCD is Xen 1.2 and the bidirectional console is in
xeno-unstable (1.3-pre).

It would be good to start doing a 1.3 XenDemoCD, but I think I'd
like to base it on Debian/Knoppix rather than RH9. In fact, it
would be great if I could hand this off to someone else. Any
volunteers from the community ? ;-)

> I bet I should try the new features and update my howto soon)

An updated README would be great, thanks.

Ian


-------------------------------------------------------
This SF.Net email is sponsored by: IBM Linux Tutorials
Free Linux tutorial presented by Daniel Robbins, President and CEO of
GenToo technologies. Learn everything from fundamentals to system
administration.http://ads.osdn.com/?ad_id=1470&alloc_id=3638&op=click
_______________________________________________
Xen-devel mailing list
Xen-devel [at] lists
https://lists.sourceforge.net/lists/listinfo/xen-devel


Ian.Pratt at cl

Mar 19, 2004, 6:48 AM

Post #8 of 12 (223 views)
Permalink
Re: Re: error in creating a second domain [In reply to]

> Hi Qian,
>
> Seems I should at least say something regarding to my howto, sorry I
> haven't got time updating it even after Demo CD 1.2 is released. (Hi Ian, is
> the ISO updated with the new bi-directional console feature in
> it?

No, the XenDemoCD is Xen 1.2 and the bidirectional console is in
xeno-unstable (1.3-pre).

It would be good to start doing a 1.3 XenDemoCD, but I think I'd
like to base it on Debian/Knoppix rather than RH9. In fact, it
would be great if I could hand this off to someone else. Any
volunteers from the community ? ;-)

> I bet I should try the new features and update my howto soon)

An updated README would be great, thanks.

Ian


-------------------------------------------------------
This SF.Net email is sponsored by: IBM Linux Tutorials
Free Linux tutorial presented by Daniel Robbins, President and CEO of
GenToo technologies. Learn everything from fundamentals to system
administration.http://ads.osdn.com/?ad_id=1470&alloc_id=3638&op=click
_______________________________________________
Xen-devel mailing list
Xen-devel [at] lists
https://lists.sourceforge.net/lists/listinfo/xen-devel


cs0u210a at liverpool

Mar 19, 2004, 9:19 AM

Post #9 of 12 (222 views)
Permalink
Re: Re: error in creating a second domain [In reply to]

> No, the XenDemoCD is Xen 1.2 and the bidirectional console is in
> xeno-unstable (1.3-pre).

Ooops. That was the stuff about libxc.so.1.2, sorry. For the lack of
hardward I just not dare to try many new things in the 1.3 tree. I even
haven't sorted out how I can test SMP-related codes.

> It would be good to start doing a 1.3 XenDemoCD, but I think I'd
> like to base it on Debian/Knoppix rather than RH9. In fact, it
> would be great if I could hand this off to someone else. Any
> volunteers from the community ? ;-)

I love Debian and wish I could help but I think it will be best left for
some other experts. Will there be any trouble basing Xen in other stock
Linux as some of the guys may be about to use them for production?

May be Bin will want to have a go as a Debian fiend?

> > I bet I should try the new features and update my howto soon)
>
> An updated README would be great, thanks.

No problems.

Cheers,
Yan-Ching CHU



-------------------------------------------------------
This SF.Net email is sponsored by: IBM Linux Tutorials
Free Linux tutorial presented by Daniel Robbins, President and CEO of
GenToo technologies. Learn everything from fundamentals to system
administration.http://ads.osdn.com/?ad_id=1470&alloc_id=3638&op=click
_______________________________________________
Xen-devel mailing list
Xen-devel [at] lists
https://lists.sourceforge.net/lists/listinfo/xen-devel


cs0u210a at liverpool

Mar 19, 2004, 9:19 AM

Post #10 of 12 (223 views)
Permalink
Re: Re: error in creating a second domain [In reply to]

> No, the XenDemoCD is Xen 1.2 and the bidirectional console is in
> xeno-unstable (1.3-pre).

Ooops. That was the stuff about libxc.so.1.2, sorry. For the lack of
hardward I just not dare to try many new things in the 1.3 tree. I even
haven't sorted out how I can test SMP-related codes.

> It would be good to start doing a 1.3 XenDemoCD, but I think I'd
> like to base it on Debian/Knoppix rather than RH9. In fact, it
> would be great if I could hand this off to someone else. Any
> volunteers from the community ? ;-)

I love Debian and wish I could help but I think it will be best left for
some other experts. Will there be any trouble basing Xen in other stock
Linux as some of the guys may be about to use them for production?

May be Bin will want to have a go as a Debian fiend?

> > I bet I should try the new features and update my howto soon)
>
> An updated README would be great, thanks.

No problems.

Cheers,
Yan-Ching CHU



-------------------------------------------------------
This SF.Net email is sponsored by: IBM Linux Tutorials
Free Linux tutorial presented by Daniel Robbins, President and CEO of
GenToo technologies. Learn everything from fundamentals to system
administration.http://ads.osdn.com/?ad_id=1470&alloc_id=3638&op=click
_______________________________________________
Xen-devel mailing list
Xen-devel [at] lists
https://lists.sourceforge.net/lists/listinfo/xen-devel


Ian.Pratt at cl

Mar 22, 2004, 12:50 AM

Post #11 of 12 (225 views)
Permalink
Re: error in creating another domain [In reply to]

> Here is the output of xc_dom_create.py:
>
> #xc_dom_create.py -fmyvm1.conf -Dvmid=1
> Parsing config file '/etc/xc/myvm1.conf'
> VM image : "/boot/xenolinux.gz"
> VM ramdisk : ""
> VM memory (MB) : "32"
> VM IP address(es) : "169.254.1.1"
> VM block device(s) : "phy:hdc1,hdc1,w"
> VM cmdline :
> "ip=169.254.1.1:169.254.1.0:169.254.1.0:255.255.0.0::eth0:off
> root=/dev/hdc1 ro 4 VMID=1
> Error creating domain.
>
> What could be possilbe wrong in this case? Where can I get detailed info
> about this error? Is there a "debug mode" to look into?

Does /proc/xen/privcmd exist?
Are you running as root?
Have you sufficient memory to start this domain? (Xen currently
reserves about 16MB for itself, which is rather more than it
actually needs).

Unfortunately, 1.2 doesn't give very descriptive error
messages. The unstable tree is better in this respect.

Ian


-------------------------------------------------------
This SF.Net email is sponsored by: IBM Linux Tutorials
Free Linux tutorial presented by Daniel Robbins, President and CEO of
GenToo technologies. Learn everything from fundamentals to system
administration.http://ads.osdn.com/?ad_id=1470&alloc_id=3638&op=click
_______________________________________________
Xen-devel mailing list
Xen-devel [at] lists
https://lists.sourceforge.net/lists/listinfo/xen-devel


Ian.Pratt at cl

Mar 22, 2004, 12:50 AM

Post #12 of 12 (223 views)
Permalink
Re: error in creating another domain [In reply to]

> Here is the output of xc_dom_create.py:
>
> #xc_dom_create.py -fmyvm1.conf -Dvmid=1
> Parsing config file '/etc/xc/myvm1.conf'
> VM image : "/boot/xenolinux.gz"
> VM ramdisk : ""
> VM memory (MB) : "32"
> VM IP address(es) : "169.254.1.1"
> VM block device(s) : "phy:hdc1,hdc1,w"
> VM cmdline :
> "ip=169.254.1.1:169.254.1.0:169.254.1.0:255.255.0.0::eth0:off
> root=/dev/hdc1 ro 4 VMID=1
> Error creating domain.
>
> What could be possilbe wrong in this case? Where can I get detailed info
> about this error? Is there a "debug mode" to look into?

Does /proc/xen/privcmd exist?
Are you running as root?
Have you sufficient memory to start this domain? (Xen currently
reserves about 16MB for itself, which is rather more than it
actually needs).

Unfortunately, 1.2 doesn't give very descriptive error
messages. The unstable tree is better in this respect.

Ian


-------------------------------------------------------
This SF.Net email is sponsored by: IBM Linux Tutorials
Free Linux tutorial presented by Daniel Robbins, President and CEO of
GenToo technologies. Learn everything from fundamentals to system
administration.http://ads.osdn.com/?ad_id=1470&alloc_id=3638&op=click
_______________________________________________
Xen-devel mailing list
Xen-devel [at] lists
https://lists.sourceforge.net/lists/listinfo/xen-devel

Xen devel RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.