Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: Xen: Bugs

[Bug 1793] New: need to correct xen-tools-4.1.1-curl.patch



Xen bugs RSS feed   Index | Next | Previous | View Threaded

bugzilla-daemon at lists

Nov 5, 2011, 11:59 AM

Post #1 of 1 (1201 views)
[Bug 1793] New: need to correct xen-tools-4.1.1-curl.patch


Summary: need to correct xen-tools-4.1.1-curl.patch
Product: Xen
Version: unstable
Platform: x86-64
OS/Version: Linux
Status: NEW
Severity: normal
Priority: P5
Component: Tools
AssignedTo: xen-bugs [at] lists
ReportedBy: taho [at] hitv

I have tried to compile xen-tools-4.1.2 on gentoo distr. but with not any
success :(
I suppose patch xen-tools-4.1.1-curl.patch is wrong.
it delete raw with difinition of curl_libs variable. Further compilation fails.
Should be:

diff -ur xen-4.1.1.orig//tools/check/check_curl
--- xen-4.1.1.orig//tools/check/check_curl 2011-06-15 00:03:44.000000000
+++ xen-4.1.1/tools/check/check_curl 2011-10-14 00:42:08.189717078 +0800
@@ -10,4 +10,5 @@

has_or_fail curl-config
curl_libs=`curl-config --libs` || fail "curl-config --libs failed"
+curl_libs=`curl-config --libs` || fail "curl-config --libs failed"
test_link $curl_libs || fail "dependency libraries for curl are missing"

after right patching works fine :)

Configure bugmail: http://bugzilla.xensource.com/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

Xen-bugs mailing list
Xen-bugs [at] lists

Xen bugs RSS feed   Index | Next | Previous | View Threaded

Interested in having your list archived? Contact Gossamer Threads
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.