Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: Xen: Bugs

[Bug 1769] xl created hvm windows gets stuck after guest reboot

 

 

Xen bugs RSS feed   Index | Next | Previous | View Threaded


bugzilla-daemon at lists

Sep 24, 2011, 3:44 PM

Post #1 of 9 (2722 views)
Permalink
[Bug 1769] xl created hvm windows gets stuck after guest reboot

http://bugzilla.xensource.com/bugzilla/show_bug.cgi?id=1769


mark [at] voidzero changed:

What |Removed |Added
----------------------------------------------------------------------------
CC| |mark [at] voidzero




------- Comment #5 from mark [at] voidzero 2011-09-24 15:44 -------
Yes, when I destroy a HVM domain this occurs for me as well, even on latest xen
unstable.


--
Configure bugmail: http://bugzilla.xensource.com/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

_______________________________________________
Xen-bugs mailing list
Xen-bugs [at] lists
http://lists.xensource.com/xen-bugs


bugzilla-daemon at lists

Sep 26, 2011, 9:40 AM

Post #2 of 9 (2634 views)
Permalink
[Bug 1769] xl created hvm windows gets stuck after guest reboot [In reply to]

http://bugzilla.xensource.com/bugzilla/show_bug.cgi?id=1769





------- Comment #6 from konrad.wilk [at] oracle 2011-09-26 09:40 -------
I believe the bug got corrected in 4.1.1, but just to make sure.. Can you
(after shutting the guest down), also run kill the qemu-dm process that is
still present for your domain?Does it work then?


--
Configure bugmail: http://bugzilla.xensource.com/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

_______________________________________________
Xen-bugs mailing list
Xen-bugs [at] lists
http://lists.xensource.com/xen-bugs


bugzilla-daemon at lists

Sep 26, 2011, 1:24 PM

Post #3 of 9 (2642 views)
Permalink
[Bug 1769] xl created hvm windows gets stuck after guest reboot [In reply to]

http://bugzilla.xensource.com/bugzilla/show_bug.cgi?id=1769





------- Comment #7 from mark [at] voidzero 2011-09-26 13:24 -------
for me counts that there was no qemu-dm process, in fact, i could not even find
the ID for the domain anywhere, also not with xenstore-ls. So I was kind of at
a loss. Where is that data stored / where does xl grab it from?


--
Configure bugmail: http://bugzilla.xensource.com/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

_______________________________________________
Xen-bugs mailing list
Xen-bugs [at] lists
http://lists.xensource.com/xen-bugs


bugzilla-daemon at lists

Oct 7, 2011, 7:38 AM

Post #4 of 9 (2719 views)
Permalink
[Bug 1769] xl created hvm windows gets stuck after guest reboot [In reply to]

http://bugzilla.xensource.com/bugzilla/show_bug.cgi?id=1769





------- Comment #8 from lev.v.kuznetsov [at] gmail 2011-10-07 07:38 -------
I got the same thing while installing Debian as HVM with xl create, dom0 is
debian kernel 3.0 x64 with upstream xen version 4.1.1 (Debian 4.1.1-2). DomU
got stuck on the reboot after install. I get the same errors trying to destroy
by ID, here's list -v output:

levk [at] tortug:~$ sudo xl list -v
Name ID Mem VCPUs State Time(s)
UUID Reason-Code
Domain-0 0 1820 4 r----- 31412.6
00000000-0000-0000-0000-000000000000 -
isla-de-muerta 56 4091 2 -b---- 6738.1
822b9df2-eb71-11e0-b55f-0024e845eb74 -
(null) 57 409 2 --psrd 82.9
400d2a0c-f0ea-11e0-bdc4-0024e845eb74 1

I can't find any way to attach so I'm pasting inline,

qemu-dm-X.log:

domid: 57
-videoram option does not work with cirrus vga device model. Videoram set to
4M.
Using file /dev/vg-store/davy-jones-locker in read-write mode
Strip off blktap sub-type prefix to
/usr/share/xen/iso/debian-6.0.2.1-netinst-amd64.iso (drv 'aio')
Using file /usr/share/xen/iso/debian-6.0.2.1-netinst-amd64.iso in read-only
mode
Watching /local/domain/0/device-model/57/logdirty/cmd
Watching /local/domain/0/device-model/57/command
Watching /local/domain/57/cpu
char device redirected to /dev/pts/5
qemu_map_cache_init nr_buckets = 10000 size 4194304
shared page at pfn feffd
buffered io page at pfn feffb
Guest uuid = 400d2a0c-f0ea-11e0-bdc4-0024e845eb74
xen be core: xen be core: can't open gnttab device
can't open gnttab device
xen be core: xen be core: can't open gnttab device
can't open gnttab device
populating video RAM at ff000000
mapping video RAM from ff000000
Register xen platform.
Done register platform.
platform_fixed_ioport: changed ro/rw state of ROM memory area. now is rw state.
xs_read(/local/domain/0/device-model/57/xen_extended_power_mgmt): read error
medium change watch on `hdb' (index: 1):
aio:/usr/share/xen/iso/debian-6.0.2.1-netinst-amd64.iso
I/O request not ready: 0, ptr: 0, port: 0, data: 0, count: 0, size: 0
Log-dirty: no command yet.
I/O request not ready: 0, ptr: 0, port: 0, data: 0, count: 0, size: 0
vcpu-set: watch node error.
xs_read(/local/domain/57/log-throttling): read error
qemu: ignoring not-understood drive `/local/domain/57/log-throttling'
medium change watch on `/local/domain/57/log-throttling' - unknown device,
ignored
xen be core: xen be core: can't open gnttab device
can't open gnttab device
xen be core: xen be core: can't open gnttab device
can't open gnttab device
xen be core: xen be core: can't open gnttab device
can't open gnttab device
xen be core: xen be core: can't open gnttab device
can't open gnttab device
xen be core: xen be core: can't open gnttab device
can't open gnttab device
xen be core: xen be core: can't open gnttab device
can't open gnttab device
xen be core: xen be core: can't open gnttab device
can't open gnttab device
xen be core: xen be core: can't open gnttab device
can't open gnttab device
xen be core: xen be core: can't open gnttab device
can't open gnttab device
cirrus vga map change while on lfb mode
mapping vram to f0000000 - f0400000
platform_fixed_ioport: changed ro/rw state of ROM memory area. now is rw state.
platform_fixed_ioport: changed ro/rw state of ROM memory area. now is ro state.
Unknown PV product 3 loaded in guest
PV driver build 1
region type 1 at [.c100,c120).
Time offset set 4, added offset 4
reset requested in cpu_handle_ioreq.
Issued domain 57 reboot
medium change watch on `hdb' (index: 1): aio:
medium change watch on `hdb' (index: 1): aio:
xen be core: xen be core: can't open gnttab device
can't open gnttab device
xen be core: xen be core: can't open gnttab device
can't open gnttab device
xen be core: xen be core: can't open gnttab device
can't open gnttab device
xen be core: xen be core: can't open gnttab device
can't open gnttab device
xen be core: xen be core: can't open gnttab device
can't open gnttab device
xen be core: xen be core: can't open gnttab device
can't open gnttab device
xen be core: xen be core: can't open gnttab device
can't open gnttab device
xen be core: xen be core: can't open gnttab device
can't open gnttab device
xen be core: xen be core: can't open gnttab device
can't open gnttab device
xen be core: xen be core: can't open gnttab device
can't open gnttab device
xen be core: xen be core: can't open gnttab device
can't open gnttab device
xen be core: xen be core: can't open gnttab device
can't open gnttab device
xen be core: xen be core: can't open gnttab device
can't open gnttab device
xen be core: xen be core: can't open gnttab device
can't open gnttab device
vcpu-set: watch node error.
xs_read(/local/domain/57/log-throttling): read error
qemu: ignoring not-understood drive `/local/domain/57/log-throttling'
medium change watch on `/local/domain/57/log-throttling' - unknown device,
ignored

xl-X.log:

Waiting for domain davy-jones-locker (domid 57) to die [pid 27577]

and this is xen-hotplug.log:

RTNETLINK answers: Operation not supported
RTNETLINK answers: Operation not supported
RTNETLINK answers: Operation not supported
RTNETLINK answers: Operation not supported
RTNETLINK answers: Operation not supported
RTNETLINK answers: Operation not supported
RTNETLINK answers: Operation not supported
Cannot find device "tap10.0"
/etc/xen/scripts/locking.sh: line 109: /var/run/xen-hotplug/block/owner: No
such file or directory
Cannot find device "tap11.0"
RTNETLINK answers: Operation not supported
Cannot find device "tap12.0"
RTNETLINK answers: Operation not supported
/etc/xen/scripts/locking.sh: line 109: /var/run/xen-hotplug/block/owner: No
such file or directory
xenstore-read: couldn't read path backend/vbd/12/2064/node
RTNETLINK answers: Operation not supported
Cannot find device "tap13.0"
xenstore-read: couldn't read path backend/vbd/13/2064/node
Cannot find device "vif14.0"
Cannot find device "tap14.0"
/etc/xen/scripts/locking.sh: line 109: /var/run/xen-hotplug/block/owner: No
such file or directory
RTNETLINK answers: Operation not supported
Cannot find device "tap15.0"
xenstore-read: couldn't read path backend/vbd/15/2064/node
RTNETLINK answers: Operation not supported
RTNETLINK answers: Operation not supported
RTNETLINK answers: Operation not supported
RTNETLINK answers: Operation not supported
RTNETLINK answers: Operation not supported
RTNETLINK answers: Operation not supported
RTNETLINK answers: Operation not supported
RTNETLINK answers: Operation not supported
RTNETLINK answers: Operation not supported
RTNETLINK answers: Operation not supported
RTNETLINK answers: Operation not supported
/etc/xen/scripts/locking.sh: line 109: /var/run/xen-hotplug/block/owner: No
such file or directory
RTNETLINK answers: Operation not supported
RTNETLINK answers: Operation not supported
RTNETLINK answers: Operation not supported
RTNETLINK answers: Operation not supported
RTNETLINK answers: Operation not supported
RTNETLINK answers: Operation not supported
RTNETLINK answers: Operation not supported
RTNETLINK answers: Operation not supported
RTNETLINK answers: Operation not supported
xenstore-read: couldn't read path backend/vbd/17/5632/params
xenstore-read: couldn't read path backend/vbd/17/5696/params
RTNETLINK answers: Operation not supported
RTNETLINK answers: Operation not supported
RTNETLINK answers: Operation not supported
RTNETLINK answers: Operation not supported
Cannot find device "tap22.0"
Cannot find device "tap23.0"
RTNETLINK answers: Operation not supported
/etc/xen/scripts/locking.sh: line 109: /var/run/xen-hotplug/block/owner: No
such file or directory
RTNETLINK answers: Operation not supported
RTNETLINK answers: Operation not supported
RTNETLINK answers: Operation not supported
RTNETLINK answers: Operation not supported
RTNETLINK answers: Operation not supported
RTNETLINK answers: Operation not supported
RTNETLINK answers: Operation not supported
RTNETLINK answers: Operation not supported
RTNETLINK answers: Operation not supported
RTNETLINK answers: Operation not supported
RTNETLINK answers: Operation not supported
RTNETLINK answers: Operation not supported
RTNETLINK answers: Operation not supported
RTNETLINK answers: Operation not supported
RTNETLINK answers: Operation not supported
RTNETLINK answers: Operation not supported
RTNETLINK answers: Operation not supported
RTNETLINK answers: Operation not supported
RTNETLINK answers: Operation not supported
RTNETLINK answers: Operation not supported
RTNETLINK answers: Operation not supported
RTNETLINK answers: Operation not supported
RTNETLINK answers: Operation not supported
RTNETLINK answers: Operation not supported
/etc/xen/scripts/locking.sh: line 109: /var/run/xen-hotplug/block/owner: No
such file or directory
RTNETLINK answers: Operation not supported
RTNETLINK answers: Operation not supported


--
Configure bugmail: http://bugzilla.xensource.com/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

_______________________________________________
Xen-bugs mailing list
Xen-bugs [at] lists
http://lists.xensource.com/xen-bugs


bugzilla-daemon at lists

Oct 7, 2011, 12:10 PM

Post #5 of 9 (2631 views)
Permalink
[Bug 1769] xl created hvm windows gets stuck after guest reboot [In reply to]

http://bugzilla.xensource.com/bugzilla/show_bug.cgi?id=1769





------- Comment #9 from konrad.wilk [at] oracle 2011-10-07 12:10 -------
That "xen be core: xen be core: can't open gnttab device" sure points to
something fishy.

Did you build the kernel yourself? If so, did you enable all the XEN modules to
be built in? Or if not, did you load them all?


--
Configure bugmail: http://bugzilla.xensource.com/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

_______________________________________________
Xen-bugs mailing list
Xen-bugs [at] lists
http://lists.xensource.com/xen-bugs


bugzilla-daemon at lists

Oct 7, 2011, 12:11 PM

Post #6 of 9 (2637 views)
Permalink
[Bug 1769] xl created hvm windows gets stuck after guest reboot [In reply to]

http://bugzilla.xensource.com/bugzilla/show_bug.cgi?id=1769





------- Comment #10 from konrad.wilk [at] oracle 2011-10-07 12:11 -------
Hm, is there an Wiki, URL that details how to install Xen on Gentoo? Or is
quite easy?


--
Configure bugmail: http://bugzilla.xensource.com/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

_______________________________________________
Xen-bugs mailing list
Xen-bugs [at] lists
http://lists.xensource.com/xen-bugs


bugzilla-daemon at lists

Oct 7, 2011, 12:26 PM

Post #7 of 9 (2628 views)
Permalink
[Bug 1769] xl created hvm windows gets stuck after guest reboot [In reply to]

http://bugzilla.xensource.com/bugzilla/show_bug.cgi?id=1769





------- Comment #11 from lev.v.kuznetsov [at] gmail 2011-10-07 12:26 -------
I did not build the kernel, it's from Debian/unstable; here's the full uname:

levk [at] tortug:/etc/xen/auto$ uname -a
Linux tortuga 3.0.0-1-amd64 #1 SMP Tue Sep 20 07:03:13 UTC 2011 x86_64
GNU/Linux


--
Configure bugmail: http://bugzilla.xensource.com/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

_______________________________________________
Xen-bugs mailing list
Xen-bugs [at] lists
http://lists.xensource.com/xen-bugs


bugzilla-daemon at lists

Oct 7, 2011, 12:35 PM

Post #8 of 9 (2630 views)
Permalink
[Bug 1769] xl created hvm windows gets stuck after guest reboot [In reply to]

http://bugzilla.xensource.com/bugzilla/show_bug.cgi?id=1769





------- Comment #12 from lev.v.kuznetsov [at] gmail 2011-10-07 12:35 -------
Just wanted to add, I installed xen from Debian unstable repos basically
following this guide: http://wiki.debian.org/Xen I have other HVM domUs and
this has never happened to any of them. I haven't rebooted my dom0 yet for
other reasons, so I don't know if this is going to persist anyway. Here's the
config for the effected domU:

levk [at] tortug:/etc/xen/auto$ grep -v "^#" ../sys/davy-jones-locker | grep -v
"^$"
kernel = "hvmloader"
builder = 'hvm'
memory = 4096
memory_sharing = 1
name = "davy-jones-locker"
uuid = "400d2a0c-f0ea-11e0-bdc4-0024e845eb74"
vcpus = 2
vif = [ 'mac=00:16:3E:1B:ED:45, type=ioemu, bridge=xenbr0, model=virtio' ]
disk = [ 'phy:/dev/vg-store/davy-jones-locker,hda,w',
'file:/usr/share/xen/iso/debian-6.0.2.1-netinst-amd64.iso,hdb:cdrom,r' ]
on_poweroff = 'destroy'
on_reboot = 'restart'
on_crash = 'destroy'
device_model = 'qemu-dm'
boot = "cd"
sdl = 0
opengl = 1
vnc = 1
vnclisten = "0.0.0.0"
vncpasswd=''
stdvga = 0
serial = 'pty'
tsc_mode = 0


--
Configure bugmail: http://bugzilla.xensource.com/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

_______________________________________________
Xen-bugs mailing list
Xen-bugs [at] lists
http://lists.xensource.com/xen-bugs


bugzilla-daemon at lists

Oct 13, 2011, 10:46 AM

Post #9 of 9 (2613 views)
Permalink
[Bug 1769] xl created hvm windows gets stuck after guest reboot [In reply to]

http://bugzilla.xensource.com/bugzilla/show_bug.cgi?id=1769





------- Comment #13 from konrad.wilk [at] oracle 2011-10-13 10:46 -------
(In reply to comment #12)
> Just wanted to add, I installed xen from Debian unstable repos basically
> following this guide: http://wiki.debian.org/Xen I have other HVM domUs and
> this has never happened to any of them. I haven't rebooted my dom0 yet for
> other reasons, so I don't know if this is going to persist anyway. Here's the
> config for the effected domU:
>
> levk [at] tortug:/etc/xen/auto$ grep -v "^#" ../sys/davy-jones-locker | grep -v
> "^$"
> kernel = "hvmloader"
> builder = 'hvm'
> memory = 4096
> memory_sharing = 1
> name = "davy-jones-locker"
> uuid = "400d2a0c-f0ea-11e0-bdc4-0024e845eb74"
> vcpus = 2
> vif = [ 'mac=00:16:3E:1B:ED:45, type=ioemu, bridge=xenbr0, model=virtio' ]

Doing model=virtio will definitely be a problem.

> disk = [ 'phy:/dev/vg-store/davy-jones-locker,hda,w',
> 'file:/usr/share/xen/iso/debian-6.0.2.1-netinst-amd64.iso,hdb:cdrom,r' ]
> on_poweroff = 'destroy'
> on_reboot = 'restart'
> on_crash = 'destroy'
> device_model = 'qemu-dm'
> boot = "cd"
> sdl = 0
> opengl = 1
> vnc = 1
> vnclisten = "0.0.0.0"
> vncpasswd=''
> stdvga = 0
> serial = 'pty'
> tsc_mode = 0
>


--
Configure bugmail: http://bugzilla.xensource.com/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

_______________________________________________
Xen-bugs mailing list
Xen-bugs [at] lists
http://lists.xensource.com/xen-bugs

Xen bugs RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.