Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: Wikipedia: Mediawiki

Getting sourceforge's mediawiki to run locally

 

 

Wikipedia mediawiki RSS feed   Index | Next | Previous | View Threaded


fnatter at gmx

Mar 17, 2012, 12:09 PM

Post #1 of 3 (481 views)
Permalink
Getting sourceforge's mediawiki to run locally

hello,

I downloaded a project wiki from sourceforge (mediawiki 1.14.1),
configured apache with php 5.3.10 in /home/felix/public_html as
localhost/~felix and copied the wiki/ directory to
/home/felix/public_html.

I configured php with display_errors=On, and I have seen php errors in
the browser window until I did a "chmod -R 777 wiki/". Once that is
fixed, I simply get an empty page when requesting index.php.

I don't see any relevant errors in the apache2 error log
(and couldn't find any php log).

The affected wiki is here:
http://freeplane.sourceforge.net/wiki/index.php/Main_Page
(yes, the color is terrible, that's why I'm working on it ;-)

How can I debug this?

Thanks in advance!
--
Felix Natter

_______________________________________________
MediaWiki-l mailing list
MediaWiki-l [at] lists
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l


jeremy at tuxmachine

Mar 17, 2012, 12:41 PM

Post #2 of 3 (461 views)
Permalink
Re: Getting sourceforge's mediawiki to run locally [In reply to]

On Sat, Mar 17, 2012 at 15:09, Felix Natter <fnatter [at] gmx> wrote:
> I downloaded a project wiki from sourceforge (mediawiki 1.14.1),
> configured apache with php 5.3.10 in /home/felix/public_html as
> localhost/~felix and copied the wiki/ directory to
> /home/felix/public_html.

I'm not sure what this means. You just inherited a MediaWiki instance
that was already at v1.14.1? Have you tried to move it or is it in
it's original location? (if so, how did you move it?)

[...]
> How can I debug this?

http://www.mediawiki.org/wiki/Manual:How_to_debug

-Jeremy

_______________________________________________
MediaWiki-l mailing list
MediaWiki-l [at] lists
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l


fnatter at gmx

Mar 18, 2012, 2:45 AM

Post #3 of 3 (459 views)
Permalink
Re: Getting sourceforge's mediawiki to run locally [In reply to]

Jeremy Baron <jeremy [at] tuxmachine> writes:

hello Jeremy,

> On Sat, Mar 17, 2012 at 15:09, Felix Natter <fnatter [at] gmx> wrote:
>> I downloaded a project wiki from sourceforge (mediawiki 1.14.1),
>> configured apache with php 5.3.10 in /home/felix/public_html as
>> localhost/~felix and copied the wiki/ directory to
>> /home/felix/public_html.
>
> I'm not sure what this means. You just inherited a MediaWiki instance
> that was already at v1.14.1? Have you tried to move it or is it in

Yes. Meanwhile a colleague help me to fix this by rerunning the
mediawiki-1.14.1 setup contained in the wiki snapshot which also sets up
a (blank) database.

Sorry, didn't know about that.

Thanks!
--
Felix Natter

_______________________________________________
MediaWiki-l mailing list
MediaWiki-l [at] lists
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l

Wikipedia mediawiki RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.