Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: Varnish: Bugs

#1128: GZIP encoding with multiple members

 

 

Varnish bugs RSS feed   Index | Next | Previous | View Threaded


varnish-bugs at varnish-cache

Apr 23, 2012, 7:46 AM

Post #1 of 7 (304 views)
Permalink
#1128: GZIP encoding with multiple members

#1128: GZIP encoding with multiple members
--------------------------------------------+-------------------------------
Reporter: zviratko | Type: defect
Status: new | Priority: normal
Milestone: | Component: varnishd
Version: 3.0.0 | Severity: normal
Keywords: gzip encoding multiple streams |
--------------------------------------------+-------------------------------
GZIP RFC allows multiple streams to be concatenated and then decompressed
as one.
Varnish fails in this scenario with:

{{{
FetchError c straight read_error: -1 0 (Junk after gzip data)
}}}

Client is served a 503.

In my case, the data in question is a JSON response made from two chunks,
each compressed in application and served as one response (with correct
headers and length). I confirmed the data is fine, and it works fine in
browsers (apart from chrome/chromium that has a bug here as well).

The only solution around this not serving it compressed to varnish, or
using pipe.

Attached is an example that causes this bug.

--
Ticket URL: <https://www.varnish-cache.org/trac/ticket/1128>
Varnish <https://varnish-cache.org/>
The Varnish HTTP Accelerator

_______________________________________________
varnish-bugs mailing list
varnish-bugs [at] varnish-cache
https://www.varnish-cache.org/lists/mailman/listinfo/varnish-bugs


varnish-bugs at varnish-cache

Apr 23, 2012, 7:49 AM

Post #2 of 7 (296 views)
Permalink
Re: #1128: GZIP encoding with multiple members [In reply to]

#1128: GZIP encoding with multiple members
-------------------------+--------------------------------------------------
Reporter: zviratko | Type: defect
Status: closed | Priority: normal
Milestone: | Component: varnishd
Version: 3.0.0 | Severity: normal
Resolution: worksforme | Keywords: gzip encoding multiple streams
-------------------------+--------------------------------------------------
Changes (by phk):

* status: new => closed
* resolution: => worksforme


Comment:

Yes, the RFC allows it, but none of the web-browsers I examined support
it, so I decided that Varnish should not either.

--
Ticket URL: <https://www.varnish-cache.org/trac/ticket/1128#comment:1>
Varnish <https://varnish-cache.org/>
The Varnish HTTP Accelerator

_______________________________________________
varnish-bugs mailing list
varnish-bugs [at] varnish-cache
https://www.varnish-cache.org/lists/mailman/listinfo/varnish-bugs


varnish-bugs at varnish-cache

Apr 23, 2012, 7:52 AM

Post #3 of 7 (293 views)
Permalink
Re: #1128: GZIP encoding with multiple members [In reply to]

#1128: GZIP encoding with multiple members
-----------------------+----------------------------------------------------
Reporter: zviratko | Type: defect
Status: reopened | Priority: normal
Milestone: | Component: varnishd
Version: 3.0.0 | Severity: normal
Resolution: | Keywords: gzip encoding multiple streams
-----------------------+----------------------------------------------------
Changes (by zviratko):

* status: closed => reopened
* resolution: worksforme =>


Comment:

Firefox 11.0 supports it
IE8 supports it
Chrome fails, but I filed them a separate bug, so I hope they will fix it.

you see this for yourself by visiting
http://beta.jobs.cz/firma/a
and using pagination (it fails in chrome rightaway).
But it works in FF and IE without problems.

Please consider fixing it, it is only a matter of time before somebody
else gets hit by this and it is a PITA to find and debug. While I believe
in your KISS approach, it should not hinder bugfixing :-)

--
Ticket URL: <https://www.varnish-cache.org/trac/ticket/1128#comment:2>
Varnish <https://varnish-cache.org/>
The Varnish HTTP Accelerator

_______________________________________________
varnish-bugs mailing list
varnish-bugs [at] varnish-cache
https://www.varnish-cache.org/lists/mailman/listinfo/varnish-bugs


varnish-bugs at varnish-cache

Apr 23, 2012, 8:05 AM

Post #4 of 7 (294 views)
Permalink
Re: #1128: GZIP encoding with multiple members [In reply to]

#1128: GZIP encoding with multiple members
-----------------------+----------------------------------------------------
Reporter: zviratko | Type: defect
Status: closed | Priority: normal
Milestone: | Component: varnishd
Version: 3.0.0 | Severity: normal
Resolution: invalid | Keywords: gzip encoding multiple streams
-----------------------+----------------------------------------------------
Changes (by phk):

* status: reopened => closed
* resolution: => invalid


Comment:

That's fine, but then it is a feature request, please add it to one of the
Future_ wiki pages.

--
Ticket URL: <https://www.varnish-cache.org/trac/ticket/1128#comment:3>
Varnish <https://varnish-cache.org/>
The Varnish HTTP Accelerator

_______________________________________________
varnish-bugs mailing list
varnish-bugs [at] varnish-cache
https://www.varnish-cache.org/lists/mailman/listinfo/varnish-bugs


varnish-bugs at varnish-cache

Apr 23, 2012, 8:08 AM

Post #5 of 7 (291 views)
Permalink
Re: #1128: GZIP encoding with multiple members [In reply to]

#1128: GZIP encoding with multiple members
-----------------------+----------------------------------------------------
Reporter: zviratko | Type: defect
Status: reopened | Priority: normal
Milestone: | Component: varnishd
Version: 3.0.0 | Severity: normal
Resolution: | Keywords: gzip encoding multiple streams
-----------------------+----------------------------------------------------
Changes (by zviratko):

* status: closed => reopened
* resolution: invalid =>


Comment:

Nope, this breaks expected RFC functionality - it is a bug.

--
Ticket URL: <https://www.varnish-cache.org/trac/ticket/1128#comment:4>
Varnish <https://varnish-cache.org/>
The Varnish HTTP Accelerator

_______________________________________________
varnish-bugs mailing list
varnish-bugs [at] varnish-cache
https://www.varnish-cache.org/lists/mailman/listinfo/varnish-bugs


varnish-bugs at varnish-cache

Apr 23, 2012, 8:37 AM

Post #6 of 7 (295 views)
Permalink
Re: #1128: GZIP encoding with multiple members [In reply to]

#1128: GZIP encoding with multiple members
-----------------------+----------------------------------------------------
Reporter: zviratko | Type: defect
Status: closed | Priority: normal
Milestone: | Component: varnishd
Version: 3.0.0 | Severity: normal
Resolution: invalid | Keywords: gzip encoding multiple streams
-----------------------+----------------------------------------------------
Changes (by phk):

* status: reopened => closed
* resolution: => invalid


Comment:

Listen, I asked you to put it in a Future_ wiki page because I call it a
feature request.

You may feel otherwise, but if I call it a feature request, that it is.

--
Ticket URL: <https://www.varnish-cache.org/trac/ticket/1128#comment:5>
Varnish <https://varnish-cache.org/>
The Varnish HTTP Accelerator

_______________________________________________
varnish-bugs mailing list
varnish-bugs [at] varnish-cache
https://www.varnish-cache.org/lists/mailman/listinfo/varnish-bugs


varnish-bugs at varnish-cache

Apr 22, 2014, 2:15 PM

Post #7 of 7 (72 views)
Permalink
Re: #1128: GZIP encoding with multiple members [In reply to]

#1128: GZIP encoding with multiple members
--------------------------------------------+----------------------
Reporter: zviratko | Owner:
Type: defect | Status: closed
Priority: normal | Milestone:
Component: varnishd | Version: 3.0.0
Severity: normal | Resolution: invalid
Keywords: gzip encoding multiple streams |
--------------------------------------------+----------------------

Comment (by keretamalam):

I am about to leave and cannot look into this further right now, but I do
want to mention that relying on pkg-config itself is not a problem (as you
said, we also use it later), the problem is that on some systems, the .pc
file for pkg-config is supplying wrong information (whereas on yours, it's
botan-config that is wrong), so that's why I'm trying to make it work with
both (while one of them is bad).
[http://maskodoq.blogspot.com/2014/03/unit-link-terbaik-di-indonesia.html
Unit Link Terbaik di Indonesia Commonwealth Life Investra Link]
[http://maskodoq.blogspot.com/2013/07/CiptoJunaedy.html Cipto Junaedy]
[http://etnisjawa.blogspot.com/2013/08/apakah-cipto-junaedy-bohong.html
Cipto Junaedy]

--
Ticket URL: <https://www.varnish-cache.org/trac/ticket/1128#comment:6>
Varnish <https://varnish-cache.org/>
The Varnish HTTP Accelerator

_______________________________________________
varnish-bugs mailing list
varnish-bugs [at] varnish-cache
https://www.varnish-cache.org/lists/mailman/listinfo/varnish-bugs

Varnish bugs RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.