Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: Varnish: Bugs

#1108: SIGBUS during Deflate

 

 

Varnish bugs RSS feed   Index | Next | Previous | View Threaded


varnish-bugs at varnish-cache

Mar 17, 2012, 11:39 AM

Post #1 of 4 (245 views)
Permalink
#1108: SIGBUS during Deflate

#1108: SIGBUS during Deflate
---------------------+------------------------------------------------------
Reporter: phobe77 | Type: defect
Status: new | Priority: normal
Milestone: | Component: varnishd
Version: 3.0.2 | Severity: normal
Keywords: |
---------------------+------------------------------------------------------
Varnish seems to (randomly?) crash during gzipping content:

{{{
Last panic at: Sat, 17 Mar 2012 06:16:05 GMT
Assert error in vmod_ch_sighandler(), vmod_crashhandler.c line 18:
Condition(Caught signal 7) not true.
thread = (cache-worker)
ident = Linux,2.6.32-5-xen-amd64,x86_64,-sfile,-smalloc,-hcritbit,epoll
Backtrace:
0x4307a5: /usr/sbin/varnishd() [0x4307a5]
0x7f80ef4e8a77:
/usr/lib/varnish/vmods/libvmod_crashhandler.so(vmod_ch_sighandler+0x47)
[0x7f80ef4e8a77]
0x7f8878a5c230: /lib/libc.so.6(+0x32230) [0x7f8878a5c230]
0x7f8878aa9a4b: /lib/libc.so.6(memcpy+0x15b) [0x7f8878aa9a4b]
0x7f8879884163: /usr/lib/varnish/libvgz.so(+0x2163) [0x7f8879884163]
0x7f8879884922: /usr/lib/varnish/libvgz.so(+0x2922) [0x7f8879884922]
0x7f8879885521: /usr/lib/varnish/libvgz.so(deflate+0x121)
[0x7f8879885521]
0x426909: /usr/sbin/varnishd(VGZ_Gzip+0xa9) [0x426909]
0x41ed2a: /usr/sbin/varnishd() [0x41ed2a]
0x421186: /usr/sbin/varnishd(VEP_Finish+0xa6) [0x421186]
sp = 0x7f80be543008 {
fd = 12, id = 12, xid = 1221668465,
client = 10.255.128.2 32830,
step = STP_FETCHBODY,
handling = deliver,
err_code = 200, err_reason = (null),
restarts = 0, esi_level = 0
flags = do_esi is_gzip
bodystatus = 3
ws = 0x7f80be543080 {
id = "sess",
{s,f,r,e} = {0x7f80be543c90,+504,(nil),+262144},
},
http[req] = {
ws = 0x7f80be543080[sess]
"HEAD",
"/bw-egas-eethen/7731064140411661",
"HTTP/1.1",
"Host: www.klusbedrijf-wijzer.nl",
"Pragma: no-cache",
"Accept: */*",
"Proxy-Connection: Keep-Alive",
"X-Prime: true",
"X-Real-IP: 10.255.128.2",
"X-UA-Browser: unk",
"X-UA-Render: unk",
"X-UA-Device: unk",
"X-Forwarded-For: 10.255.128.2",
},
worker = 0x7f80adcf7ab0 {
ws = 0x7f80adcf7cf0 {
id = "wrk",
{s,f,r,e} = {0x7f80adce5a40,+2624,(nil),+65536},
},
http[bereq] = {
ws = 0x7f80adcf7cf0[wrk]
"GET",
"/bw-egas-eethen/7731064140411661",
"HTTP/1.1",
"Host: www.klusbedrijf-wijzer.nl",
"Pragma: no-cache",
"Accept: */*",
"Proxy-Connection: Keep-Alive",
"X-Prime: true",
"X-Real-IP: 10.255.128.2",
"X-UA-Browser: unk",
"X-UA-Render: unk",
"X-UA-Device: unk",
"X-Forwarded-For: 10.255.128.2",
"X-Varnish: 1221668465",
"Accept-Encoding: gzip",
},
http[beresp] = {
ws = 0x7f80adcf7cf0[wrk]
"HTTP/1.1",
"200",
"OK",
"P3P: CP="NOI ADM DEV PSAi COM NAV OUR OTRo STP IND DEM"",
"X-Depends: vcard-NL9fb5ef5e-c145-102d-aa25-00163e221d37, vcard-
NL184fb9e6-c131-102d-aa25-00163e221d37, vcard-NLa1707800-c145-102d-
aa25-00163e221d37, vcard-NL802227ec-c155-102d-aa25-00163e221d37, vcard-
NLfdfea3ae-c13f-102d-aa25-00163e221d37, vcard-NL26526dde-c147-102d-
aa25-00163e221d37, vcard-NL7c337bce-c158-102d-aa25-00163e221d37, vcard-
NL8b33fdba-c13a-102d-aa25-00163e221d37, vcard-NLe77fbe96-c0af-102d-
aa25-00163e221d37, vcard-NL6c5ab8e6-c141-102d-aa25-00163e221d37, vcard-
NL87b9e540-c145-102d-aa25-00163e221d37, template",
"Content-Type: text/html; charset=utf-8",
"Last-Modified: Sat, 17 Mar 2012 04:19:21 GMT",
"Content-Encoding: gzip",
"Transfer-Encoding: chunked",
"Date: Sat, 17 Mar 2012 04:19:21 GMT",
"X-Request-Path: /bw-egas-eethen/7731064140411661",
"X-Request-Url: www.klusbedrijf-wijzer.nl/bw-egas-
eethen/7731064140411661",
"Vary: Accept-Encoding,Cookie",
"X-Reset-Age: true",
"Cache-Control: public,max-age=86400",
"X-I: yp-85,http6",
},
},
vcl = {
srcname = {
"input",
"Default",
"useragent.vcl",
"purge.vcl",
},
},
obj = 0x7f86d7e0a000 {
xid = 1221668465,
ws = 0x7f86d7e0a018 {
id = "obj",
{s,f,r,e} = {0x7f86d7e0a258,+1056,(nil),+1104},
},
http[obj] = {
ws = 0x7f86d7e0a018[obj]
"HTTP/1.1",
"OK",
"P3P: CP="NOI ADM DEV PSAi COM NAV OUR OTRo STP IND DEM"",
"X-Depends: vcard-NL9fb5ef5e-c145-102d-aa25-00163e221d37, vcard-
NL184fb9e6-c131-102d-aa25-00163e221d37, vcard-NLa1707800-c145-102d-
aa25-00163e221d37, vcard-NL802227ec-c155-102d-aa25-00163e221d37, vcard-
NLfdfea3ae-c13f-102d-aa25-00163e221d37, vcard-NL26526dde-c147-102d-
aa25-00163e221d37, vcard-NL7c337bce-c158-102d-aa25-00163e221d37, vcard-
NL8b33fdba-c13a-102d-aa25-00163e221d37, vcard-NLe77fbe96-c0af-102d-
aa25-00163e221d37, vcard-NL6c5ab8e6-c141-102d-aa25-00163e221d37, vcard-
NL87b9e540-c145-102d-aa25-00163e221d37, template",
"Content-Type: text/html; charset=utf-8",
"Last-Modified: Sat, 17 Mar 2012 04:19:21 GMT",
"Content-Encoding: gzip",
"Date: Sat, 17 Mar 2012 04:19:21 GMT",
"X-Request-Path: /bw-egas-eethen/7731064140411661",
"X-Request-Url: www.klusbedrijf-wijzer.nl/bw-egas-
eethen/7731064140411661",
"Vary: Accept-Encoding,Cookie",
"X-Reset-Age: true",
"Cache-Control: public,max-age=86400",
"X-I: yp-85,http6",
},
len = 3813,
store = {
3813 {
1f 8b 08 00 00 00 00 00 00 03 02 00 00 00 ff ff |................|
6c 90 4d 4f c2 40 10 86 ef 24 fe 87 71 4f 9a d8 |l.MO.@...$..qO..|
ae 84 8b 08 e5 c0 47 a2 06 85 68 8d 7a 5c da 81 |......G...h.z\..|
2e 6e 67 71 3b b4 f8 ef dd 52 34 68 bc ec ee 3b |.ngq;....R4h...;|
[3749 more]
},
},
},
},
}}}

--
Ticket URL: <https://www.varnish-cache.org/trac/ticket/1108>
Varnish <https://varnish-cache.org/>
The Varnish HTTP Accelerator

_______________________________________________
varnish-bugs mailing list
varnish-bugs [at] varnish-cache
https://www.varnish-cache.org/lists/mailman/listinfo/varnish-bugs


varnish-bugs at varnish-cache

Mar 19, 2012, 4:25 AM

Post #2 of 4 (229 views)
Permalink
Re: #1108: SIGBUS during Deflate [In reply to]

#1108: SIGBUS during Deflate
---------------------+------------------------------------------------------
Reporter: phobe77 | Type: defect
Status: new | Priority: normal
Milestone: | Component: varnishd
Version: 3.0.2 | Severity: normal
Keywords: |
---------------------+------------------------------------------------------

Comment(by martin):

Hi,

Do you know anything more specifically how to reproduce this error? How
often does it occur, specific circumstances leading up to it etc.

Please also attach the VCL configuration if possible, and varnishstat
output.

Could you also please confirm if this could be a out-of-storage situation?
Is the file used for -sfile backing sparse?

Martin

--
Ticket URL: <https://www.varnish-cache.org/trac/ticket/1108#comment:1>
Varnish <https://varnish-cache.org/>
The Varnish HTTP Accelerator

_______________________________________________
varnish-bugs mailing list
varnish-bugs [at] varnish-cache
https://www.varnish-cache.org/lists/mailman/listinfo/varnish-bugs


varnish-bugs at varnish-cache

Mar 19, 2012, 3:04 PM

Post #3 of 4 (228 views)
Permalink
Re: #1108: SIGBUS during Deflate [In reply to]

#1108: SIGBUS during Deflate
---------------------+------------------------------------------------------
Reporter: phobe77 | Type: defect
Status: new | Priority: normal
Milestone: | Component: varnishd
Version: 3.0.2 | Severity: normal
Keywords: |
---------------------+------------------------------------------------------

Comment(by phobe77):

Hi,

after doing some more digging into the system it looks likely that it is a
disk space issue. I think i have set the partition size to close to the
cache size although the cache has never been filled to more than 30%.

Have doubled the available disk space and restarted varnish. Lets see for
a couple of days if this fixes the issue. For now you can close the case.

Thanks for your support.

--
Ticket URL: <https://www.varnish-cache.org/trac/ticket/1108#comment:2>
Varnish <https://varnish-cache.org/>
The Varnish HTTP Accelerator

_______________________________________________
varnish-bugs mailing list
varnish-bugs [at] varnish-cache
https://www.varnish-cache.org/lists/mailman/listinfo/varnish-bugs


varnish-bugs at varnish-cache

Mar 20, 2012, 1:44 AM

Post #4 of 4 (227 views)
Permalink
Re: #1108: SIGBUS during Deflate [In reply to]

#1108: SIGBUS during Deflate
----------------------+-----------------------------------------------------
Reporter: phobe77 | Type: defect
Status: closed | Priority: normal
Milestone: | Component: varnishd
Version: 3.0.2 | Severity: normal
Resolution: invalid | Keywords:
----------------------+-----------------------------------------------------
Changes (by martin):

* status: new => closed
* resolution: => invalid


Comment:

Thanks for the update. I will close this bug.

Martin

--
Ticket URL: <https://www.varnish-cache.org/trac/ticket/1108#comment:3>
Varnish <https://varnish-cache.org/>
The Varnish HTTP Accelerator

_______________________________________________
varnish-bugs mailing list
varnish-bugs [at] varnish-cache
https://www.varnish-cache.org/lists/mailman/listinfo/varnish-bugs

Varnish bugs RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.