Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: Varnish: Bugs

#888: Assert error in ESI_Deliver(), cache_esi_deliver.c line 326

 

 

Varnish bugs RSS feed   Index | Next | Previous | View Threaded


varnish-bugs at varnish-cache

Mar 31, 2011, 7:20 AM

Post #1 of 5 (253 views)
Permalink
#888: Assert error in ESI_Deliver(), cache_esi_deliver.c line 326

#888: Assert error in ESI_Deliver(), cache_esi_deliver.c line 326
--------------------+-------------------------------------------------------
Reporter: perbu | Owner:
Type: defect | Status: new
Priority: normal | Milestone:
Component: build | Version: trunk
Severity: normal | Keywords:
--------------------+-------------------------------------------------------
Spanking new code. As usual, googlebot came along and ruined the uptime.

panic.show: {{{


Last panic at: Thu, 31 Mar 2011 14:12:59 GMT
Assert error in ESI_Deliver(), cache_esi_deliver.c line 326:
Condition(i == VGZ_OK || i == VGZ_END) not true.
thread = (cache-worker)
ident = Linux,2.6.32-30-generic,x86_64,-smalloc,-smalloc,-hcritbit,epoll
Backtrace:
0x42cd28: pan_ic+b8
0x41f6fa: ESI_Deliver+3fa
0x42f878: RES_WriteObj+228
0x416b70: cnt_deliver+230
0x4179fd: CNT_Session+2ed
0x42e4e8: wrk_do_cnt_sess+b8
0x42e971: wrk_thread_real+411
0x7f57899289ca: _end+7f57892b0752
0x7f578968570d: _end+7f578900d495
sp = 0x7f5779035008 {
fd = 13, id = 13, xid = 1767439512,
client = 66.249.71.11 34085,
step = STP_DELIVER,
handling = deliver,
restarts = 0, esi_level = 0
ws = 0x7f5779035080 {
id = "sess",
{s,f,r,e} = {0x7f5779035cf0,+512,(nil),+65536},
},
http[req] = {
ws = 0x7f5779035080[sess]
"GET",
"/trac/changeset?new=6af4255312dc5fa13fa62cdaef27c67af78e2b4c%40bin/varnishd&old=355d66cb3a37fcea513192f2597ddf68f8fabdaa
%40bin/varnishd",
"HTTP/1.1",
"Host: www.varnish-cache.org",
"Connection: Keep-alive",
"Accept: */*",
"From: googlebot(at)googlebot.com",
"User-Agent: Mozilla/5.0 (compatible; Googlebot/2.1;
+http://www.google.com/bot.html)",
"X-Forwarded-For: 66.249.71.11, 66.249.71.11",
},
worker = 0x7f57828dbb70 {
ws = 0x7f57828dbd10 {
id = "wrk",
{s,f,r,e} = {0x7f57828c9b00,+152,(nil),+65536},
},
http[resp] = {
ws = 0x7f57828dbd10[wrk]
"HTTP/1.1",
"200",
"Ok",
"Server: Apache/2.2.14 (Ubuntu)",
"Cache-Control: must-revalidate",
"Vary: Accept-Encoding",

"Content-Type: text/html;charset=utf-8",
"X-ESI: on",
"Transfer-Encoding: chunked",
"Date: Thu, 31 Mar 2011 14:12:58 GMT",
"X-Varnish: 1767439512 1767439483",
"Age: 1",
"Via: 1.1 varnish",
"Connection: keep-alive",
},
},
vcl = {
srcname = {
"input",
"Default",
},
},
obj = 0x7f5778a0a400 {
xid = 1767439483,
ws = 0x7f5778a0a418 {
id = "obj",
{s,f,r,e} = {0x7f5778a0a638,+288,(nil),+312},
},
http[obj] = {
ws = 0x7f5778a0a418[obj]
"HTTP/1.1",
"Ok",
"Date: Thu, 31 Mar 2011 14:12:45 GMT",
"Server: Apache/2.2.14 (Ubuntu)",
"Cache-Control: must-revalidate",
"Vary: Accept-Encoding",
"Content-Encoding: gzip",
"Content-Type: text/html;charset=utf-8",
"X-ESI: on",
"Content-Length: 229494",
},
len = 229494,
store = {
131072 {
1f 8b 08 00 00 00 00 00 00 03 02 00 00 00 ff ff |................|
b2 51 74 f1 77 0e 89 0c 70 55 c8 28 c9 cd 51 08 |.Qt.w...pU.(..Q.|
08 75 f2 f1 74 56 50 d2 d5 d7 0f 37 76 d6 d7 77 |.u..tVP....7v..w|
09 71 51 88 f0 08 f1 f5 51 30 d4 33 50 08 2e 29 |.qQ.....Q0.3P..)|
[131008 more]
},
98422 {
0a 14 4b ca 4f a9 44 15 b6 01 8b 29 24 e7 24 16 |..K.O.D....)$.$.|
17 db 2a 95 e6 e5 e6 a7 28 61 b7 0c c3 3c 54 e9 |..*.....(a...<T.|
0c 3b 0b 03 b0 4b 41 4c a0 f3 a1 ec 14 98 d1 39 |.;...KAL.......9|
4a 76 36 c5 05 89 79 76 b5 36 fa 60 1a 97 d3 a1 |Jv6...yv.6.`....|
[98358 more]
},
},
},
},

}}}

--
Ticket URL: <http://varnish-cache.org/trac/ticket/888>
Varnish <http://varnish-cache.org/>
The Varnish HTTP Accelerator

_______________________________________________
varnish-bugs mailing list
varnish-bugs [at] varnish-cache
http://www.varnish-cache.org/lists/mailman/listinfo/varnish-bugs


varnish-bugs at varnish-cache

Mar 31, 2011, 7:25 AM

Post #2 of 5 (255 views)
Permalink
Re: #888: Assert error in ESI_Deliver(), cache_esi_deliver.c line 326 [In reply to]

#888: Assert error in ESI_Deliver(), cache_esi_deliver.c line 326
--------------------+-------------------------------------------------------
Reporter: perbu | Owner:
Type: defect | Status: new
Priority: normal | Milestone:
Component: build | Version: trunk
Severity: normal | Keywords:
--------------------+-------------------------------------------------------

Comment(by perbu):

NOticed the following in syslog:


Mar 31 16:12:58 odd varnishd[24553]: Child (24555) said WARNING at 15117
ESI 1.0 <esi:include> lacks final '/'
Mar 31 16:12:58 odd varnishd[24553]: Child (24555) said ERROR at 15123 ESI
1.0 </esi:include> illegal end-tag
Mar 31 16:12:59 odd varnishd[24553]: Child (24555) said INFLATE=-3
(invalid stored block lengths)
Mar 31 16:12:59 odd varnishd[24553]: Child (24555) died signal=6

The PID matches the asserting child.

--
Ticket URL: <http://www.varnish-cache.org/trac/ticket/888#comment:1>
Varnish <http://varnish-cache.org/>
The Varnish HTTP Accelerator

_______________________________________________
varnish-bugs mailing list
varnish-bugs [at] varnish-cache
http://www.varnish-cache.org/lists/mailman/listinfo/varnish-bugs


varnish-bugs at varnish-cache

Mar 31, 2011, 10:01 AM

Post #3 of 5 (238 views)
Permalink
Re: #888: Assert error in ESI_Deliver(), cache_esi_deliver.c line 326 [In reply to]

#888: Assert error in ESI_Deliver(), cache_esi_deliver.c line 326
--------------------+-------------------------------------------------------
Reporter: perbu | Owner:
Type: defect | Status: new
Priority: normal | Milestone:
Component: build | Version: trunk
Severity: normal | Keywords:
--------------------+-------------------------------------------------------

Comment(by phk):

Please pull 3c8e5203ebd7ad232c80406511d4288a41a6fc87 (or later) and try
again.

--
Ticket URL: <http://www.varnish-cache.org/trac/ticket/888#comment:2>
Varnish <http://varnish-cache.org/>
The Varnish HTTP Accelerator

_______________________________________________
varnish-bugs mailing list
varnish-bugs [at] varnish-cache
http://www.varnish-cache.org/lists/mailman/listinfo/varnish-bugs


varnish-bugs at varnish-cache

Mar 31, 2011, 11:15 AM

Post #4 of 5 (239 views)
Permalink
Re: #888: Assert error in ESI_Deliver(), cache_esi_deliver.c line 326 [In reply to]

#888: Assert error in ESI_Deliver(), cache_esi_deliver.c line 326
--------------------+-------------------------------------------------------
Reporter: perbu | Owner:
Type: defect | Status: closed
Priority: normal | Milestone:
Component: build | Version: trunk
Severity: normal | Resolution: fixed
Keywords: |
--------------------+-------------------------------------------------------
Changes (by phk):

* status: new => closed
* resolution: => fixed


Comment:

This one is confirmed fixed now.

--
Ticket URL: <http://www.varnish-cache.org/trac/ticket/888#comment:3>
Varnish <http://varnish-cache.org/>
The Varnish HTTP Accelerator

_______________________________________________
varnish-bugs mailing list
varnish-bugs [at] varnish-cache
http://www.varnish-cache.org/lists/mailman/listinfo/varnish-bugs


varnish-bugs at varnish-cache

Apr 22, 2014, 1:34 PM

Post #5 of 5 (39 views)
Permalink
Re: #888: Assert error in ESI_Deliver(), cache_esi_deliver.c line 326 [In reply to]

#888: Assert error in ESI_Deliver(), cache_esi_deliver.c line 326
--------------------+---------------------
Reporter: perbu | Owner:
Type: defect | Status: closed
Priority: normal | Milestone:
Component: build | Version: trunk
Severity: normal | Resolution: fixed
Keywords: |
--------------------+---------------------

Comment (by keretamalam):

I am about to leave and cannot look into this further right now, but I do
want to mention that relying on pkg-config itself is not a problem (as you
said, we also use it later), the problem is that on some systems, the .pc
file for pkg-config is supplying wrong information (whereas on yours, it's
botan-config that is wrong), so that's why I'm trying to make it work with
both (while one of them is bad).
[http://maskodoq.blogspot.com/2014/04/unit-link-terbaik-di-indonesia.html
Unit Link Terbaik di Indonesia Commonwealth Life Investra Link]
[http://maskodoq.blogspot.com/2013/07/CiptoJunaedy.html Cipto Junaedy]

--
Ticket URL: <https://www.varnish-cache.org/trac/ticket/888#comment:4>
Varnish <https://varnish-cache.org/>
The Varnish HTTP Accelerator

_______________________________________________
varnish-bugs mailing list
varnish-bugs [at] varnish-cache
https://www.varnish-cache.org/lists/mailman/listinfo/varnish-bugs

Varnish bugs RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.