Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: Varnish: Bugs

#864: Varnishlog crashes when searching for 503 errors

 

 

Varnish bugs RSS feed   Index | Next | Previous | View Threaded


varnish-bugs at varnish-cache

Feb 26, 2011, 11:19 AM

Post #1 of 9 (723 views)
Permalink
#864: Varnishlog crashes when searching for 503 errors

#864: Varnishlog crashes when searching for 503 errors
---------------------+------------------------------------------------------
Reporter: kriller | Type: defect
Status: new | Priority: normal
Milestone: | Component: build
Version: 2.1.5 | Severity: normal
Keywords: |
---------------------+------------------------------------------------------
I'm trying to find the cause of some 503 errors I'm observing during a
load-test.

Running "varnishlog -r /path/to/logfile -o TxStatus 503" causes varnishlog
to segfault with the following backtrace:

Program received signal SIGSEGV, Segmentation fault.
0x00000000004015cb in h_order (priv=0x0, tag=SLT_SessionOpen, fd=6843503,
len=0, spec=1, ptr=0x774777 "o") at varnishlog.c:130
130 if (ob[fd] == NULL) {
(gdb) bt full
#0 0x00000000004015cb in h_order (priv=0x0, tag=SLT_SessionOpen,
fd=6843503, len=0, spec=1, ptr=0x774777 "o") at varnishlog.c:130
type = 99 'c'
__func__ = "h_order"
#1 0x00007ffff77c3e73 in VSL_Dispatch (vd=0x6d4010, func=0x40152f
<h_order>, priv=0x0) at shmlog.c:383
i = 1
u = 6843503
l = 0
s = 1
p = 0x774770 "\006"
__PRETTY_FUNCTION__ = "VSL_Dispatch"
#2 0x0000000000401aa1 in do_order (vd=0x6d4010, argc=2,
argv=0x7fffffffe0f8) at varnishlog.c:227
i = 32767
error = 0x0
erroroffset = 0
#3 0x0000000000401f25 in main (argc=6, argv=0x7fffffffe0d8) at
varnishlog.c:391
c = -1
a_flag = 0
D_flag = 0
o_flag = 1
u_flag = 0
n_arg = 0x0
P_arg = 0x0
w_arg = 0x0
pfh = 0x0
vd = 0x6d4010

--
Ticket URL: <http://varnish-cache.org/trac/ticket/864>
Varnish <http://varnish-cache.org/>
The Varnish HTTP Accelerator

_______________________________________________
varnish-bugs mailing list
varnish-bugs [at] varnish-cache
http://www.varnish-cache.org/lists/mailman/listinfo/varnish-bugs


varnish-bugs at varnish-cache

Feb 28, 2011, 5:12 AM

Post #2 of 9 (691 views)
Permalink
Re: #864: Varnishlog crashes when searching for 503 errors [In reply to]

#864: Varnishlog crashes when searching for 503 errors
---------------------+------------------------------------------------------
Reporter: kriller | Owner: kristian
Type: defect | Status: new
Priority: normal | Milestone:
Component: build | Version: 2.1.5
Severity: normal | Keywords:
---------------------+------------------------------------------------------
Changes (by kristian):

* owner: => kristian


Comment:

Are you able to read the log without using a filter and -o? And is the log
written by varnishlog itself, or are you accessing the raw shmlog
directly? I'd like to see the actual command-lines(plural), just to be
sure.

--
Ticket URL: <http://www.varnish-cache.org/trac/ticket/864#comment:1>
Varnish <http://varnish-cache.org/>
The Varnish HTTP Accelerator

_______________________________________________
varnish-bugs mailing list
varnish-bugs [at] varnish-cache
http://www.varnish-cache.org/lists/mailman/listinfo/varnish-bugs


varnish-bugs at varnish-cache

Feb 28, 2011, 5:34 AM

Post #3 of 9 (700 views)
Permalink
Re: #864: Varnishlog crashes when searching for 503 errors [In reply to]

#864: Varnishlog crashes when searching for 503 errors
---------------------+------------------------------------------------------
Reporter: kriller | Owner: kristian
Type: defect | Status: new
Priority: normal | Milestone:
Component: build | Version: 2.1.5
Severity: normal | Keywords:
---------------------+------------------------------------------------------

Comment(by kriller):

The log is initially written to a file by varnishlog, which is started by
the debian startup-script (/usr/bin/varnishlog -a -w
/var/log/varnish/varnish.log -D -P /var/run/varnishlog/varnishlog.pid).

Using varnishlog without -o and a filter works fine (/usr/bin/varnishlog
-r /var/log/varnishlog > /dev/null).

--
Ticket URL: <http://varnish-cache.org/trac/ticket/864#comment:2>
Varnish <http://varnish-cache.org/>
The Varnish HTTP Accelerator

_______________________________________________
varnish-bugs mailing list
varnish-bugs [at] varnish-cache
http://www.varnish-cache.org/lists/mailman/listinfo/varnish-bugs


varnish-bugs at varnish-cache

Feb 28, 2011, 5:35 AM

Post #4 of 9 (696 views)
Permalink
Re: #864: Varnishlog crashes when searching for 503 errors [In reply to]

#864: Varnishlog crashes when searching for 503 errors
---------------------+------------------------------------------------------
Reporter: kriller | Owner: kristian
Type: defect | Status: new
Priority: normal | Milestone:
Component: build | Version: 2.1.5
Severity: normal | Keywords:
---------------------+------------------------------------------------------

Comment(by kriller):

and the last path should of course have been /var/log/varnish/varnish.log
instead of /var/log/varnishlog

--
Ticket URL: <http://varnish-cache.org/trac/ticket/864#comment:3>
Varnish <http://varnish-cache.org/>
The Varnish HTTP Accelerator

_______________________________________________
varnish-bugs mailing list
varnish-bugs [at] varnish-cache
http://www.varnish-cache.org/lists/mailman/listinfo/varnish-bugs


varnish-bugs at varnish-cache

Mar 7, 2011, 3:26 AM

Post #5 of 9 (665 views)
Permalink
Re: #864: Varnishlog crashes when searching for 503 errors [In reply to]

#864: Varnishlog crashes when searching for 503 errors
------------------------+---------------------------------------------------
Reporter: kriller | Owner: kristian
Type: defect | Status: assigned
Priority: normal | Milestone:
Component: varnishlog | Version: 2.1.5
Severity: normal | Keywords:
------------------------+---------------------------------------------------
Changes (by kristian):

* status: new => assigned
* component: build => varnishlog


Comment:

Ok, this is definitely a bug. It also ties in with #807, and is largely
known.

The essence of the problem is lack of input-validation in varnishlog. (And
other tools)

--
Ticket URL: <http://varnish-cache.org/trac/ticket/864#comment:4>
Varnish <http://varnish-cache.org/>
The Varnish HTTP Accelerator

_______________________________________________
varnish-bugs mailing list
varnish-bugs [at] varnish-cache
http://www.varnish-cache.org/lists/mailman/listinfo/varnish-bugs


varnish-bugs at varnish-cache

Mar 7, 2011, 4:44 AM

Post #6 of 9 (661 views)
Permalink
Re: #864: Varnishlog crashes when searching for 503 errors [In reply to]

#864: Varnishlog crashes when searching for 503 errors
------------------------+---------------------------------------------------
Reporter: kriller | Owner: kristian
Type: defect | Status: assigned
Priority: normal | Milestone: Later
Component: varnishlog | Version: 2.1.5
Severity: normal | Keywords:
------------------------+---------------------------------------------------
Changes (by kristian):

* milestone: => Later


--
Ticket URL: <http://www.varnish-cache.org/trac/ticket/864#comment:5>
Varnish <http://varnish-cache.org/>
The Varnish HTTP Accelerator

_______________________________________________
varnish-bugs mailing list
varnish-bugs [at] varnish-cache
http://www.varnish-cache.org/lists/mailman/listinfo/varnish-bugs


varnish-bugs at varnish-cache

Mar 7, 2011, 4:49 AM

Post #7 of 9 (678 views)
Permalink
Re: #864: Varnishlog crashes when searching for 503 errors [In reply to]

#864: Varnishlog crashes when searching for 503 errors
------------------------+---------------------------------------------------
Reporter: kriller | Owner:
Type: defect | Status: new
Priority: normal | Milestone: Later
Component: varnishlog | Version: 2.1.5
Severity: normal | Keywords:
------------------------+---------------------------------------------------
Changes (by kristian):

* owner: kristian =>
* status: assigned => new


--
Ticket URL: <http://varnish-cache.org/trac/ticket/864#comment:6>
Varnish <http://varnish-cache.org/>
The Varnish HTTP Accelerator

_______________________________________________
varnish-bugs mailing list
varnish-bugs [at] varnish-cache
http://www.varnish-cache.org/lists/mailman/listinfo/varnish-bugs


varnish-bugs at varnish-cache

Apr 23, 2012, 3:27 AM

Post #8 of 9 (384 views)
Permalink
Re: #864: Varnishlog crashes when searching for 503 errors [In reply to]

#864: Varnishlog crashes when searching for 503 errors
------------------------+---------------------------------------------------
Reporter: kriller | Owner:
Type: defect | Status: closed
Priority: normal | Milestone: Later
Component: varnishlog | Version: 2.1.5
Severity: normal | Resolution: worksforme
Keywords: |
------------------------+---------------------------------------------------
Changes (by kristian):

* status: new => closed
* resolution: => worksforme


Comment:

This seems to have mysteriously have gone away now.

Can't reproduce under heavy load any more... Please re-open if you still
have issues like this.

--
Ticket URL: <https://www.varnish-cache.org/trac/ticket/864#comment:7>
Varnish <https://varnish-cache.org/>
The Varnish HTTP Accelerator

_______________________________________________
varnish-bugs mailing list
varnish-bugs [at] varnish-cache
https://www.varnish-cache.org/lists/mailman/listinfo/varnish-bugs


varnish-bugs at varnish-cache

Apr 22, 2014, 2:20 PM

Post #9 of 9 (104 views)
Permalink
Re: #864: Varnishlog crashes when searching for 503 errors [In reply to]

#864: Varnishlog crashes when searching for 503 errors
------------------------+-------------------------
Reporter: kriller | Owner:
Type: defect | Status: closed
Priority: normal | Milestone: Later
Component: varnishlog | Version: 2.1.5
Severity: normal | Resolution: worksforme
Keywords: |
------------------------+-------------------------

Comment (by keretamalam):

I am about to leave and cannot look into this further right now, but I do
want to mention that relying on pkg-config itself is not a problem (as you
said, we also use it later), the problem is that on some systems, the .pc
file for pkg-config is supplying wrong information (whereas on yours, it's
botan-config that is wrong), so that's why I'm trying to make it work with
both (while one of them is bad).
[http://maskodoq.blogspot.com/2014/03/unit-link-terbaik-di-indonesia.html
Unit Link Terbaik di Indonesia Commonwealth Life Investra Link]
[http://maskodoq.blogspot.com/2013/07/CiptoJunaedy.html Cipto Junaedy]
[http://etnisjawa.blogspot.com/2013/08/apakah-cipto-junaedy-bohong.html
Cipto Junaedy]

--
Ticket URL: <https://www.varnish-cache.org/trac/ticket/864#comment:8>
Varnish <https://varnish-cache.org/>
The Varnish HTTP Accelerator

_______________________________________________
varnish-bugs mailing list
varnish-bugs [at] varnish-cache
https://www.varnish-cache.org/lists/mailman/listinfo/varnish-bugs

Varnish bugs RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.