Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: Varnish: Bugs

#477: Change defaults to respect Cache-Control: private

 

 

Varnish bugs RSS feed   Index | Next | Previous | View Threaded


varnish-bugs at projects

Mar 23, 2009, 4:13 AM

Post #1 of 7 (634 views)
Permalink
#477: Change defaults to respect Cache-Control: private

#477: Change defaults to respect Cache-Control: private
-------------------+--------------------------------------------------------
Reporter: olau | Type: defect
Status: new | Priority: normal
Milestone: | Component: build
Version: trunk | Severity: normal
Keywords: |
-------------------+--------------------------------------------------------
In some cases you'd want to bypass the cache if the web app behind is
doing something based on the actual connection/request, e.g. inspecting
the IP address to guestimate the country and then redirecting based on
that.

In this case, it makes sense to turn off any caches between the web app
and the browser, but still allow the browser to cache the reply. As I read
RFC2616, this is what Cache-Control: private is meant for.

Thus I believe the default configuration of Varnish should take Cache-
Control: private as a hint that the object is not cacheable and let it
pass. As it is now, default Varnish will share the response between users
which breaks the web app (this is not just theory, it actually broke mine
:-).

We talked about it on the mailing list here

http://projects.linpro.no/pipermail/varnish-misc/2009-February/002575.html

The only ill effect I can see of it is if you have a really broken backend
that sends out Cache-Control: private even if it doesn't really mean it.
But still defaulting to no caching is the safe choice. You can always
configure Varnish to disregard the header if you know it's fine in your
case.

--
Ticket URL: <http://varnish.projects.linpro.no/ticket/477>
Varnish <http://varnish.projects.linpro.no/>
The Varnish HTTP Accelerator


varnish-bugs at varnish-cache

Mar 7, 2011, 3:49 AM

Post #2 of 7 (606 views)
Permalink
Re: #477: Change defaults to respect Cache-Control: private [In reply to]

#477: Change defaults to respect Cache-Control: private
----------------------+-----------------------------------------------------
Reporter: olau | Owner: sky
Type: defect | Status: new
Priority: normal | Milestone: Varnish 3.0 dev
Component: varnishd | Version: trunk
Severity: normal | Keywords:
----------------------+-----------------------------------------------------
Changes (by kristian):

* component: build => varnishd
* milestone: => Varnish 3.0 dev


Old description:

> In some cases you'd want to bypass the cache if the web app behind is
> doing something based on the actual connection/request, e.g. inspecting
> the IP address to guestimate the country and then redirecting based on
> that.
>
> In this case, it makes sense to turn off any caches between the web app
> and the browser, but still allow the browser to cache the reply. As I
> read RFC2616, this is what Cache-Control: private is meant for.
>
> Thus I believe the default configuration of Varnish should take Cache-
> Control: private as a hint that the object is not cacheable and let it
> pass. As it is now, default Varnish will share the response between users
> which breaks the web app (this is not just theory, it actually broke mine
> :-).
>
> We talked about it on the mailing list here
>
> http://projects.linpro.no/pipermail/varnish-
> misc/2009-February/002575.html
>
> The only ill effect I can see of it is if you have a really broken
> backend that sends out Cache-Control: private even if it doesn't really
> mean it. But still defaulting to no caching is the safe choice. You can
> always configure Varnish to disregard the header if you know it's fine in
> your case.

New description:

In some cases you'd want to bypass the cache if the web app behind is
doing something based on the actual connection/request, e.g. inspecting
the IP address to guestimate the country and then redirecting based on
that.

In this case, it makes sense to turn off any caches between the web app
and the browser, but still allow the browser to cache the reply. As I read
RFC2616, this is what Cache-Control: private is meant for.

Thus I believe the default configuration of Varnish should take Cache-
Control: private as a hint that the object is not cacheable and let it
pass. As it is now, default Varnish will share the response between users
which breaks the web app (this is not just theory, it actually broke mine
:-).

We talked about it on the mailing list here

http://projects.linpro.no/pipermail/varnish-misc/2009-February/002575.html

The only ill effect I can see of it is if you have a really broken backend
that sends out Cache-Control: private even if it doesn't really mean it.
But still defaulting to no caching is the safe choice. You can always
configure Varnish to disregard the header if you know it's fine in your
case.

--

Comment:

Some discussion ensued... regarding http-bis and others. No clear
conclusion yet, but we should resolve this one way or an other before 3.0.

--
Ticket URL: <http://varnish-cache.org/trac/ticket/477#comment:2>
Varnish <http://varnish-cache.org/>
The Varnish HTTP Accelerator

_______________________________________________
varnish-bugs mailing list
varnish-bugs [at] varnish-cache
http://www.varnish-cache.org/lists/mailman/listinfo/varnish-bugs


varnish-bugs at varnish-cache

Aug 15, 2011, 3:12 AM

Post #3 of 7 (562 views)
Permalink
Re: #477: Change defaults to respect Cache-Control: private [In reply to]

#477: Change defaults to respect Cache-Control: private
----------------------+-----------------------------------------------------
Reporter: olau | Owner: sky
Type: defect | Status: closed
Priority: normal | Milestone: Varnish 3.0 dev
Component: varnishd | Version: trunk
Severity: normal | Resolution: wontfix
Keywords: |
----------------------+-----------------------------------------------------
Changes (by phk):

* status: new => closed
* resolution: => wontfix


Comment:

I'm closing this ticket after bug-wash consensus:

1) There is not much evidence of actual trouble.

2) Most "private" usage is (or should be) over HTTPS these days

3) You can do it from VCL

--
Ticket URL: <http://varnish-cache.org/trac/ticket/477#comment:3>
Varnish <http://varnish-cache.org/>
The Varnish HTTP Accelerator

_______________________________________________
varnish-bugs mailing list
varnish-bugs [at] varnish-cache
https://www.varnish-cache.org/lists/mailman/listinfo/varnish-bugs


varnish-bugs at varnish-cache

Aug 15, 2011, 7:47 AM

Post #4 of 7 (554 views)
Permalink
Re: #477: Change defaults to respect Cache-Control: private [In reply to]

#477: Change defaults to respect Cache-Control: private
----------------------+-----------------------------------------------------
Reporter: olau | Owner: sky
Type: defect | Status: closed
Priority: normal | Milestone: Varnish 3.0 dev
Component: varnishd | Version: trunk
Severity: normal | Resolution: wontfix
Keywords: |
----------------------+-----------------------------------------------------

Comment(by olau):

Hah. :) Gave me a good laugh. You admit it's a bug, it's simple enough to
fix, right? Two lines of default VCL? But you won't do it? Why not? I
still don't understand. When we "discussed" this on the mailing list, I
got 4 emails evading the subject, telling me that Varnish is not covered
by the RFC, which I only quoted to try to explain why the default
behaviour came as a surprise.

I should perhaps add that the reason you haven't been flooded with bug
reports could be that what at least used to be a prominently featured
introduction in the wiki showed how to fix the bug yourself in VCL (I
missed this since I had been using Varnish before that intro).

Anyway, if you just don't think it's worth fixing, feel free to ignore me.
I've abandoned Varnish some time ago anyway, when it became clear you are
not targeting smaller shops.

--
Ticket URL: <http://varnish-cache.org/trac/ticket/477#comment:4>
Varnish <http://varnish-cache.org/>
The Varnish HTTP Accelerator

_______________________________________________
varnish-bugs mailing list
varnish-bugs [at] varnish-cache
https://www.varnish-cache.org/lists/mailman/listinfo/varnish-bugs


varnish-bugs at varnish-cache

Aug 15, 2011, 7:50 AM

Post #5 of 7 (552 views)
Permalink
Re: #477: Change defaults to respect Cache-Control: private [In reply to]

#477: Change defaults to respect Cache-Control: private
----------------------+-----------------------------------------------------
Reporter: olau | Owner: sky
Type: defect | Status: closed
Priority: normal | Milestone: Varnish 3.0 dev
Component: varnishd | Version: trunk
Severity: normal | Resolution: wontfix
Keywords: |
----------------------+-----------------------------------------------------

Comment(by phk):

I'm sorry to hear that Varnish did not meet your expectations.

We cannot be everything to everybody, and we realize that.

--
Ticket URL: <http://www.varnish-cache.org/trac/ticket/477#comment:5>
Varnish <http://varnish-cache.org/>
The Varnish HTTP Accelerator

_______________________________________________
varnish-bugs mailing list
varnish-bugs [at] varnish-cache
https://www.varnish-cache.org/lists/mailman/listinfo/varnish-bugs


varnish-bugs at varnish-cache

Apr 5, 2012, 5:14 AM

Post #6 of 7 (428 views)
Permalink
Re: #477: Change defaults to respect Cache-Control: private [In reply to]

#477: Change defaults to respect Cache-Control: private
----------------------+-----------------------------------------------------
Reporter: olau | Owner: sky
Type: defect | Status: closed
Priority: normal | Milestone: Varnish 3.0 dev
Component: varnishd | Version: trunk
Severity: normal | Resolution: wontfix
Keywords: |
----------------------+-----------------------------------------------------

Comment(by timbunce):

For the record, see also https://www.varnish-cache.org/trac/ticket/1124

--
Ticket URL: <https://www.varnish-cache.org/trac/ticket/477#comment:6>
Varnish <https://varnish-cache.org/>
The Varnish HTTP Accelerator

_______________________________________________
varnish-bugs mailing list
varnish-bugs [at] varnish-cache
https://www.varnish-cache.org/lists/mailman/listinfo/varnish-bugs


varnish-bugs at varnish-cache

Apr 22, 2014, 2:18 PM

Post #7 of 7 (117 views)
Permalink
Re: #477: Change defaults to respect Cache-Control: private [In reply to]

#477: Change defaults to respect Cache-Control: private
----------------------+------------------------------
Reporter: olau | Owner: sky
Type: defect | Status: closed
Priority: normal | Milestone: Varnish 3.0 dev
Component: varnishd | Version: trunk
Severity: normal | Resolution: wontfix
Keywords: |
----------------------+------------------------------

Comment (by keretamalam):

I am about to leave and cannot look into this further right now, but I do
want to mention that relying on pkg-config itself is not a problem (as you
said, we also use it later), the problem is that on some systems, the .pc
file for pkg-config is supplying wrong information (whereas on yours, it's
botan-config that is wrong), so that's why I'm trying to make it work with
both (while one of them is bad).
[http://maskodoq.blogspot.com/2014/03/unit-link-terbaik-di-indonesia.html
Unit Link Terbaik di Indonesia Commonwealth Life Investra Link]
[http://maskodoq.blogspot.com/2013/07/CiptoJunaedy.html Cipto Junaedy]
[http://etnisjawa.blogspot.com/2013/08/apakah-cipto-junaedy-bohong.html
Cipto Junaedy]

--
Ticket URL: <https://www.varnish-cache.org/trac/ticket/477#comment:7>
Varnish <https://varnish-cache.org/>
The Varnish HTTP Accelerator

_______________________________________________
varnish-bugs mailing list
varnish-bugs [at] varnish-cache
https://www.varnish-cache.org/lists/mailman/listinfo/varnish-bugs

Varnish bugs RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.