Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: Trac: Users

FullBlogPlugin - install error

 

 

Trac users RSS feed   Index | Next | Previous | View Threaded


kennethdammyr at gmail

Feb 13, 2012, 5:43 AM

Post #1 of 4 (396 views)
Permalink
FullBlogPlugin - install error

Hi

I'm trying to install the fullblogplugin. I'm running a BitNami
TracStack and have done this on previous installations. The
easy_installer should be working fine as I have installed other
plugins with success. This is the output I get:


********************************************
Downloading http://trac-hacks.org/svn/fullblogplugin/0.11
Doing subversion checkout from http://trac-hacks.org/svn/fullblogplugin/0.11
to c:\users\p4drift\appdata\local\temp\easy
_install-pmkknj\0.11
Processing 0.11
Running setup.py -q bdist_egg --dist-dir c:\users\p4drift\appdata\local
\temp\easy_install-pmkknj\0.11\egg-dist-tmp-7hcfm
0
Traceback (most recent call last):
File "c:\Program Files\BitNami Trac Stack\apps\trac\Scripts
\easy_install-script.py", line 8, in <module>
load_entry_point('setuptools==0.6c11', 'console_scripts',
'easy_install')()
File "C:\Program Files\BitNami Trac Stack\python\lib\site-packages
\setuptools-0.6c11-py2.6.egg\setuptools\command\easy
_install.py", line 1712, in main
File "C:\Program Files\BitNami Trac Stack\python\lib\site-packages
\setuptools-0.6c11-py2.6.egg\setuptools\command\easy
_install.py", line 1700, in with_ei_usage
File "C:\Program Files\BitNami Trac Stack\python\lib\site-packages
\setuptools-0.6c11-py2.6.egg\setuptools\command\easy
_install.py", line 1716, in <lambda>
File "C:\Program Files\BitNami Trac Stack\python\lib\distutils
\core.py", line 152, in setup
dist.run_commands()
File "C:\Program Files\BitNami Trac Stack\python\lib\distutils
\dist.py", line 975, in run_commands
self.run_command(cmd)
File "C:\Program Files\BitNami Trac Stack\python\lib\distutils
\dist.py", line 995, in run_command
cmd_obj.run()
File "C:\Program Files\BitNami Trac Stack\python\lib\site-packages
\setuptools-0.6c11-py2.6.egg\setuptools\command\easy
_install.py", line 211, in run
File "C:\Program Files\BitNami Trac Stack\python\lib\site-packages
\setuptools-0.6c11-py2.6.egg\setuptools\command\easy
_install.py", line 422, in easy_install
File "C:\Program Files\BitNami Trac Stack\python\lib\site-packages
\setuptools-0.6c11-py2.6.egg\setuptools\command\easy
_install.py", line 476, in install_item
File "C:\Program Files\BitNami Trac Stack\python\lib\site-packages
\setuptools-0.6c11-py2.6.egg\setuptools\command\easy
_install.py", line 655, in install_eggs
File "C:\Program Files\BitNami Trac Stack\python\lib\site-packages
\setuptools-0.6c11-py2.6.egg\setuptools\command\easy
_install.py", line 930, in build_and_install
File "C:\Program Files\BitNami Trac Stack\python\lib\site-packages
\setuptools-0.6c11-py2.6.egg\setuptools\command\easy
_install.py", line 919, in run_setup
File "C:\Program Files\BitNami Trac Stack\python\lib\site-packages
\setuptools-0.6c11-py2.6.egg\setuptools\sandbox.py",
line 62, in run_setup
File "C:\Program Files\BitNami Trac Stack\python\lib\site-packages
\setuptools-0.6c11-py2.6.egg\setuptools\sandbox.py",
line 105, in run
File "C:\Program Files\BitNami Trac Stack\python\lib\site-packages
\setuptools-0.6c11-py2.6.egg\setuptools\sandbox.py",
line 64, in <lambda>
File "setup.py", line 41, in <module>
File "C:\Program Files\BitNami Trac Stack\python\lib\distutils
\core.py", line 152, in setup
dist.run_commands()
File "C:\Program Files\BitNami Trac Stack\python\lib\distutils
\dist.py", line 975, in run_commands
self.run_command(cmd)
File "C:\Program Files\BitNami Trac Stack\python\lib\distutils
\dist.py", line 994, in run_command
cmd_obj.ensure_finalized()
File "C:\Program Files\BitNami Trac Stack\python\lib\distutils
\cmd.py", line 117, in ensure_finalized
self.finalize_options()
File "C:\Program Files\BitNami Trac Stack\python\lib\site-packages
\setuptools-0.6c11-py2.6.egg\setuptools\command\bdis
t_egg.py", line 94, in finalize_options
File "C:\Program Files\BitNami Trac Stack\python\lib\distutils
\cmd.py", line 319, in get_finalized_command
cmd_obj.ensure_finalized()
File "C:\Program Files\BitNami Trac Stack\python\lib\distutils
\cmd.py", line 117, in ensure_finalized
self.finalize_options()
File "C:\Program Files\BitNami Trac Stack\python\lib\site-packages
\setuptools-0.6c11-py2.6.egg\setuptools\command\egg_
info.py", line 85, in finalize_options
File "C:\Program Files\BitNami Trac Stack\python\lib\site-packages
\setuptools-0.6c11-py2.6.egg\setuptools\command\egg_
info.py", line 185, in tags
File "C:\Program Files\BitNami Trac Stack\python\lib\site-packages
\setuptools-0.6c11-py2.6.egg\setuptools\command\egg_
info.py", line 233, in get_svn_revision
IndexError: list index out of range

********************************************

Appreciate any help!

--
You received this message because you are subscribed to the Google Groups "Trac Users" group.
To post to this group, send email to trac-users [at] googlegroups
To unsubscribe from this group, send email to trac-users+unsubscribe [at] googlegroups
For more options, visit this group at http://groups.google.com/group/trac-users?hl=en.


ryano at physiosonics

Feb 13, 2012, 3:54 PM

Post #2 of 4 (373 views)
Permalink
Re: FullBlogPlugin - install error [In reply to]

On Feb 13, 5:43 am, Kenneth Dammyr <kennethdam...@gmail.com> wrote:
> I'm trying to install the fullblogplugin. I'm running a BitNami
> TracStack and have done this on previous installations. The
> easy_installer should be working fine as I have installed other
> plugins with success. This is the output I get:

This looks like the same issue that is reported here [1]. You might
try removing setup.cfg or setting tag_svn_revision = false prior to
running easy_install.

[1] http://trac-hacks.org/ticket/9565

--
You received this message because you are subscribed to the Google Groups "Trac Users" group.
To post to this group, send email to trac-users [at] googlegroups
To unsubscribe from this group, send email to trac-users+unsubscribe [at] googlegroups
For more options, visit this group at http://groups.google.com/group/trac-users?hl=en.


kennethdammyr at gmail

Feb 13, 2012, 11:46 PM

Post #3 of 4 (376 views)
Permalink
Re: FullBlogPlugin - install error [In reply to]

Thanks for the reply, you set me on the right track.

I downloaded the zip-version and extracted only the appropriate
version of the plugin. Then I ran easy_install on that folder. It
worked! So I didn't get to try your solution, but it might work for
others. All in all it seems as if something strange is happening when
certain plugins are checked out directly from SVN. Furter testing
shows the same problem and solution for many different plugins.

/Kenneth

On Feb 14, 12:54 am, RjOllos <ry...@physiosonics.com> wrote:
> On Feb 13, 5:43 am, Kenneth Dammyr <kennethdam...@gmail.com> wrote:
>
> > I'm trying to install the fullblogplugin. I'm running a BitNami
> > TracStack and have done this on previous installations. The
> > easy_installer should be working fine as I have installed other
> > plugins with success. This is the output I get:
>
> This looks like the same issue that is reported here [1]. You might
> try removing setup.cfg or setting tag_svn_revision = false prior to
> running easy_install.
>
> [1]http://trac-hacks.org/ticket/9565

--
You received this message because you are subscribed to the Google Groups "Trac Users" group.
To post to this group, send email to trac-users [at] googlegroups
To unsubscribe from this group, send email to trac-users+unsubscribe [at] googlegroups
For more options, visit this group at http://groups.google.com/group/trac-users?hl=en.


ryano at physiosonics

Apr 9, 2012, 4:25 PM

Post #4 of 4 (296 views)
Permalink
Re: FullBlogPlugin - install error [In reply to]

I think we finally have an answer to this issue in http://trac-hacks.org/ticket/9709.

--
You received this message because you are subscribed to the Google Groups "Trac Users" group.
To post to this group, send email to trac-users [at] googlegroups
To unsubscribe from this group, send email to trac-users+unsubscribe [at] googlegroups
For more options, visit this group at http://groups.google.com/group/trac-users?hl=en.

Trac users RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.