Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: syslinux: users

pxelinux problems

 

 

syslinux users RSS feed   Index | Next | Previous | View Threaded


andyw at hep

Mar 19, 2002, 3:08 AM

Post #1 of 3 (653 views)
Permalink
pxelinux problems

Hi,

I'm seeing a strange problem when using pxelinux - it loads OK initially
and finds pxelinux.cfg/default, but then hangs.

Looking in the server's /var/log/messages, I find this:

Mar 18 14:01:38 fal000phys02 tftpd[24310]: tftp: client does not accept options
Mar 18 14:01:38 fal000phys02 xinetd[6441]: tftp service was deactivated because
of looping

If I reload xinetd twice, tftpd is reactivated and I get the boot prompt
on the client. If I type in the label name it says "Can't find image...,
but I can type in "vmlinuz initrd=initrd.img" and the kernel loads and
everything works fine from there.

The pxelinux.cfg/default file is a copy of the syslinux.cfg taken from the
Red Hat installation boot image, as I'm attempting to upgrade the OS in
100 boxes in a cluster that have no floppy or CD drives.

The cluster boxes use Intel Boot Client 3.0.3, and I'm using the
"conventional TFTP" configuration of dhcpd. The server is running Red Hat
7.0.

Can anyone see where I'm going wrong?

Cheers,
Andy Wallace


andyw at hep

Mar 19, 2002, 10:24 AM

Post #2 of 3 (631 views)
Permalink
pxelinux problems [In reply to]

On Tue, 19 Mar 2002, Josef Siemes wrote:

> Hi,
> Andrew Wallace <andyw [at] hep> schrieb am 19.03.02:
> > I'm seeing a strange problem when using pxelinux - it loads OK initially
> > and finds pxelinux.cfg/default, but then hangs.
> >
> > Looking in the server's /var/log/messages, I find this:
> >
> > Mar 18 14:01:38 fal000phys02 tftpd[24310]: tftp: client does not accept options
>
> The rom resets one tftp request, and the tftp server logs this. No
> problem, just annoying.
>
> > Mar 18 14:01:38 fal000phys02 xinetd[6441]: tftp service was deactivated because
> > of looping
>
> xinetd thinks that the tftp server starts too often per second, so
> it deactivates it.
>
> Which tftp server do you use? Did you try to use the short daemon mode
> of tftp-hpa? Did you try to tell xinetd to allow several (e.g. 100)
> instances per second to be started?
>
> If you boot via pxelinux one client issues about 10 tftp requests,
> and these in much less than a second. This isn't a problem, but
> xinetd seems to think it is.
>
> Regards,
>
> Josef
>

Thanks for the explanation. It worked after I changed the default file to
get rid of some unneeded options. I still got the first error message but
it didn't shut down tftp and the installation program started. However,
from your message I'm guessing this had nothing to do with it :-)

I'm actually using the tftp-server version which comes with RedHat 7.0. If
I have more problems I'll switch to tftp-hpa and try it as a standalone
daemon.

Cheers,
Andy


hpa at zytor

Mar 19, 2002, 10:57 AM

Post #3 of 3 (629 views)
Permalink
pxelinux problems [In reply to]

Andrew Wallace wrote:

>
> Thanks for the explanation. It worked after I changed the default file to
> get rid of some unneeded options. I still got the first error message but
> it didn't shut down tftp and the installation program started. However,
> from your message I'm guessing this had nothing to do with it :-)
>
> I'm actually using the tftp-server version which comes with RedHat 7.0. If
> I have more problems I'll switch to tftp-hpa and try it as a standalone
> daemon.
>


The tftp-server from RedHat is an utterly archaic version of tftp-hpa.
Don't use it.

-hpa

syslinux users RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.