Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: Request Tracker: Users

not ok could not load a valid user

 

 

Request Tracker users RSS feed   Index | Next | Previous | View Threaded


esoward at remotedbaexperts

May 23, 2012, 9:19 AM

Post #1 of 2 (344 views)
Permalink
not ok could not load a valid user

# /opt/rt4/bin/rt-mailgate --queue BigBrother --action correspond --url http://rt.rdba.remotedbaexperts.com --debug < TEST-THIS
/opt/rt4/bin/rt-mailgate: temp file is '/tmp/j92jIcubtH/9qakj2w0lb'
/opt/rt4/bin/rt-mailgate: connecting to http://rt.rdba.remotedbaexperts.com/REST/1.0/NoAuth/mail-gateway
not ok - Could not load a valid user

what I've attempted;
1-changed permissions on the two queues (BigBrother, under "Everyone" create tickets, reply to tickets, view queue,
2-saved changes
3-rebooted server
4-re-ran "TEST-THIS" with same result "not ok - Could not load a valid user"

Any pointers beyond queue permissions ? thanks for the input,
Evan


JThuau at spacex

May 23, 2012, 9:23 AM

Post #2 of 2 (332 views)
Permalink
Re: not ok could not load a valid user [In reply to]

Tickets created by email have a "from" field, that is used to lookup a user in RT, in order to assign that user as the requestor.

Sounds like your test is not from a valid user as RT sees it.
I don't remember if it fails with that error message, but double check that your http server (apache/whatever) is configured properly for the "NoAuth" bits…

Thanks,
Jok
--
| Joachim Thuau | IT Systems Engineer - Linux / SpaceX |

From: Evan Soward <esoward [at] remotedbaexperts<mailto:esoward [at] remotedbaexperts>>
Date: Wednesday, May 23, 2012 9:19 AM
To: RT Users <rt-users [at] lists<mailto:rt-users [at] lists>>
Subject: [rt-users] not ok could not load a valid user

# /opt/rt4/bin/rt-mailgate --queue BigBrother --action correspond --url http://rt.rdba.remotedbaexperts.com --debug < TEST-THIS
/opt/rt4/bin/rt-mailgate: temp file is '/tmp/j92jIcubtH/9qakj2w0lb'
/opt/rt4/bin/rt-mailgate: connecting to http://rt.rdba.remotedbaexperts.com/REST/1.0/NoAuth/mail-gateway
not ok - Could not load a valid user

what I’ve attempted;
1-changed permissions on the two queues (BigBrother, under “Everyone” create tickets, reply to tickets, view queue,
2-saved changes
3-rebooted server
4-re-ran “TEST-THIS” with same result “not ok – Could not load a valid user”

Any pointers beyond queue permissions ? thanks for the input,
Evan

Request Tracker users RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.