Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: RANCID: Users

Rancid enable problem

 

 

RANCID users RSS feed   Index | Next | Previous | View Threaded


michael6at at yahoo

May 24, 2012, 8:01 AM

Post #1 of 15 (2461 views)
Permalink
Rancid enable problem

Hy Guy’s,

I have a really crazy Problem with Rancid on Ubuntu,
I have now ca. 70 Devices in my cloginrc file
from simple switch to ASA Firewalls everything runs perfekt.
Now I have added another ASA5510.
I try to login with clogin IP and I could log
in, but the enable command doesn’t come.
In my Rancid logs I see the following:

missed cmd(s): write term,show redundancy secondary
End of run not found
!DEBUG: ^

My cloginrc entry for this device looks like the following:
add password 193.186.1.2 {userpw} {enablepw}
add autoenable 193.186.1.2 1


I don’t understand whats going on here, this
is the only Device that doesn’t work.

I hope somebody help me

_______________________________________________
Rancid-discuss mailing list
Rancid-discuss [at] shrubbery
http://www.shrubbery.net/mailman/listinfo.cgi/rancid-discuss


rwest at zyedge

May 24, 2012, 8:14 AM

Post #2 of 15 (2423 views)
Permalink
Re: Rancid enable problem [In reply to]

Set autoenable to 0

Sent from handheld

On May 24, 2012, at 11:11 AM, "Michael" <michael6at [at] yahoo> wrote:

> Hy Guys,
>
> I have a really crazy Problem with Rancid on Ubuntu,
> I have now ca. 70 Devices in my cloginrc file
> from simple switch to ASA Firewalls everything runs perfekt.
> Now I have added another ASA5510.
> I try to login with clogin IP and I could log
> in, but the enable command doesnt come.
> In my Rancid logs I see the following:
>
> missed cmd(s): write term,show redundancy secondary
> End of run not found
> !DEBUG: ^
>
> My cloginrc entry for this device looks like the following:
> add password 193.186.1.2 {userpw} {enablepw}
> add autoenable 193.186.1.2 1
>
>
> I dont understand whats going on here, this
> is the only Device that doesnt work.
>
> I hope somebody help me
>
> _______________________________________________
> Rancid-discuss mailing list
> Rancid-discuss [at] shrubbery
> http://www.shrubbery.net/mailman/listinfo.cgi/rancid-discuss
_______________________________________________
Rancid-discuss mailing list
Rancid-discuss [at] shrubbery
http://www.shrubbery.net/mailman/listinfo.cgi/rancid-discuss


adam.korab at gmail

May 24, 2012, 9:45 AM

Post #3 of 15 (2409 views)
Permalink
Re: Rancid enable problem [In reply to]

And as always remember that the first match in cloginrc wins, so make
sure you place the autoenable statement in the right place for the
given device.

--Adam
--
Adam Korab

On May 24, 2012, at 10:14, Ryan West <rwest [at] zyedge> wrote:

> Set autoenable to 0
>
> Sent from handheld
>
> On May 24, 2012, at 11:11 AM, "Michael" <michael6at [at] yahoo> wrote:
>
>> Hy Guys,
>>
>> I have a really crazy Problem with Rancid on Ubuntu,
>> I have now ca. 70 Devices in my cloginrc file
>> from simple switch to ASA Firewalls everything runs perfekt.
>> Now I have added another ASA5510.
>> I try to login with clogin IP and I could log
>> in, but the enable command doesnt come.
>> In my Rancid logs I see the following:
>>
>> missed cmd(s): write term,show redundancy secondary
>> End of run not found
>> !DEBUG: ^
>>
>> My cloginrc entry for this device looks like the following:
>> add password 193.186.1.2 {userpw} {enablepw}
>> add autoenable 193.186.1.2 1
>>
>>
>> I dont understand whats going on here, this
>> is the only Device that doesnt work.
>>
>> I hope somebody help me
>>
>> _______________________________________________
>> Rancid-discuss mailing list
>> Rancid-discuss [at] shrubbery
>> http://www.shrubbery.net/mailman/listinfo.cgi/rancid-discuss
> _______________________________________________
> Rancid-discuss mailing list
> Rancid-discuss [at] shrubbery
> http://www.shrubbery.net/mailman/listinfo.cgi/rancid-discuss
_______________________________________________
Rancid-discuss mailing list
Rancid-discuss [at] shrubbery
http://www.shrubbery.net/mailman/listinfo.cgi/rancid-discuss


michael6at at yahoo

May 24, 2012, 11:25 PM

Post #4 of 15 (2426 views)
Permalink
Re: Rancid enable problem [In reply to]

Hy Guy's,

Thanks for the answers.
I try to set the autoenable value to 0 with the same success...
Yes it looks for me also, that the device doesn't have autoenable, but how could i resolve the problem?
Maybe you could tell me,I'am a rancid newbie sorry.

Where should i place the autoenable command?

Thanks and best regards



________________________________
Von: Adam Korab <adam.korab [at] gmail>
An: Ryan West <rwest [at] zyedge>
CC: Michael <michael6at [at] yahoo>; "rancid-discuss [at] shrubbery" <rancid-discuss [at] shrubbery>
Gesendet: 18:45 Donnerstag, 24.Mai 2012
Betreff: Re: [rancid] Rancid enable problem

And as always remember that the first match in cloginrc wins, so make
sure you place the autoenable statement in the right place for the
given device.

--Adam
--
Adam Korab

On May 24, 2012, at 10:14, Ryan West <rwest [at] zyedge> wrote:

> Set autoenable to 0
>
> Sent from handheld
>
> On May 24, 2012, at 11:11 AM, "Michael" <michael6at [at] yahoo> wrote:
>
>> Hy Guy’s,
>>
>> I have a really crazy Problem with Rancid on Ubuntu,
>> I have now ca. 70 Devices in my cloginrc file
>> from simple switch to ASA Firewalls everything runs perfekt.
>> Now I have added another ASA5510.
>> I try to login with clogin IP and I could log
>> in, but the enable command doesn’t come.
>> In my Rancid logs I see the following:
>>
>> missed cmd(s): write term,show redundancy secondary
>> End of run not found
>> !DEBUG:              ^
>>
>> My cloginrc entry for this device looks like the following:
>> add password 193.186.1.2 {userpw} {enablepw}
>> add autoenable 193.186.1.2 1
>>
>>
>> I don’t understand whats going on here, this
>> is the only Device that doesn’t work.
>>
>> I hope somebody  help me
>>
>> _______________________________________________
>> Rancid-discuss mailing list
>> Rancid-discuss [at] shrubbery
>> http://www.shrubbery.net/mailman/listinfo.cgi/rancid-discuss
> _______________________________________________
> Rancid-discuss mailing list
> Rancid-discuss [at] shrubbery
> http://www.shrubbery.net/mailman/listinfo.cgi/rancid-discuss


rwest at zyedge

May 25, 2012, 6:26 AM

Post #5 of 15 (2408 views)
Permalink
Re: Rancid enable problem [In reply to]

On Fri, May 25, 2012 at 02:25:31, michael schnatterer wrote:
> Subject: Re: [rancid] Rancid enable problem
>
> Hy Guy's,
>
> Thanks for the answers.
> I try to set the autoenable value to 0 with the same success...
> Yes it looks for me also, that the device doesn't have autoenable, but
> how could i resolve the problem?
> Maybe you could tell me,I'am a rancid newbie sorry.
>
> Where should i place the autoenable command?
>

Here's an example of a typical ASA for me:

# AEI Firewalls
add user customer-fw* username
add password customer-fw* {password} {password}
add autoenable customer-fw* 0
add method customer-fw* ssh
_______________________________________________
Rancid-discuss mailing list
Rancid-discuss [at] shrubbery
http://www.shrubbery.net/mailman/listinfo.cgi/rancid-discuss


michael6at at yahoo

May 28, 2012, 11:47 PM

Post #6 of 15 (2407 views)
Permalink
Re: Rancid enable problem [In reply to]

Hy Guy's

Thanks for your help, but it wouldn't work...
I tried with clogin -autoenable 193.186.1.2 but the enable command doesn't come.
I tried to write the add autoenable 193.186.1.2 1 or 0 on the top of my cloginrc, without success.

I'am a little bit frustrated about the problem :(

have anybody any other idea?

Realy thanks for every help



________________________________
Von: Ryan West <rwest [at] zyedge>
An: michael schnatterer <michael6at [at] yahoo>; Adam Korab <adam.korab [at] gmail>
CC: "rancid-discuss [at] shrubbery" <rancid-discuss [at] shrubbery>
Gesendet: 15:26 Freitag, 25.Mai 2012
Betreff: RE: [rancid] Rancid enable problem

On Fri, May 25, 2012 at 02:25:31, michael schnatterer wrote:
> Subject: Re: [rancid] Rancid enable problem
>
> Hy Guy's,
>
> Thanks for the answers.
> I try to set the autoenable value to 0 with the same success...
> Yes it looks for me also, that the device doesn't have autoenable, but
> how could i resolve the problem?
> Maybe you could tell me,I'am a rancid newbie sorry.
>
> Where should i place the autoenable command?
>

Here's an example of a typical ASA for me:

# AEI Firewalls
add user customer-fw* username
add password customer-fw* {password} {password}
add autoenable customer-fw* 0
add method customer-fw* ssh


rwest at zyedge

May 29, 2012, 4:56 AM

Post #7 of 15 (2396 views)
Permalink
Re: Rancid enable problem [In reply to]

On Tue, May 29, 2012 at 02:47:51, michael schnatterer wrote:
> Subject: Re: [rancid] Rancid enable problem
>
> Hy Guy's
>
> Thanks for your help, but it wouldn't work...
> I tried with clogin -autoenable 193.186.1.2 but the enable command
> doesn't come.
> I tried to write the add autoenable 193.186.1.2 1 or 0 on the top of
> my cloginrc, without success.
>
> I'am a little bit frustrated about the problem :(
>
> have anybody any other idea?
>
> Realy thanks for every help

When you login to the device manually with the RANCID username, what exactly do you type? Is it {username}, followed by {password}, then enable, followed by the same {password}?

_______________________________________________
Rancid-discuss mailing list
Rancid-discuss [at] shrubbery
http://www.shrubbery.net/mailman/listinfo.cgi/rancid-discuss


michael6at at yahoo

May 29, 2012, 5:46 AM

Post #8 of 15 (2394 views)
Permalink
Re: Rancid enable problem [In reply to]

In this case i have an other username as RANCID, but this username is entered in the cloginrc too.

add user 193.186.1.2 {User}
I login with the User and a password, after that i write enable and enter an other password as the first one.

Thanks




________________________________
Von: Ryan West <rwest [at] zyedge>
An: michael schnatterer <michael6at [at] yahoo>; Adam Korab <adam.korab [at] gmail>
CC: "rancid-discuss [at] shrubbery" <rancid-discuss [at] shrubbery>
Gesendet: 13:56 Dienstag, 29.Mai 2012
Betreff: RE: [rancid] Rancid enable problem

On Tue, May 29, 2012 at 02:47:51, michael schnatterer wrote:
> Subject: Re: [rancid] Rancid enable problem
>
> Hy Guy's
>
> Thanks for your help, but it wouldn't work...
> I tried with clogin -autoenable 193.186.1.2 but the enable command
> doesn't come.
> I tried to write the add autoenable 193.186.1.2 1 or 0 on the top of
> my cloginrc, without success.
>
> I'am a little bit frustrated about the problem :(
>
> have anybody any other idea?
>
> Realy thanks for every help

When you login to the device manually with the RANCID username, what exactly do you type? Is it {username}, followed by {password}, then enable, followed by the same {password}?


rwest at zyedge

May 29, 2012, 5:49 AM

Post #9 of 15 (2397 views)
Permalink
Re: Rancid enable problem [In reply to]

Paste a sanitized version of your .cloginrc file.

Sent from handheld

On May 29, 2012, at 8:46 AM, "michael schnatterer" <michael6at [at] yahoo<mailto:michael6at [at] yahoo>> wrote:

In this case i have an other username as RANCID, but this username is entered in the cloginrc too.

add user 193.186.1.2 {User}
I login with the User and a password, after that i write enable and enter an other password as the first one.

Thanks

________________________________
Von: Ryan West <rwest [at] zyedge<mailto:rwest [at] zyedge>>
An: michael schnatterer <michael6at [at] yahoo<mailto:michael6at [at] yahoo>>; Adam Korab <adam.korab [at] gmail<mailto:adam.korab [at] gmail>>
CC: "rancid-discuss [at] shrubbery<mailto:rancid-discuss [at] shrubbery>" <rancid-discuss [at] shrubbery<mailto:rancid-discuss [at] shrubbery>>
Gesendet: 13:56 Dienstag, 29.Mai 2012
Betreff: RE: [rancid] Rancid enable problem

On Tue, May 29, 2012 at 02:47:51, michael schnatterer wrote:
> Subject: Re: [rancid] Rancid enable problem
>
> Hy Guy's
>
> Thanks for your help, but it wouldn't work...
> I tried with clogin -autoenable 193.186.1.2 but the enable command
> doesn't come.
> I tried to write the add autoenable 193.186.1.2 1 or 0 on the top of
> my cloginrc, without success.
>
> I'am a little bit frustrated about the problem :(
>
> have anybody any other idea?
>
> Realy thanks for every help

When you login to the device manually with the RANCID username, what exactly do you type? Is it {username}, followed by {password}, then enable, followed by the same {password}?


michael6at at yahoo

May 29, 2012, 7:38 AM

Post #10 of 15 (2407 views)
Permalink
Re: Rancid enable problem [In reply to]

.cloginrc

add user user1 {password}
add user * {rancid}

#Firewall
add password 193.186.1.2 {userpassword} {enablepassword}
add autoenable 193.186.1.2 1 or 0

add method * {ssh} {telnet}


Thats it, how i said in my further post on every asa firewall work this config

Best regards and thanks



________________________________
Von: Ryan West <rwest [at] zyedge>
An: michael schnatterer <michael6at [at] yahoo>
CC: Adam Korab <adam.korab [at] gmail>; "rancid-discuss [at] shrubbery" <rancid-discuss [at] shrubbery>
Gesendet: 14:49 Dienstag, 29.Mai 2012
Betreff: Re: [rancid] Rancid enable problem


Paste a sanitized version of your .cloginrc file.

Sent from handheld

On May 29, 2012, at 8:46 AM, "michael schnatterer" <michael6at [at] yahoo> wrote:


In this case i have an other username as RANCID, but this username is entered in the cloginrc too.
>
>
>add user 193.186.1.2 {User}
>I login with the User and a password, after that i write enable and enter an other password as the first one.
>
>
>Thanks
>
>
>
>
>________________________________
> Von: Ryan West <rwest [at] zyedge>
>An: michael schnatterer <michael6at [at] yahoo>; Adam Korab <adam.korab [at] gmail>
>CC: "rancid-discuss [at] shrubbery" <rancid-discuss [at] shrubbery>
>Gesendet: 13:56 Dienstag, 29.Mai 2012
>Betreff: RE: [rancid] Rancid enable problem
>
>On Tue, May 29, 2012 at 02:47:51, michael schnatterer wrote:
>> Subject: Re: [rancid] Rancid enable problem
>>
>> Hy Guy's
>>
>> Thanks for your help, but it wouldn't work...
>> I tried with clogin -autoenable 193.186.1.2 but the enable command
>> doesn't come.
>> I tried to write the add autoenable 193.186.1.2 1 or 0 on the top of
>> my cloginrc, without success.
>>
>> I'am a little bit frustrated about the problem :(
>>
>> have anybody any other idea?
>>
>> Realy thanks for every help
>
>When you login to the device manually with the RANCID username, what exactly do you type? Is it {username}, followed by {password}, then enable, followed by the same {password}?
>
>
>
>


rwest at zyedge

May 29, 2012, 8:42 AM

Post #11 of 15 (2396 views)
Permalink
Re: Rancid enable problem [In reply to]

The autoenable should be set to 0 for your config.

-ryan

From: michael schnatterer [mailto:michael6at [at] yahoo]
Sent: Tuesday, May 29, 2012 10:39 AM
To: Ryan West
Cc: Adam Korab; rancid-discuss [at] shrubbery
Subject: Re: [rancid] Rancid enable problem

.cloginrc

add user user1 {password}
add user * {rancid}

#Firewall
add password 193.186.1.2 {userpassword} {enablepassword}
add autoenable 193.186.1.2 1 or 0

add method * {ssh} {telnet}


Thats it, how i said in my further post on every asa firewall work this config
Best regards and thanks

________________________________
Von: Ryan West <rwest [at] zyedge<mailto:rwest [at] zyedge>>
An: michael schnatterer <michael6at [at] yahoo<mailto:michael6at [at] yahoo>>
CC: Adam Korab <adam.korab [at] gmail<mailto:adam.korab [at] gmail>>; "rancid-discuss [at] shrubbery<mailto:rancid-discuss [at] shrubbery>" <rancid-discuss [at] shrubbery<mailto:rancid-discuss [at] shrubbery>>
Gesendet: 14:49 Dienstag, 29.Mai 2012
Betreff: Re: [rancid] Rancid enable problem

Paste a sanitized version of your .cloginrc file.

Sent from handheld

On May 29, 2012, at 8:46 AM, "michael schnatterer" <michael6at [at] yahoo<mailto:michael6at [at] yahoo>> wrote:
In this case i have an other username as RANCID, but this username is entered in the cloginrc too.

add user 193.186.1.2 {User}
I login with the User and a password, after that i write enable and enter an other password as the first one.

Thanks

________________________________
Von: Ryan West <rwest [at] zyedge<mailto:rwest [at] zyedge>>
An: michael schnatterer <michael6at [at] yahoo<mailto:michael6at [at] yahoo>>; Adam Korab <adam.korab [at] gmail<mailto:adam.korab [at] gmail>>
CC: "rancid-discuss [at] shrubbery<mailto:rancid-discuss [at] shrubbery>" <rancid-discuss [at] shrubbery<mailto:rancid-discuss [at] shrubbery>>
Gesendet: 13:56 Dienstag, 29.Mai 2012
Betreff: RE: [rancid] Rancid enable problem

On Tue, May 29, 2012 at 02:47:51, michael schnatterer wrote:
> Subject: Re: [rancid] Rancid enable problem
>
> Hy Guy's
>
> Thanks for your help, but it wouldn't work...
> I tried with clogin -autoenable 193.186.1.2 but the enable command
> doesn't come.
> I tried to write the add autoenable 193.186.1.2 1 or 0 on the top of
> my cloginrc, without success.
>
> I'am a little bit frustrated about the problem :(
>
> have anybody any other idea?
>
> Realy thanks for every help

When you login to the device manually with the RANCID username, what exactly do you type? Is it {username}, followed by {password}, then enable, followed by the same {password}?


michael6at at yahoo

May 30, 2012, 7:07 AM

Post #12 of 15 (2392 views)
Permalink
Re: Rancid enable problem [In reply to]

Hy,
Thanks for your Reply,

But i have tried 0 and 1 already...



________________________________
Von: Ryan West <rwest [at] zyedge>
An: michael schnatterer <michael6at [at] yahoo>
CC: Adam Korab <adam.korab [at] gmail>; "rancid-discuss [at] shrubbery" <rancid-discuss [at] shrubbery>
Gesendet: 17:42 Dienstag, 29.Mai 2012
Betreff: RE: [rancid] Rancid enable problem



The autoenable should be set to 0 for your config.

-ryan

From:michael schnatterer [mailto:michael6at [at] yahoo]
Sent: Tuesday, May 29, 2012 10:39 AM
To: Ryan West
Cc: Adam Korab; rancid-discuss [at] shrubbery
Subject: Re: [rancid] Rancid enable problem

.cloginrc

add user user1 {password}
add user * {rancid}

#Firewall
add password 193.186.1.2 {userpassword} {enablepassword}
add autoenable 193.186.1.2 1 or 0

add method * {ssh} {telnet}


Thats it, how i said in my further post on every asa firewall work this config
Best regards and thanks


________________________________

Von:Ryan West <rwest [at] zyedge>
An: michael schnatterer <michael6at [at] yahoo>
CC: Adam Korab <adam.korab [at] gmail>; "rancid-discuss [at] shrubbery" <rancid-discuss [at] shrubbery>
Gesendet: 14:49 Dienstag, 29.Mai 2012
Betreff: Re: [rancid] Rancid enable problem

Paste a sanitized version of your .cloginrc file.

Sent from handheld

On May 29, 2012, at 8:46 AM, "michael schnatterer" <michael6at [at] yahoo> wrote:
In this case i have an other username as RANCID, but this username is entered in the cloginrc too.
>
>add user 193.186.1.2 {User}
>I login with the User and a password, after that i write enable and enter an other password as the first one.
>
>Thanks
>
>
>________________________________
>
>Von:Ryan West <rwest [at] zyedge>
>An: michael schnatterer <michael6at [at] yahoo>; Adam Korab <adam.korab [at] gmail>
>CC: "rancid-discuss [at] shrubbery" <rancid-discuss [at] shrubbery>
>Gesendet: 13:56 Dienstag, 29.Mai 2012
>Betreff: RE: [rancid] Rancid enable problem
>
>On Tue, May 29, 2012 at 02:47:51, michael schnatterer wrote:
>> Subject: Re: [rancid] Rancid enable problem
>>
>> Hy Guy's
>>
>> Thanks for your help, but it wouldn't work...
>> I tried with clogin -autoenable 193.186.1.2 but the enable command
>> doesn't come.
>> I tried to write the add autoenable 193.186.1.2 1 or 0 on the top of
>> my cloginrc, without success.
>>
>> I'am a little bit frustrated about the problem :(
>>
>> have anybody any other idea?
>>
>> Realy thanks for every help
>
>When you login to the device manually with the RANCID username, what exactly do you type? Is it {username}, followed by {password}, then enable, followed by the same {password}?
>
>
>


michael6at at yahoo

May 31, 2012, 6:24 AM

Post #13 of 15 (2393 views)
Permalink
Re: Rancid enable problem [In reply to]

Hy,
Here is my Output:

rancid [at] srv0: /home/rancid/bin/clogin -c show version "hostname"

version
spawn ssh -c 3des -x -l rancid version
ssh: Could not resolve hostname version: Name or service not known

Error: Couldn't login: version
"hostname"
spawn ssh -c 3des -x -l "User" "hostname"
"user"@"hostnames" password:
#######ASA Firewall ########
ASA-FW>
ASA-FW> termin terminal length 0
^
ERROR: % Invalid input detected at '^' marker.
ERROR: Command authorization failed
ASA-FW>show
INFO: % Type "show ?" for a list of
subcommands
ASA-FW> exit


________________________________
Von: Ryan West <rwest [at] zyedge>
An: michael schnatterer <michael6at [at] yahoo>
CC: Adam Korab <adam.korab [at] gmail>; "rancid-discuss [at] shrubbery" <rancid-discuss [at] shrubbery>
Gesendet: 17:42 Dienstag, 29.Mai 2012
Betreff: RE: [rancid] Rancid enable problem



The autoenable should be set to 0 for your config.

-ryan

From:michael schnatterer [mailto:michael6at [at] yahoo]
Sent: Tuesday, May 29, 2012 10:39 AM
To: Ryan West
Cc: Adam Korab; rancid-discuss [at] shrubbery
Subject: Re: [rancid] Rancid enable problem

.cloginrc

add user user1 {password}
add user * {rancid}

#Firewall
add password 193.186.1.2 {userpassword} {enablepassword}
add autoenable 193.186.1.2 1 or 0

add method * {ssh} {telnet}


Thats it, how i said in my further post on every asa firewall work this config
Best regards and thanks


________________________________

Von:Ryan West <rwest [at] zyedge>
An: michael schnatterer <michael6at [at] yahoo>
CC: Adam Korab <adam.korab [at] gmail>; "rancid-discuss [at] shrubbery" <rancid-discuss [at] shrubbery>
Gesendet: 14:49 Dienstag, 29.Mai 2012
Betreff: Re: [rancid] Rancid enable problem

Paste a sanitized version of your .cloginrc file.

Sent from handheld

On May 29, 2012, at 8:46 AM, "michael schnatterer" <michael6at [at] yahoo> wrote:
In this case i have an other username as RANCID, but this username is entered in the cloginrc too.
>
>add user 193.186.1.2 {User}
>I login with the User and a password, after that i write enable and enter an other password as the first one.
>
>Thanks
>
>
>________________________________
>
>Von:Ryan West <rwest [at] zyedge>
>An: michael schnatterer <michael6at [at] yahoo>; Adam Korab <adam.korab [at] gmail>
>CC: "rancid-discuss [at] shrubbery" <rancid-discuss [at] shrubbery>
>Gesendet: 13:56 Dienstag, 29.Mai 2012
>Betreff: RE: [rancid] Rancid enable problem
>
>On Tue, May 29, 2012 at 02:47:51, michael schnatterer wrote:
>> Subject: Re: [rancid] Rancid enable problem
>>
>> Hy Guy's
>>
>> Thanks for your help, but it wouldn't work...
>> I tried with clogin -autoenable 193.186.1.2 but the enable command
>> doesn't come.
>> I tried to write the add autoenable 193.186.1.2 1 or 0 on the top of
>> my cloginrc, without success.
>>
>> I'am a little bit frustrated about the problem :(
>>
>> have anybody any other idea?
>>
>> Realy thanks for every help
>
>When you login to the device manually with the RANCID username, what exactly do you type? Is it {username}, followed by {password}, then enable, followed by the same {password}?
>
>
>


rwest at zyedge

May 31, 2012, 7:24 AM

Post #14 of 15 (2391 views)
Permalink
Re: Rancid enable problem [In reply to]

You're never issuing enable, which is why you need autoenable 0. Post the same output with autoenable 0.

Sent from handheld

On May 31, 2012, at 9:25 AM, "michael schnatterer" <michael6at [at] yahoo<mailto:michael6at [at] yahoo>> wrote:

Hy,
Here is my Output:

rancid [at] srv0: /home/rancid/bin/clogin -c show version "hostname"

version
spawn ssh -c 3des -x -l rancid version
ssh: Could not resolve hostname version: Name or service not known

Error: Couldn't login: version
"hostname"
spawn ssh -c 3des -x -l "User" "hostname"
"user"@"hostnames" password:
#######ASA Firewall ########
ASA-FW>
ASA-FW> termin terminal length 0
^
ERROR: % Invalid input detected at '^' marker.
ERROR: Command authorization failed
ASA-FW>show
INFO: % Type "show ?" for a list of subcommands
ASA-FW> exit

________________________________
Von: Ryan West <rwest [at] zyedge<mailto:rwest [at] zyedge>>
An: michael schnatterer <michael6at [at] yahoo<mailto:michael6at [at] yahoo>>
CC: Adam Korab <adam.korab [at] gmail<mailto:adam.korab [at] gmail>>; "rancid-discuss [at] shrubbery<mailto:rancid-discuss [at] shrubbery>" <rancid-discuss [at] shrubbery<mailto:rancid-discuss [at] shrubbery>>
Gesendet: 17:42 Dienstag, 29.Mai 2012
Betreff: RE: [rancid] Rancid enable problem

The autoenable should be set to 0 for your config.

-ryan

From: michael schnatterer [mailto:michael6at [at] yahoo]
Sent: Tuesday, May 29, 2012 10:39 AM
To: Ryan West
Cc: Adam Korab; rancid-discuss [at] shrubbery<mailto:rancid-discuss [at] shrubbery>
Subject: Re: [rancid] Rancid enable problem

.cloginrc

add user user1 {password}
add user * {rancid}

#Firewall
add password 193.186.1.2 {userpassword} {enablepassword}
add autoenable 193.186.1.2 1 or 0

add method * {ssh} {telnet}


Thats it, how i said in my further post on every asa firewall work this config
Best regards and thanks

________________________________
Von: Ryan West <rwest [at] zyedge<mailto:rwest [at] zyedge>>
An: michael schnatterer <michael6at [at] yahoo<mailto:michael6at [at] yahoo>>
CC: Adam Korab <adam.korab [at] gmail<mailto:adam.korab [at] gmail>>; "rancid-discuss [at] shrubbery<mailto:rancid-discuss [at] shrubbery>" <rancid-discuss [at] shrubbery<mailto:rancid-discuss [at] shrubbery>>
Gesendet: 14:49 Dienstag, 29.Mai 2012
Betreff: Re: [rancid] Rancid enable problem

Paste a sanitized version of your .cloginrc file.

Sent from handheld

On May 29, 2012, at 8:46 AM, "michael schnatterer" <michael6at [at] yahoo<mailto:michael6at [at] yahoo>> wrote:
In this case i have an other username as RANCID, but this username is entered in the cloginrc too.

add user 193.186.1.2 {User}
I login with the User and a password, after that i write enable and enter an other password as the first one.

Thanks

________________________________
Von: Ryan West <rwest [at] zyedge<mailto:rwest [at] zyedge>>
An: michael schnatterer <michael6at [at] yahoo<mailto:michael6at [at] yahoo>>; Adam Korab <adam.korab [at] gmail<mailto:adam.korab [at] gmail>>
CC: "rancid-discuss [at] shrubbery<mailto:rancid-discuss [at] shrubbery>" <rancid-discuss [at] shrubbery<mailto:rancid-discuss [at] shrubbery>>
Gesendet: 13:56 Dienstag, 29.Mai 2012
Betreff: RE: [rancid] Rancid enable problem

On Tue, May 29, 2012 at 02:47:51, michael schnatterer wrote:
> Subject: Re: [rancid] Rancid enable problem
>
> Hy Guy's
>
> Thanks for your help, but it wouldn't work...
> I tried with clogin -autoenable 193.186.1.2 but the enable command
> doesn't come.
> I tried to write the add autoenable 193.186.1.2 1 or 0 on the top of
> my cloginrc, without success.
>
> I'am a little bit frustrated about the problem :(
>
> have anybody any other idea?
>
> Realy thanks for every help

When you login to the device manually with the RANCID username, what exactly do you type? Is it {username}, followed by {password}, then enable, followed by the same {password}?


michael6at at yahoo

Jun 6, 2012, 6:28 AM

Post #15 of 15 (2397 views)
Permalink
Re: Rancid enable problem [In reply to]

Hy Guy's

I'am realy Happy it works now for me :)
The problem was the banner, i take * instead of the # and now everything is working

Thanks again for everybody that helped me!
Best Regards



________________________________
Von: Ryan West <rwest [at] zyedge>
An: michael schnatterer <michael6at [at] yahoo>
CC: Adam Korab <adam.korab [at] gmail>; "rancid-discuss [at] shrubbery" <rancid-discuss [at] shrubbery>
Gesendet: 16:24 Donnerstag, 31.Mai 2012
Betreff: Re: [rancid] Rancid enable problem


You're never issuing enable, which is why you need autoenable 0. Post the same output with autoenable 0.

Sent from handheld

On May 31, 2012, at 9:25 AM, "michael schnatterer" <michael6at [at] yahoo> wrote:


Hy,
>Here is my Output:
>
>rancid [at] srv0: /home/rancid/bin/clogin -c show version "hostname"
>
>version
>spawn ssh -c 3des -x -l rancid version
>ssh: Could not resolve hostname version: Name or service not known
>
>Error: Couldn't login: version
>"hostname"
>spawn ssh -c 3des -x -l "User" "hostname"
>"user"@"hostnames" password:
>#######ASA Firewall ########
>ASA-FW>
>ASA-FW> termin terminal length 0
> ^
>ERROR: % Invalid input detected at '^' marker.
>ERROR: Command authorization failed
>ASA-FW>show
>INFO: % Type "show ?" for a list of subcommands
>ASA-FW> exit
>
>
>
>________________________________
> Von: Ryan West <rwest [at] zyedge>
>An: michael schnatterer <michael6at [at] yahoo>
>CC: Adam Korab <adam.korab [at] gmail>; "rancid-discuss [at] shrubbery" <rancid-discuss [at] shrubbery>
>Gesendet: 17:42 Dienstag, 29.Mai 2012
>Betreff: RE: [rancid] Rancid enable problem
>
>
>
>The autoenable should be set to 0 for your config.
>
>-ryan
>
>From:michael schnatterer [mailto:michael6at [at] yahoo]
>Sent: Tuesday, May 29, 2012 10:39 AM
>To: Ryan West
>Cc: Adam Korab; rancid-discuss [at] shrubbery
>Subject: Re: [rancid] Rancid enable problem
>
>.cloginrc
>
>add user user1 {password}
>add user * {rancid}
>
>#Firewall
>add password 193.186.1.2 {userpassword} {enablepassword}
>add autoenable 193.186.1.2 1 or 0
>
>add method * {ssh} {telnet}
>
>
>Thats it, how i said in my further post on every asa firewall work this config
>Best regards and thanks
>
>
>________________________________
>
>Von:Ryan West <rwest [at] zyedge>
>An: michael schnatterer <michael6at [at] yahoo>
>CC: Adam Korab <adam.korab [at] gmail>; "rancid-discuss [at] shrubbery" <rancid-discuss [at] shrubbery>
>Gesendet: 14:49 Dienstag, 29.Mai 2012
>Betreff: Re: [rancid] Rancid enable problem
>
>Paste a sanitized version of your .cloginrc file.
>
>Sent from handheld
>
>On May 29, 2012, at 8:46 AM, "michael schnatterer" <michael6at [at] yahoo> wrote:
>In this case i have an other username as RANCID, but this username is entered in the cloginrc too.
>>
>>add user 193.186.1.2 {User}
>>I login with the User and a password, after that i write enable and enter an other password as the first one.
>>
>>Thanks
>>
>>
>>________________________________
>>
>>Von:Ryan West <rwest [at] zyedge>
>>An: michael schnatterer <michael6at [at] yahoo>; Adam Korab <adam.korab [at] gmail>
>>CC: "rancid-discuss [at] shrubbery" <rancid-discuss [at] shrubbery>
>>Gesendet: 13:56 Dienstag, 29.Mai 2012
>>Betreff: RE: [rancid] Rancid enable problem
>>
>>On Tue, May 29, 2012 at 02:47:51, michael schnatterer wrote:
>>> Subject: Re: [rancid] Rancid enable problem
>>>
>>> Hy Guy's
>>>
>>> Thanks for your help, but it wouldn't work...
>>> I tried with clogin -autoenable 193.186.1.2 but the enable command
>>> doesn't come.
>>> I tried to write the add autoenable 193.186.1.2 1 or 0 on the top of
>>> my cloginrc, without success.
>>>
>>> I'am a little bit frustrated about the problem :(
>>>
>>> have anybody any other idea?
>>>
>>> Realy thanks for every help
>>
>>When you login to the device manually with the RANCID username, what exactly do you type? Is it {username}, followed by {password}, then enable, followed by the same {password}?
>>
>>
>>
>
>
>

RANCID users RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.