Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: Quagga: Users

Segmentation fault while running Quagga on Octeon

 

 

Quagga users RSS feed   Index | Next | Previous | View Threaded


Harini.Gopalakrishnan at lntinfotech

May 24, 2012, 2:53 AM

Post #1 of 2 (405 views)
Permalink
Segmentation fault while running Quagga on Octeon

Hi ,
I am trying to cross compile quagga 0.99.18 routing suite for octeon .
After setting "ac_cv_func_malloc_0_nonnull=yes ac_cv_func_realloc_0_nonnull=yes" in configure my cross compilation was successful . But when I tried to run the zebra daemon on the octeon board I got a segmentation fault.
please suggest a way to go about this issue.
Also please provide a solution to get statically linked quagga daemons as the -static flag is ineffective.


Thanks & Regards,
Harini Gopalakrishnan


________________________________
The contents of this e-mail and any attachment(s) may contain confidential or privileged information for the intended recipient(s). Unintended recipients are prohibited from taking action on the basis of information in this e-mail and using or disseminating the information, and must notify the sender and delete it from their system. L&T Infotech will not accept responsibility or liability for the accuracy or completeness of, or the presence of any virus or disabling code in this e-mail"


avi.bana.sa.007 at gmail

May 24, 2012, 3:52 AM

Post #2 of 2 (380 views)
Permalink
Re: Segmentation fault while running Quagga on Octeon [In reply to]

Hi Harini,

Give:
--disable-pie flag while cross compiling . Then try...
On Thu, May 24, 2012 at 3:23 PM, Harini Gopalakrishnan <
Harini.Gopalakrishnan [at] lntinfotech> wrote:

> Hi ,****
>
> I am trying to cross compile quagga 0.99.18 routing suite
> for octeon . ****
>
> After setting “ac_cv_func_malloc_0_nonnull=yes
> ac_cv_func_realloc_0_nonnull=yes” in configure my cross compilation was
> successful . But when I tried to run the zebra daemon on the octeon board I
> got a segmentation fault.****
>
> please suggest a way to go about this issue.****
>
> Also please provide a solution to * get statically linked quagga daemons *as
> the –static flag is ineffective*.*
>
> ** **
>
> ** **
>
> Thanks & Regards,****
>
> Harini Gopalakrishnan****
>
> ** **
>
> ------------------------------
> The contents of this e-mail and any attachment(s) may contain confidential
> or privileged information for the intended recipient(s). Unintended
> recipients are prohibited from taking action on the basis of information in
> this e-mail and using or disseminating the information, and must notify the
> sender and delete it from their system. L&T Infotech will not accept
> responsibility or liability for the accuracy or completeness of, or the
> presence of any virus or disabling code in this e-mail"
>
> _______________________________________________
> Quagga-users mailing list
> Quagga-users [at] lists
> http://lists.quagga.net/mailman/listinfo/quagga-users
>
>

Quagga users RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.