Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: Quagga: Users

Multiple loopback interfaces

 

 

Quagga users RSS feed   Index | Next | Previous | View Threaded


renatowestphal at gmail

Nov 8, 2010, 3:42 AM

Post #1 of 4 (2761 views)
Permalink
Multiple loopback interfaces

Hi all,

Anyone knows if there is a way to configure multiple loopback interfaces on
Quagga/Linux?

Ex (Cisco):
interface Loopback0
ip address 192.168.20.20 255.255.255.255
router ospf 1
network 192.168.20.20 0.0.0.0 area 10

R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static
route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

...
192.168.20.0/32 is subnetted, 1 subnets
C 192.168.20.20 is directly connected, Loopback0
....
-----------------------------------------------------------------------------------------------------------

I can configure Quagga in the same way, however the loopback address is not
redistributed into OSPF. Actually the loopback interface is not even
installed in the kernel.

Any help would be appreciated.

--
Renato Westphal


tyler at tolaris

Nov 8, 2010, 4:07 AM

Post #2 of 4 (2693 views)
Permalink
Re: Multiple loopback interfaces [In reply to]

I do the same thing - use a loopback address and advertise it via OSPF.
I set an interface alias, lo:1, at the OS level, outside Quagga. The
Debian way is /etc/network/interfaces:

auto lo:1
iface lo:1 inet static
address 192.168.20.20
netmask 255.255.255.255

Then in Quagga:

router ospf
ospf router-id 192.168.20.20
network 192.168.20.20/32 area 0.0.0.0

Regards,
Tyler

On Mon, 2010-11-08 at 09:42 -0200, Renato Westphal wrote:
> Hi all,
>
>
> Anyone knows if there is a way to configure multiple loopback
> interfaces on Quagga/Linux?
>
>
> Ex (Cisco):
> interface Loopback0
> ip address 192.168.20.20 255.255.255.255
> router ospf 1
> network 192.168.20.20 0.0.0.0 area 10
>
>
> R2#show ip route
> Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
> D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
> N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
> E1 - OSPF external type 1, E2 - OSPF external type 2
> i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS
> level-2
> ia - IS-IS inter area, * - candidate default, U - per-user
> static route
> o - ODR, P - periodic downloaded static route
>
>
> Gateway of last resort is not set
>
>
> ...
> 192.168.20.0/32 is subnetted, 1 subnets
> C 192.168.20.20 is directly connected, Loopback0
> ....
> -----------------------------------------------------------------------------------------------------------
>
>
> I can configure Quagga in the same way, however the loopback address
> is not redistributed into OSPF. Actually the loopback interface is not
> even installed in the kernel.
>
>
> Any help would be appreciated.
>
> --
> Renato Westphal
>
> _______________________________________________
> Quagga-users mailing list
> Quagga-users [at] lists
> http://lists.quagga.net/mailman/listinfo/quagga-users

--
--
"Freedom of thought is best promoted by the gradual illumination of
men's minds, which follows from the advance of science."
-- Charles Darwin

_______________________________________________
Quagga-users mailing list
Quagga-users [at] lists
http://lists.quagga.net/mailman/listinfo/quagga-users


mike-quagga at tiedyenetworks

Nov 8, 2010, 4:27 AM

Post #3 of 4 (2703 views)
Permalink
Re: Multiple loopback interfaces [In reply to]

Renato Westphal wrote:
> Hi all,
>
> Anyone knows if there is a way to configure multiple loopback
> interfaces on Quagga/Linux?
>
> Ex (Cisco):
> interface Loopback0
> ip address 192.168.20.20 255.255.255.255
> router ospf 1
> network 192.168.20.20 0.0.0.0 area 10
>
> R2#show ip route
> Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
> D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
> N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
> E1 - OSPF external type 1, E2 - OSPF external type 2
> i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS
> level-2
> ia - IS-IS inter area, * - candidate default, U - per-user
> static route
> o - ODR, P - periodic downloaded static route
>
> Gateway of last resort is not set
>
> ...
> 192.168.20.0/32 <http://192.168.20.0/32> is subnetted, 1 subnets
> C 192.168.20.20 is directly connected, Loopback0
> ....
> -----------------------------------------------------------------------------------------------------------
>
> I can configure Quagga in the same way, however the loopback address
> is not redistributed into OSPF. Actually the loopback interface is not
> even installed in the kernel.
>
> Any help would be appreciated.
>

Well firstly you need to configure the loopback interface in the zebra
daemon. If you don't do that and instead use an operating system specfic
method, you are likely to fail.

eg: in zebra (or zebra.conf)

interface lo
description local loopback
ip address 127.0.0.1/8
ip address 192.168.20.20/32



Verify then it's installed in the routing table. I think that's all
you'll need.

Mike-
_______________________________________________
Quagga-users mailing list
Quagga-users [at] lists
http://lists.quagga.net/mailman/listinfo/quagga-users


renatowestphal at gmail

Nov 8, 2010, 11:55 AM

Post #4 of 4 (2699 views)
Permalink
Re: Multiple loopback interfaces [In reply to]

2010/11/8 mike <mike-quagga [at] tiedyenetworks>

> Renato Westphal wrote:
>
>> Hi all,
>>
>> Anyone knows if there is a way to configure multiple loopback interfaces
>> on Quagga/Linux?
>>
>> Ex (Cisco):
>> interface Loopback0
>> ip address 192.168.20.20 255.255.255.255
>> router ospf 1
>> network 192.168.20.20 0.0.0.0 area 10
>>
>> R2#show ip route
>> Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
>> D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
>> N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
>> E1 - OSPF external type 1, E2 - OSPF external type 2
>> i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS
>> level-2
>> ia - IS-IS inter area, * - candidate default, U - per-user static
>> route
>> o - ODR, P - periodic downloaded static route
>>
>> Gateway of last resort is not set
>>
>> ...
>> 192.168.20.0/32 <http://192.168.20.0/32> is subnetted, 1 subnets
>>
>> C 192.168.20.20 is directly connected, Loopback0
>> ....
>>
>> -----------------------------------------------------------------------------------------------------------
>>
>> I can configure Quagga in the same way, however the loopback address is
>> not redistributed into OSPF. Actually the loopback interface is not even
>> installed in the kernel.
>>
>> Any help would be appreciated.
>>
>>
> Well firstly you need to configure the loopback interface in the zebra
> daemon. If you don't do that and instead use an operating system specfic
> method, you are likely to fail.
>
> eg: in zebra (or zebra.conf)
>
> interface lo
> description local loopback
> ip address 127.0.0.1/8
> ip address 192.168.20.20/32
>
>
>
> Verify then it's installed in the routing table. I think that's all you'll
> need.
>
> Mike-
>
> _______________________________________________
> Quagga-users mailing list
> Quagga-users [at] lists
> http://lists.quagga.net/mailman/listinfo/quagga-users
>

Tyler/Mike,

Thank you very much!

--
Renato Westphal

Quagga users RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.