Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: Qmail: users

HELO/EHLO not required ?

 

 

Qmail users RSS feed   Index | Next | Previous | View Threaded


jens at bruger

Dec 7, 2011, 9:42 AM

Post #1 of 3 (1338 views)
Permalink
HELO/EHLO not required ?

Hi,

I just came across this site...
<http://notes.sagredo.eu/node/22#chkuser>

And I noticed that ehlo/helo is 'not required anymore' after applying the AUTH patch.
I've just verified that I can send mail to myself without providing helo/ehlo.
Is this correct behaviour ?!??
Usually qmail required helo, and I am surprised that it's not required.


Love,
Jens


search-web-for-address at pyropus

Dec 7, 2011, 10:07 AM

Post #2 of 3 (1263 views)
Permalink
Re: HELO/EHLO not required ? [In reply to]

Jens Bauer <jens [at] bruger> wrote:
>
> And I noticed that ehlo/helo is 'not required anymore' after applying the
> AUTH patch. I've just verified that I can send mail to myself without
> providing helo/ehlo. Is this correct behaviour ?!?? Usually qmail required
> helo, and I am surprised that it's not required.

You're mistaken. qmail-smtpd does not require the client to issue HELO/EHLO
prior to sending mail, and never has to the best of my knowledge.

Perhaps you've been using an add-on or patch that makes that change?

Charles
--
--------------------------------------------------------------------------
Charles Cazabon
GPL'ed software available at: http://pyropus.ca/software/
Read http://pyropus.ca/personal/writings/12-steps-to-qmail-list-bliss.html
--------------------------------------------------------------------------


jens at plustv

Dec 8, 2011, 2:38 AM

Post #3 of 3 (1262 views)
Permalink
Re: HELO/EHLO not required ? [In reply to]

Hi Charles,

You're right. I confused that qmail required 'mail from' before 'rcpt to' for being 'helo' before anything else, so sorry for the noise... :)


Love,
Jens


On 7 Dec 2011 12:07:30 -0600, Charles Cazabon wrote:
> Jens Bauer <jens [at] bruger> wrote:
>>
>> And I noticed that ehlo/helo is 'not required anymore' after applying the
>> AUTH patch. I've just verified that I can send mail to myself without
>> providing helo/ehlo. Is this correct behaviour ?!?? Usually qmail
>> required
>> helo, and I am surprised that it's not required.
>
> You're mistaken. qmail-smtpd does not require the client to issue HELO/EHLO
> prior to sending mail, and never has to the best of my knowledge.
>
> Perhaps you've been using an add-on or patch that makes that change?
>
> Charles
> --
> --------------------------------------------------------------------------
> Charles Cazabon
> GPL'ed software available at: http://pyropus.ca/software/
> Read http://pyropus.ca/personal/writings/12-steps-to-qmail-list-bliss.html
> --------------------------------------------------------------------------
>

Qmail users RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.