Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: OpenStack: Netstack

About python versions that we are planning to support

 

 

OpenStack netstack RSS feed   Index | Next | Previous | View Threaded


gongysh at cn

May 7, 2012, 6:54 PM

Post #1 of 2 (229 views)
Permalink
About python versions that we are planning to support

Hi,
I see some ones are trying to support python2.4. But our tox.ini under quantum is only supporting test py26 and py27.
So my question is if we are trying to support py24. In addition I remember that we will support py30.

As far as I know, py2.4 does not support many new syntaxes introduced by py2.5+. Other projects such as nova, horizon are also adopting some of these new syntaxes. Moreover some third party components such as Django 1.4 required by horizon are only tested under py2.6 and py2.7.

So if py2.4 is out of our scope, we should stop that trying. If we need py2.4, we have to make all of us know it and keep our code 2.4 compatible.

Thanks

Yong Sheng Gong


mnewby at internap

May 7, 2012, 8:53 PM

Post #2 of 2 (228 views)
Permalink
Re: About python versions that we are planning to support [In reply to]

Hi,

Python 2.4 compatibility is required, but only for agent code. Agent code needs to be deployable on Xen dom0, which uses CentoOS 5.5 and only supports 2.4 out of the box.

Both quantum and nova have agent code that needs to be deployed to dom0, but up until now both projects have relied on savvy reviewers and bug reports to ensure compatibility. I'm working on it, though. I'll be adding a tox build to quantum that will run agent tests - and agent tests only - under 2.4, and then openstack-ci can add a jenkins job to run that build on CentOS and gate merges.

The relevant bug: https://bugs.launchpad.net/quantum/+bug/995278

Thanks,


Maru


On 2012-05-07, at 6:54 PM, Yong Sheng Gong wrote:

> Hi,
> I see some ones are trying to support python2.4. But our tox.ini under quantum is only supporting test py26 and py27.
> So my question is if we are trying to support py24. In addition I remember that we will support py30.
>
> As far as I know, py2.4 does not support many new syntaxes introduced by py2.5+. Other projects such as nova, horizon are also adopting some of these new syntaxes. Moreover some third party components such as Django 1.4 required by horizon are only tested under py2.6 and py2.7.
>
> So if py2.4 is out of our scope, we should stop that trying. If we need py2.4, we have to make all of us know it and keep our code 2.4 compatible.
>
> Thanks
>
> Yong Sheng Gong
>
> --
> Mailing list: https://launchpad.net/~netstack
> Post to : netstack [at] lists
> Unsubscribe : https://launchpad.net/~netstack
> More help : https://help.launchpad.net/ListHelp

OpenStack netstack RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.