Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: OpenStack: Dev

Re: [Openstack-operators] ERROR: Malformed request url (HTTP 400)

 

 

OpenStack dev RSS feed   Index | Next | Previous | View Threaded


lorin at nimbisservices

May 30, 2012, 2:28 PM

Post #1 of 1 (112 views)
Permalink
Re: [Openstack-operators] ERROR: Malformed request url (HTTP 400)

Hi Igor:

The best place to report problems with the docs is to file a bug in the openstack-manuals project on launchpad: https://bugs.launchpad.net/openstack-manuals

(You'll need to create a Launchpad account to report a bug if you don't have one yet).

Take care,

Lorin
--
Lorin Hochstein
Lead Architect - Cloud Services
Nimbis Services, Inc.
www.nimbisservices.com





On May 30, 2012, at 3:10 PM, Igor Laskovy wrote:

> Hi all again!
> Just need clarification, in which way I can send a messages about
> mistakes in that docs?
>
> On Sun, May 13, 2012 at 6:47 PM, Igor Laskovy <igor.laskovy [at] gmail> wrote:
>> Well, instead of it I did use the real uuid of service tenant))
>> End, actually that clarify about %(tenant_id)s is exist at docs.
>>
>> BTW, for what reason needs to execute TENANT variable in the volume section?
>>
>> On May 13, 2012 5:55 PM, "Dolph Mathews" <dolph.mathews [at] gmail> wrote:
>>>
>>> Igor,
>>>
>>> What did you use instead / how did you interpret that portion of the docs?
>>>
>>> I think we need to clarify in the docs that %(tenant_id)s is very
>>> intentional, and intended to be used exactly as written (and explain how it
>>> behaves) -- you're certainly not the first person to run into this kind of
>>> issue on endpoints.
>>>
>>> -Dolph
>>>
>>> On Sun, May 13, 2012 at 8:42 AM, Igor Laskovy <igor.laskovy [at] gmail>
>>> wrote:
>>>>
>>>> Hello all,
>>>>
>>>> I have solved this problem))
>>>> For me it was incorrect built endpoints in keystone for nova and
>>>> volume services.
>>>> I thought that %(tenant_id)s is mistake as other mistakes in the
>>>> installation guide
>>>>
>>>> (http://docs.openstack.org/trunk/openstack-compute/install/content/keystone-service-endpoint-create.html),
>>>> but it wasn't .
>>>>
>>>> Thanks everybody for attention!
>>>>
>>>> On Sat, May 12, 2012 at 4:53 PM, Igor Laskovy <igor.laskovy [at] gmail>
>>>> wrote:
>>>>> Guys, I am still need help))
>>>>>
>>>>> On May 10, 2012 9:45 PM, "Igor Laskovy" <igor.laskovy [at] gmail> wrote:
>>>>>>
>>>>>> Hi Dolph and Kevin,
>>>>>> thank you for your attention and sorry for delay reply.
>>>>>>
>>>>>> Here are what I have in nova-api.log :
>>>>>>
>>>>>> 2012-05-10 14:40:08 INFO nova.api.openstack.wsgi
>>>>>> [req-c6b9ea76-bbe1-4796-a231-41fc41c7695f
>>>>>> 50be127b9b7f49dcbf5ffea06d23d83a ebf29e67cbd445daa5ad09f76cdf69f9] GET
>>>>>>
>>>>>> http://192.168.1.71:8774/v2/7033300637bc4964a8d0a43649fcf898/images/detail
>>>>>>
>>>>>> 2012-05-10 14:40:08 DEBUG nova.api.openstack.wsgi
>>>>>> [req-c6b9ea76-bbe1-4796-a231-41fc41c7695f
>>>>>> 50be127b9b7f49dcbf5ffea06d23d83a ebf29e67cbd445daa5ad09f76cdf69f9]
>>>>>> Unrecognized Content-Type provided in request from (pid=1005) get_body
>>>>>> /usr/lib/python2.7/dist-packages/nova/api/openstack/wsgi.py:697
>>>>>>
>>>>>> On Thu, May 10, 2012 at 2:27 AM, Dolph Mathews
>>>>>> <dolph.mathews [at] gmail>
>>>>>> wrote:
>>>>>>> Hrm, good catch! I see no problems with that request at all...
>>>>>>>
>>>>>>> -Dolph Mathews
>>>>>>>
>>>>>>> On May 9, 2012, at 5:58 PM, "Kevin L. Mitchell"
>>>>>>> <kevin.mitchell [at] rackspace> wrote:
>>>>>>>
>>>>>>>> On Wed, 2012-05-09 at 15:32 -0500, Dolph Mathews wrote:
>>>>>>>>> It also just occurred to me that perhaps you're using a *very* old
>>>>>>>>> novaclient against a more recent version of keystone?
>>>>>>>>
>>>>>>>> Actually, if you look a little more closely:
>>>>>>>>
>>>>>>>>> $ nova --debug image-list
>>>>>>>>> connect: (192.168.1.71, 5000)
>>>>>>>>> send: 'POST /v2.0/tokens HTTP/1.1\r\nHost:
>>>>>>>>> 192.168.1.71:5000\r\nContent-Length: 117\r
>>>>>>>>> \ncontent-type:
>>>>>>>>> application/json\r\naccept-encoding: gzip,
>>>>>>>>> deflate\r
>>>>>>>>> \naccept:
>>>>>>>>> application/json\r\nuser-agent:
>>>>>>>>> python-novaclient\r\n
>>>>>>>>> \r\n{"auth":
>>>>>>>> ^^^^^^^^
>>>>>>>>> {"tenantName": "labSpaceDemo",
>>>>>>>>> "passwordCredentials":
>>>>>>>>> {"username":
>>>>>>>>> "adminUser", "password": "lfplhfgthvf"}}}'
>>>>>>>>
>>>>>>>> The request body for Keystone is not, in fact, malformed. It would
>>>>>>>> be
>>>>>>>> interesting to look at the nova-api logs for this request…
>>>>>>>> --
>>>>>>>> Kevin L. Mitchell <kevin.mitchell [at] rackspace>
>>>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>> --
>>>>>> Igor Laskovy
>>>>
>>>>
>>>>
>>>> --
>>>> Igor Laskovy
>>>
>>>
>>
>
>
>
> --
> Igor Laskovy
> Kiev, Ukraine
> _______________________________________________
> Openstack-operators mailing list
> Openstack-operators [at] lists
> http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-operators
Attachments: smime.p7s (4.78 KB)

OpenStack dev RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.