Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: OpenStack: Dev

devstack multi-node tutorial fails

 

 

OpenStack dev RSS feed   Index | Next | Previous | View Threaded


mauch at kit

May 23, 2012, 7:00 AM

Post #1 of 9 (374 views)
Permalink
devstack multi-node tutorial fails

Hi,



I just want so say, that some days ago the stack.sh script hast been changed
concerning the rabbit server installation.

The current description for multi node tutorial
(http://devstack.org/guides/multinode-lab.html) will fail.



At the moment it is necessary to install the rabbit service on the compute
hosts TOO (but of course with the IP from the master node)!!

e.g.:



ENABLED_SERVICES=n-cpu,n-net,g-api,rabbit

RABBIT_HOST=$MASTERNODE
RABBIT_PASSWORD=pass





Otherwise the compute node tries to find a rabbit-mq server on localhost!



There are also some other wrong details in the multi-node toturial.



It must be:



RABBIT_PASSWORD and MYSQL_PASSWORD instead of MYSQL_PASS und RABBIT_PASS



Und the parameter MULTI_HOST=1 has to be change to MULTI_HOST=True (and
should only be available on the master node, as I understand it right).





Cheers Viktor



--

Dipl.-Phys. Viktor Mauch



Steinbuch Centre for Computing (SCC)

<http://www.scc.kit.edu/> http://www.scc.kit.edu/



Karlsruhe Institute of Technology (KIT)

Hermann-von-Helmholtz-Platz 1

D-76344 Eggenstein-Leopoldshafen



Phone: +49(0)721 608-28721

eMail: <mailto:mauch [at] kit> mauch [at] kit



KIT - University of the State of Baden-Wuerttemberg and National Research
Center of the Helmholtz Association
Attachments: smime.p7s (5.84 KB)


razique.mahroua at gmail

May 23, 2012, 7:27 AM

Post #2 of 9 (370 views)
Permalink
Re: devstack multi-node tutorial fails [In reply to]

Thanks for the feedback
as for the multi_node mode, no it supposes you spawn a nova-network
component on every compute node
Razique


> Mauch, Viktor (SCC) <mailto:mauch [at] kit>
> 23 mai 2012 16:00
>
> Hi,
>
> I just want so say, that some days ago the stack.sh script hast been
> changed concerning the rabbit server installation.
>
> The current description for multi node tutorial
> (http://devstack.org/guides/multinode-lab.html) will fail.
>
> At the moment it is necessary to install the rabbit service on the
> compute hosts TOO (but of course with the IP from the master node)!!
>
> e.g.:
>
> ENABLED_SERVICES=n-cpu,n-net,g-api,rabbit
>
> RABBIT_HOST=$MASTERNODE
> RABBIT_PASSWORD=pass
>
> Otherwise the compute node tries to find a rabbit-mq server on localhost!
>
> There are also some other wrong details in the multi-node toturial.
>
> It must be:
>
> RABBIT_PASSWORD and MYSQL_PASSWORD instead of MYSQL_PASS und RABBIT_PASS
>
> Und the parameter MULTI_HOST=1 has to be change to MULTI_HOST=True
> (and should only be available on the master node, as I understand it
> right).
>
> Cheers Viktor
>
> --
>
> Dipl.-Phys. Viktor Mauch
>
> Steinbuch Centre for Computing (SCC)
>
> http://www.scc.kit.edu/
>
> Karlsruhe Institute of Technology (KIT)
>
> Hermann-von-Helmholtz-Platz 1
>
> D-76344 Eggenstein-Leopoldshafen
>
> Phone: +49(0)721 608-28721
>
> eMail: mauch [at] kit <mailto:mauch [at] kit>
>
> KIT -- University of the State of Baden-Wuerttemberg and National
> Research Center of the Helmholtz Association
>
> _______________________________________________
> Mailing list: https://launchpad.net/~openstack
> Post to : openstack [at] lists
> Unsubscribe : https://launchpad.net/~openstack
> More help : https://help.launchpad.net/ListHelp

--
Nuage & Co - Razique Mahroua
razique.mahroua [at] gmail
Attachments: compose-unknown-contact.jpg (0.75 KB)
  image.jpg (9.88 KB)


dan at nicira

May 23, 2012, 8:36 AM

Post #3 of 9 (470 views)
Permalink
Re: devstack multi-node tutorial fails [In reply to]

Hi Viktor,

I've noticed similar issues (need to specify rabbit and glance api on
"compute nodes" even though it is unused) while running multi-node setups
with Quantum. I created a question on devstack's launchpad page for this,
but haven't heard anything yet:
https://answers.launchpad.net/devstack/+question/197749

Dan


On Wed, May 23, 2012 at 7:00 AM, Mauch, Viktor (SCC) <mauch [at] kit> wrote:

> Hi,****
>
> ** **
>
> I just want so say, that some days ago the stack.sh script hast been
> changed concerning the rabbit server installation.****
>
> The current description for multi node tutorial (
> http://devstack.org/guides/multinode-lab.html) will fail.****
>
> ** **
>
> At the moment it is necessary to install the rabbit service on the compute
> hosts TOO (but of course with the IP from the master node)!!****
>
> e.g.:****
>
> ** **
>
> ENABLED_SERVICES=n-cpu,n-net,g-api,rabbit****
>
> RABBIT_HOST=$MASTERNODE****
>
> RABBIT_PASSWORD=pass****
>
> ** **
>
> ** **
>
> Otherwise the compute node tries to find a rabbit-mq server on localhost!*
> ***
>
> ** **
>
> There are also some other wrong details in the multi-node toturial.****
>
> ** **
>
> It must be:****
>
> ** **
>
> RABBIT_PASSWORD and MYSQL_PASSWORD instead of MYSQL_PASS und RABBIT_PASS**
> **
>
> ** **
>
> Und the parameter MULTI_HOST=1 has to be change to MULTI_HOST=True (and
> should only be available on the master node, as I understand it right).***
> *
>
> ** **
>
> ** **
>
> Cheers Viktor****
>
> ** **
>
> --****
>
> Dipl.-Phys. Viktor Mauch****
>
> ** **
>
> Steinbuch Centre for Computing (SCC)****
>
> http://www.scc.kit.edu/****
>
> ** **
>
> Karlsruhe Institute of Technology (KIT)****
>
> Hermann-von-Helmholtz-Platz 1****
>
> D-76344 Eggenstein-Leopoldshafen****
>
> ** **
>
> Phone: +49(0)721 608-28721****
>
> eMail: mauch [at] kit****
>
> ** **
>
> KIT University of the State of Baden-Wuerttemberg and National Research
> Center of the Helmholtz Association****
>
> ** **
>
> _______________________________________________
> Mailing list: https://launchpad.net/~openstack
> Post to : openstack [at] lists
> Unsubscribe : https://launchpad.net/~openstack
> More help : https://help.launchpad.net/ListHelp
>
>


--
~~~~~~~~~~~~~~~~~~~~~~~~~~~
Dan Wendlandt
Nicira, Inc: www.nicira.com
twitter: danwendlandt
~~~~~~~~~~~~~~~~~~~~~~~~~~~


razique.mahroua at gmail

May 24, 2012, 1:18 AM

Post #4 of 9 (383 views)
Permalink
Re: devstack multi-node tutorial fails [In reply to]

Hey,
no you don't need to, the only case where the SSH exchange is mandatory
is for the [live|classi] migration

Raz
> Mauch, Viktor (SCC) <mailto:mauch [at] kit>
> 23 mai 2012 16:31
>
> Another thing:
>
> Is it really necessary to implement password-less ssh login via
> .ssh/authorized_keys?
>
> For me it works without it.
>
> Viktor
>
> *From:*Razique Mahroua [mailto:razique.mahroua [at] gmail]
> *Sent:* Wednesday, May 23, 2012 4:28 PM
> *To:* Mauch, Viktor (SCC)
> *Cc:* openstack [at] lists
> *Subject:* Re: [Openstack] devstack multi-node tutorial fails
>
> Thanks for the feedback
> as for the multi_node mode, no it supposes you spawn a nova-network
> component on every compute node
> Razique
>
>
>
> *Mauch, Viktor (SCC)* <mailto:mauch [at] kit>
>
> 23 mai 2012 16:00
>
> Hi,
>
> I just want so say, that some days ago the stack.sh script hast been
> changed concerning the rabbit server installation.
>
> The current description for multi node tutorial
> (http://devstack.org/guides/multinode-lab.html) will fail.
>
> At the moment it is necessary to install the rabbit service on the
> compute hosts TOO (but of course with the IP from the master node)!!
>
> e.g.:
>
> ENABLED_SERVICES=n-cpu,n-net,g-api,rabbit
>
> RABBIT_HOST=$MASTERNODE
>
> RABBIT_PASSWORD=pass
>
> Otherwise the compute node tries to find a rabbit-mq server on localhost!
>
> There are also some other wrong details in the multi-node toturial.
>
> It must be:
>
> RABBIT_PASSWORD and MYSQL_PASSWORD instead of MYSQL_PASS und RABBIT_PASS
>
> Und the parameter MULTI_HOST=1 has to be change to MULTI_HOST=True
> (and should only be available on the master node, as I understand it
> right).
>
> Cheers Viktor
>
> --
>
> Dipl.-Phys. Viktor Mauch
>
> Steinbuch Centre for Computing (SCC)
>
> http://www.scc.kit.edu/
>
> Karlsruhe Institute of Technology (KIT)
>
> Hermann-von-Helmholtz-Platz 1
>
> D-76344 Eggenstein-Leopoldshafen
>
> Phone: +49(0)721 608-28721
>
> eMail: mauch [at] kit <mailto:mauch [at] kit>
>
> KIT -- University of the State of Baden-Wuerttemberg and National
> Research Center of the Helmholtz Association
>
> _______________________________________________
> Mailing list: https://launchpad.net/~openstack
> <https://launchpad.net/%7Eopenstack>
> Post to : openstack [at] lists
> <mailto:openstack [at] lists>
> Unsubscribe : https://launchpad.net/~openstack
> <https://launchpad.net/%7Eopenstack>
> More help : https://help.launchpad.net/ListHelp
>
> --
> Nuage & Co - Razique Mahroua
> *razique.mahroua [at] gmail <mailto:razique.mahroua [at] gmail>*
>
> Razique Mahroua <mailto:razique.mahroua [at] gmail>
> 23 mai 2012 16:27
> Thanks for the feedback
> as for the multi_node mode, no it supposes you spawn a nova-network
> component on every compute node
> Razique
>
>
>

--
Nuage & Co - Razique Mahroua
razique.mahroua [at] gmail
Attachments: compose-unknown-contact.jpg (0.75 KB)
  image.jpg (0.87 KB)
  image.jpg (8.67 KB)
  postbox-contact.jpg (1.18 KB)
  image.jpg (9.88 KB)


mauch at kit

May 24, 2012, 2:46 AM

Post #5 of 9 (380 views)
Permalink
Re: devstack multi-node tutorial fails [In reply to]

Hmmmm, who would be the responsible person to make corrections and insert
some more comments to the current multi node tutorial of devstack??



Cheers Viktor



From: Razique Mahroua [mailto:razique.mahroua [at] gmail]
Sent: Thursday, May 24, 2012 10:18 AM
To: Mauch, Viktor (SCC)
Cc: openstack [at] lists
Subject: Re: [Openstack] devstack multi-node tutorial fails



Hey,
no you don't need to, the only case where the SSH exchange is mandatory is
for the [live|classi] migration

Raz





<mailto:mauch [at] kit> Mauch, Viktor (SCC)

23 mai 2012 16:31

Another thing:



Is it really necessary to implement password-less ssh login via
.ssh/authorized_keys?



For me it works without it.



Viktor



From: Razique Mahroua [mailto:razique.mahroua [at] gmail]
Sent: Wednesday, May 23, 2012 4:28 PM
To: Mauch, Viktor (SCC)
Cc: openstack [at] lists
Subject: Re: [Openstack] devstack multi-node tutorial fails



Thanks for the feedback
as for the multi_node mode, no it supposes you spawn a nova-network
component on every compute node
Razique








<mailto:mauch [at] kit> Mauch, Viktor (SCC)

23 mai 2012 16:00

Hi,



I just want so say, that some days ago the stack.sh script hast been changed
concerning the rabbit server installation.

The current description for multi node tutorial
(http://devstack.org/guides/multinode-lab.html) will fail.



At the moment it is necessary to install the rabbit service on the compute
hosts TOO (but of course with the IP from the master node)!!

e.g.:



ENABLED_SERVICES=n-cpu,n-net,g-api,rabbit

RABBIT_HOST=$MASTERNODE

RABBIT_PASSWORD=pass





Otherwise the compute node tries to find a rabbit-mq server on localhost!



There are also some other wrong details in the multi-node toturial.



It must be:



RABBIT_PASSWORD and MYSQL_PASSWORD instead of MYSQL_PASS und RABBIT_PASS



Und the parameter MULTI_HOST=1 has to be change to MULTI_HOST=True (and
should only be available on the master node, as I understand it right).





Cheers Viktor



--

Dipl.-Phys. Viktor Mauch



Steinbuch Centre for Computing (SCC)

http://www.scc.kit.edu/



Karlsruhe Institute of Technology (KIT)

Hermann-von-Helmholtz-Platz 1

D-76344 Eggenstein-Leopoldshafen



Phone: +49(0)721 608-28721

eMail: mauch [at] kit



KIT - University of the State of Baden-Wuerttemberg and National Research
Center of the Helmholtz Association



_______________________________________________
Mailing list: https://launchpad.net/~openstack
<https://launchpad.net/%7Eopenstack>
Post to : openstack [at] lists
Unsubscribe : https://launchpad.net/~openstack
<https://launchpad.net/%7Eopenstack>
More help : https://help.launchpad.net/ListHelp



--
Nuage & Co - Razique Mahroua
razique.mahroua [at] gmail







<mailto:razique.mahroua [at] gmail> Razique Mahroua

23 mai 2012 16:27

Thanks for the feedback
as for the multi_node mode, no it supposes you spawn a nova-network
component on every compute node
Razique






--
Nuage & Co - Razique Mahroua
razique.mahroua [at] gmail
Attachments: image001.jpg (0.75 KB)
  image002.jpg (0.87 KB)
  image003.jpg (8.67 KB)
  image004.jpg (1.18 KB)
  image005.jpg (9.88 KB)
  smime.p7s (5.84 KB)


razique.mahroua at gmail

May 24, 2012, 2:48 AM

Post #6 of 9 (409 views)
Permalink
Re: devstack multi-node tutorial fails [In reply to]

Hey Viktor, coud you send me the link ?
If it's within the official doc, we'll have a look, otherwise, I guess
you could contact the team directly :-)


> Mauch, Viktor (SCC) <mailto:mauch [at] kit>
> 24 mai 2012 11:46
>
> Hmmmm, who would be the responsible person to make corrections and
> insert some more comments to the current multi node tutorial of devstack??
>
> Cheers Viktor
>
> *From:*Razique Mahroua [mailto:razique.mahroua [at] gmail]
> *Sent:* Thursday, May 24, 2012 10:18 AM
> *To:* Mauch, Viktor (SCC)
> *Cc:* openstack [at] lists
> *Subject:* Re: [Openstack] devstack multi-node tutorial fails
>
> Hey,
> no you don't need to, the only case where the SSH exchange is
> mandatory is for the [live|classi] migration
>
> Raz
>
> *Mauch, Viktor (SCC)* <mailto:mauch [at] kit>
>
> 23 mai 2012 16:31
>
> Another thing:
>
> Is it really necessary to implement password-less ssh login via
> .ssh/authorized_keys?
>
> For me it works without it.
>
> Viktor
>
> *From:*Razique Mahroua [mailto:razique.mahroua [at] gmail]
> *Sent:* Wednesday, May 23, 2012 4:28 PM
> *To:* Mauch, Viktor (SCC)
> *Cc:* openstack [at] lists <mailto:openstack [at] lists>
> *Subject:* Re: [Openstack] devstack multi-node tutorial fails
>
> Thanks for the feedback
> as for the multi_node mode, no it supposes you spawn a nova-network
> component on every compute node
> Razique
>
>
>
>
> *Mauch, Viktor (SCC)* <mailto:mauch [at] kit>
>
> 23 mai 2012 16:00
>
> Hi,
>
> I just want so say, that some days ago the stack.sh script hast been
> changed concerning the rabbit server installation.
>
> The current description for multi node tutorial
> (http://devstack.org/guides/multinode-lab.html) will fail.
>
> At the moment it is necessary to install the rabbit service on the
> compute hosts TOO (but of course with the IP from the master node)!!
>
> e.g.:
>
> ENABLED_SERVICES=n-cpu,n-net,g-api,rabbit
>
> RABBIT_HOST=$MASTERNODE
>
> RABBIT_PASSWORD=pass
>
> Otherwise the compute node tries to find a rabbit-mq server on localhost!
>
> There are also some other wrong details in the multi-node toturial.
>
> It must be:
>
> RABBIT_PASSWORD and MYSQL_PASSWORD instead of MYSQL_PASS und RABBIT_PASS
>
> Und the parameter MULTI_HOST=1 has to be change to MULTI_HOST=True
> (and should only be available on the master node, as I understand it
> right).
>
> Cheers Viktor
>
> --
>
> Dipl.-Phys. Viktor Mauch
>
> Steinbuch Centre for Computing (SCC)
>
> http://www.scc.kit.edu/
>
> Karlsruhe Institute of Technology (KIT)
>
> Hermann-von-Helmholtz-Platz 1
>
> D-76344 Eggenstein-Leopoldshafen
>
> Phone: +49(0)721 608-28721
>
> eMail: mauch [at] kit <mailto:mauch [at] kit>
>
> KIT -- University of the State of Baden-Wuerttemberg and National
> Research Center of the Helmholtz Association
>
> _______________________________________________
> Mailing list: https://launchpad.net/~openstack
> <https://launchpad.net/%7Eopenstack>
> Post to : openstack [at] lists
> <mailto:openstack [at] lists>
> Unsubscribe : https://launchpad.net/~openstack
> <https://launchpad.net/%7Eopenstack>
> More help : https://help.launchpad.net/ListHelp
>
> --
> Nuage & Co - Razique Mahroua
> *razique.mahroua [at] gmail <mailto:razique.mahroua [at] gmail>*
>
> *Razique Mahroua* <mailto:razique.mahroua [at] gmail>
>
> 23 mai 2012 16:27
>
> Thanks for the feedback
> as for the multi_node mode, no it supposes you spawn a nova-network
> component on every compute node
> Razique
>
>
> --
> Nuage & Co - Razique Mahroua
> *razique.mahroua [at] gmail <mailto:razique.mahroua [at] gmail>*
>
> Razique Mahroua <mailto:razique.mahroua [at] gmail>
> 24 mai 2012 10:18
> Hey,
> no you don't need to, the only case where the SSH exchange is
> mandatory is for the [live|classi] migration
>
> Raz
>
> Mauch, Viktor (SCC) <mailto:mauch [at] kit>
> 23 mai 2012 16:31
>
> Another thing:
>
> Is it really necessary to implement password-less ssh login via
> .ssh/authorized_keys?
>
> For me it works without it.
>
> Viktor
>
> *From:*Razique Mahroua [mailto:razique.mahroua [at] gmail]
> *Sent:* Wednesday, May 23, 2012 4:28 PM
> *To:* Mauch, Viktor (SCC)
> *Cc:* openstack [at] lists
> *Subject:* Re: [Openstack] devstack multi-node tutorial fails
>
> Thanks for the feedback
> as for the multi_node mode, no it supposes you spawn a nova-network
> component on every compute node
> Razique
>
>
>
> *Mauch, Viktor (SCC)* <mailto:mauch [at] kit>
>
> 23 mai 2012 16:00
>
> Hi,
>
> I just want so say, that some days ago the stack.sh script hast been
> changed concerning the rabbit server installation.
>
> The current description for multi node tutorial
> (http://devstack.org/guides/multinode-lab.html) will fail.
>
> At the moment it is necessary to install the rabbit service on the
> compute hosts TOO (but of course with the IP from the master node)!!
>
> e.g.:
>
> ENABLED_SERVICES=n-cpu,n-net,g-api,rabbit
>
> RABBIT_HOST=$MASTERNODE
>
> RABBIT_PASSWORD=pass
>
> Otherwise the compute node tries to find a rabbit-mq server on localhost!
>
> There are also some other wrong details in the multi-node toturial.
>
> It must be:
>
> RABBIT_PASSWORD and MYSQL_PASSWORD instead of MYSQL_PASS und RABBIT_PASS
>
> Und the parameter MULTI_HOST=1 has to be change to MULTI_HOST=True
> (and should only be available on the master node, as I understand it
> right).
>
> Cheers Viktor
>
> --
>
> Dipl.-Phys. Viktor Mauch
>
> Steinbuch Centre for Computing (SCC)
>
> http://www.scc.kit.edu/
>
> Karlsruhe Institute of Technology (KIT)
>
> Hermann-von-Helmholtz-Platz 1
>
> D-76344 Eggenstein-Leopoldshafen
>
> Phone: +49(0)721 608-28721
>
> eMail: mauch [at] kit <mailto:mauch [at] kit>
>
> KIT -- University of the State of Baden-Wuerttemberg and National
> Research Center of the Helmholtz Association
>
> _______________________________________________
> Mailing list: https://launchpad.net/~openstack
> <https://launchpad.net/%7Eopenstack>
> Post to : openstack [at] lists
> <mailto:openstack [at] lists>
> Unsubscribe : https://launchpad.net/~openstack
> <https://launchpad.net/%7Eopenstack>
> More help : https://help.launchpad.net/ListHelp
>
> --
> Nuage & Co - Razique Mahroua
> *razique.mahroua [at] gmail <mailto:razique.mahroua [at] gmail>*
>
> Razique Mahroua <mailto:razique.mahroua [at] gmail>
> 23 mai 2012 16:27
> Thanks for the feedback
> as for the multi_node mode, no it supposes you spawn a nova-network
> component on every compute node
> Razique
>
>
>

--
Nuage & Co - Razique Mahroua
razique.mahroua [at] gmail
Attachments: compose-unknown-contact.jpg (0.75 KB)
  image.jpg (0.87 KB)
  image.jpg (0.87 KB)
  image.jpg (8.66 KB)
  image.jpg (1.17 KB)
  image.jpg (8.67 KB)
  postbox-contact.jpg (1.18 KB)
  image.jpg (9.88 KB)


mauch at kit

May 24, 2012, 2:53 AM

Post #7 of 9 (383 views)
Permalink
Re: devstack multi-node tutorial fails [In reply to]

This is the Link:



http://devstack.org/guides/multinode-lab.html



The corrections would be:

it is at the moment necessary to install the "rabbit" service also on the
compute nodes (of course with the IP from the head node)



MYSQL_PASS -> MYSQL_PASSWORD

RABBIT_PASS -> RABBIT_PASSWORD

MULTI_HOST=1 -> MULTI_HOST=True (one I think only in the localrc config file
of the head node)



Some more comments concerning the ssh access (because of live migration)



Cheers vic



From: Razique Mahroua [mailto:razique.mahroua [at] gmail]
Sent: Thursday, May 24, 2012 11:49 AM
To: Mauch, Viktor (SCC)
Cc: openstack [at] lists
Subject: Re: [Openstack] devstack multi-node tutorial fails



Hey Viktor, coud you send me the link ?
If it's within the official doc, we'll have a look, otherwise, I guess you
could contact the team directly :-)







<mailto:mauch [at] kit> Mauch, Viktor (SCC)

24 mai 2012 11:46

Hmmmm, who would be the responsible person to make corrections and insert
some more comments to the current multi node tutorial of devstack??



Cheers Viktor



From: Razique Mahroua [mailto:razique.mahroua [at] gmail]
Sent: Thursday, May 24, 2012 10:18 AM
To: Mauch, Viktor (SCC)
Cc: openstack [at] lists
Subject: Re: [Openstack] devstack multi-node tutorial fails



Hey,
no you don't need to, the only case where the SSH exchange is mandatory is
for the [live|classi] migration

Raz






<mailto:mauch [at] kit> Mauch, Viktor (SCC)

23 mai 2012 16:31

Another thing:



Is it really necessary to implement password-less ssh login via
.ssh/authorized_keys?



For me it works without it.



Viktor



From: Razique Mahroua [mailto:razique.mahroua [at] gmail]
Sent: Wednesday, May 23, 2012 4:28 PM
To: Mauch, Viktor (SCC)
Cc: openstack [at] lists
Subject: Re: [Openstack] devstack multi-node tutorial fails



Thanks for the feedback
as for the multi_node mode, no it supposes you spawn a nova-network
component on every compute node
Razique









<mailto:mauch [at] kit> Mauch, Viktor (SCC)

23 mai 2012 16:00

Hi,



I just want so say, that some days ago the stack.sh script hast been changed
concerning the rabbit server installation.

The current description for multi node tutorial
(http://devstack.org/guides/multinode-lab.html) will fail.



At the moment it is necessary to install the rabbit service on the compute
hosts TOO (but of course with the IP from the master node)!!

e.g.:



ENABLED_SERVICES=n-cpu,n-net,g-api,rabbit

RABBIT_HOST=$MASTERNODE

RABBIT_PASSWORD=pass





Otherwise the compute node tries to find a rabbit-mq server on localhost!



There are also some other wrong details in the multi-node toturial.



It must be:



RABBIT_PASSWORD and MYSQL_PASSWORD instead of MYSQL_PASS und RABBIT_PASS



Und the parameter MULTI_HOST=1 has to be change to MULTI_HOST=True (and
should only be available on the master node, as I understand it right).





Cheers Viktor



--

Dipl.-Phys. Viktor Mauch



Steinbuch Centre for Computing (SCC)

http://www.scc.kit.edu/



Karlsruhe Institute of Technology (KIT)

Hermann-von-Helmholtz-Platz 1

D-76344 Eggenstein-Leopoldshafen



Phone: +49(0)721 608-28721

eMail: mauch [at] kit



KIT - University of the State of Baden-Wuerttemberg and National Research
Center of the Helmholtz Association



_______________________________________________
Mailing list: https://launchpad.net/~openstack
<https://launchpad.net/%7Eopenstack>
Post to : openstack [at] lists
Unsubscribe : https://launchpad.net/~openstack
<https://launchpad.net/%7Eopenstack>
More help : https://help.launchpad.net/ListHelp



--
Nuage & Co - Razique Mahroua
razique.mahroua [at] gmail







<mailto:razique.mahroua [at] gmail> Razique Mahroua

23 mai 2012 16:27

Thanks for the feedback
as for the multi_node mode, no it supposes you spawn a nova-network
component on every compute node
Razique







--
Nuage & Co - Razique Mahroua
razique.mahroua [at] gmail







<mailto:razique.mahroua [at] gmail> Razique Mahroua

24 mai 2012 10:18

Hey,
no you don't need to, the only case where the SSH exchange is mandatory is
for the [live|classi] migration

Raz



<mailto:mauch [at] kit> Mauch, Viktor (SCC)

23 mai 2012 16:31

Another thing:



Is it really necessary to implement password-less ssh login via
.ssh/authorized_keys?



For me it works without it.



Viktor



From: Razique Mahroua [mailto:razique.mahroua [at] gmail]
Sent: Wednesday, May 23, 2012 4:28 PM
To: Mauch, Viktor (SCC)
Cc: openstack [at] lists
Subject: Re: [Openstack] devstack multi-node tutorial fails



Thanks for the feedback
as for the multi_node mode, no it supposes you spawn a nova-network
component on every compute node
Razique








<mailto:mauch [at] kit> Mauch, Viktor (SCC)

23 mai 2012 16:00

Hi,



I just want so say, that some days ago the stack.sh script hast been changed
concerning the rabbit server installation.

The current description for multi node tutorial
(http://devstack.org/guides/multinode-lab.html) will fail.



At the moment it is necessary to install the rabbit service on the compute
hosts TOO (but of course with the IP from the master node)!!

e.g.:



ENABLED_SERVICES=n-cpu,n-net,g-api,rabbit

RABBIT_HOST=$MASTERNODE

RABBIT_PASSWORD=pass





Otherwise the compute node tries to find a rabbit-mq server on localhost!



There are also some other wrong details in the multi-node toturial.



It must be:



RABBIT_PASSWORD and MYSQL_PASSWORD instead of MYSQL_PASS und RABBIT_PASS



Und the parameter MULTI_HOST=1 has to be change to MULTI_HOST=True (and
should only be available on the master node, as I understand it right).





Cheers Viktor



--

Dipl.-Phys. Viktor Mauch



Steinbuch Centre for Computing (SCC)

http://www.scc.kit.edu/



Karlsruhe Institute of Technology (KIT)

Hermann-von-Helmholtz-Platz 1

D-76344 Eggenstein-Leopoldshafen



Phone: +49(0)721 608-28721

eMail: mauch [at] kit



KIT - University of the State of Baden-Wuerttemberg and National Research
Center of the Helmholtz Association



_______________________________________________
Mailing list: https://launchpad.net/~openstack
<https://launchpad.net/%7Eopenstack>
Post to : openstack [at] lists
Unsubscribe : https://launchpad.net/~openstack
<https://launchpad.net/%7Eopenstack>
More help : https://help.launchpad.net/ListHelp



--
Nuage & Co - Razique Mahroua
razique.mahroua [at] gmail







<mailto:razique.mahroua [at] gmail> Razique Mahroua

23 mai 2012 16:27

Thanks for the feedback
as for the multi_node mode, no it supposes you spawn a nova-network
component on every compute node
Razique






--
Nuage & Co - Razique Mahroua
razique.mahroua [at] gmail
Attachments: image001.jpg (0.75 KB)
  image002.jpg (0.87 KB)
  image003.jpg (0.87 KB)
  image004.jpg (8.66 KB)
  image005.jpg (1.17 KB)
  image006.jpg (8.67 KB)
  image007.jpg (1.18 KB)
  image008.jpg (9.88 KB)
  smime.p7s (5.84 KB)


dtroyer at gmail

May 24, 2012, 7:24 AM

Post #8 of 9 (392 views)
Permalink
Re: devstack multi-node tutorial fails [In reply to]

On Thu, May 24, 2012 at 4:46 AM, Mauch, Viktor (SCC) <mauch [at] kit> wrote:

> Hmmmm, who would be the responsible person to make corrections and insert
> some more comments to the current multi node tutorial of devstack??
>

The devstack.org site is built from the gh-pages branch of devstack at
https://github.com/cloudbuilders/devstack/tree/gh-pages. Clone that, make
your changes and send a pull request. Let us know you've done that, it's
the only time that we use pull requests in that repo.

dt

--

Dean Troyer
dtroyer [at] gmail


John.Garbutt at citrix

May 24, 2012, 10:02 AM

Post #9 of 9 (394 views)
Permalink
Re: devstack multi-node tutorial fails [In reply to]

I have been having issues with multi-node too.

I have just pushed this, to fix the issues with setting RABBIT_HOST:
https://review.openstack.org/#/c/7757/

Cheers,
John

From: openstack-bounces+john.garbutt=eu.citrix.com [at] lists [mailto:openstack-bounces+john.garbutt=eu.citrix.com [at] lists] On Behalf Of Mauch, Viktor (SCC)
Sent: 24 May 2012 10:53
To: Razique Mahroua
Cc: openstack [at] lists
Subject: Re: [Openstack] devstack multi-node tutorial fails

This is the Link:

http://devstack.org/guides/multinode-lab.html

The corrections would be:
it is at the moment necessary to install the "rabbit" service also on the compute nodes (of course with the IP from the head node)

MYSQL_PASS -> MYSQL_PASSWORD
RABBIT_PASS -> RABBIT_PASSWORD
MULTI_HOST=1 -> MULTI_HOST=True (one I think only in the localrc config file of the head node)

Some more comments concerning the ssh access (because of live migration)

Cheers vic

From: Razique Mahroua [mailto:razique.mahroua [at] gmail]
Sent: Thursday, May 24, 2012 11:49 AM
To: Mauch, Viktor (SCC)
Cc: openstack [at] lists
Subject: Re: [Openstack] devstack multi-node tutorial fails

Hey Viktor, coud you send me the link ?
If it's within the official doc, we'll have a look, otherwise, I guess you could contact the team directly :-)


[cid:image001.jpg [at] 01CD39D7]
Mauch, Viktor (SCC)<mailto:mauch [at] kit>
24 mai 2012 11:46
Hmmmm, who would be the responsible person to make corrections and insert some more comments to the current multi node tutorial of devstack??

Cheers Viktor

From: Razique Mahroua [mailto:razique.mahroua [at] gmail]
Sent: Thursday, May 24, 2012 10:18 AM
To: Mauch, Viktor (SCC)
Cc: openstack [at] lists<mailto:openstack [at] lists>
Subject: Re: [Openstack] devstack multi-node tutorial fails

Hey,
no you don't need to, the only case where the SSH exchange is mandatory is for the [live|classi] migration

Raz

[cid:image002.jpg [at] 01CD39D7]
Mauch, Viktor (SCC)<mailto:mauch [at] kit>
23 mai 2012 16:31
Another thing:

Is it really necessary to implement password-less ssh login via .ssh/authorized_keys?

For me it works without it.

Viktor

From: Razique Mahroua [mailto:razique.mahroua [at] gmail]
Sent: Wednesday, May 23, 2012 4:28 PM
To: Mauch, Viktor (SCC)
Cc: openstack [at] lists<mailto:openstack [at] lists>
Subject: Re: [Openstack] devstack multi-node tutorial fails

Thanks for the feedback
as for the multi_node mode, no it supposes you spawn a nova-network component on every compute node
Razique




[cid:image003.jpg [at] 01CD39D7]
Mauch, Viktor (SCC)<mailto:mauch [at] kit>
23 mai 2012 16:00
Hi,

I just want so say, that some days ago the stack.sh script hast been changed concerning the rabbit server installation.
The current description for multi node tutorial (http://devstack.org/guides/multinode-lab.html) will fail.

At the moment it is necessary to install the rabbit service on the compute hosts TOO (but of course with the IP from the master node)!!
e.g.:

ENABLED_SERVICES=n-cpu,n-net,g-api,rabbit
RABBIT_HOST=$MASTERNODE
RABBIT_PASSWORD=pass


Otherwise the compute node tries to find a rabbit-mq server on localhost!

There are also some other wrong details in the multi-node toturial.

It must be:

RABBIT_PASSWORD and MYSQL_PASSWORD instead of MYSQL_PASS und RABBIT_PASS

Und the parameter MULTI_HOST=1 has to be change to MULTI_HOST=True (and should only be available on the master node, as I understand it right).


Cheers Viktor

--
Dipl.-Phys. Viktor Mauch

Steinbuch Centre for Computing (SCC)
http://www.scc.kit.edu/

Karlsruhe Institute of Technology (KIT)
Hermann-von-Helmholtz-Platz 1
D-76344 Eggenstein-Leopoldshafen

Phone: +49(0)721 608-28721
eMail: mauch [at] kit<mailto:mauch [at] kit>

KIT - University of the State of Baden-Wuerttemberg and National Research Center of the Helmholtz Association

_______________________________________________
Mailing list: https://launchpad.net/~openstack<https://launchpad.net/%7Eopenstack>
Post to : openstack [at] lists<mailto:openstack [at] lists>
Unsubscribe : https://launchpad.net/~openstack<https://launchpad.net/%7Eopenstack>
More help : https://help.launchpad.net/ListHelp

--
Nuage & Co - Razique Mahroua
razique.mahroua [at] gmail<mailto:razique.mahroua [at] gmail>
[cid:image004.jpg [at] 01CD39D7]

[cid:image005.jpg [at] 01CD39D7]
Razique Mahroua<mailto:razique.mahroua [at] gmail>
23 mai 2012 16:27
Thanks for the feedback
as for the multi_node mode, no it supposes you spawn a nova-network component on every compute node
Razique



--
Nuage & Co - Razique Mahroua
razique.mahroua [at] gmail<mailto:razique.mahroua [at] gmail>
[cid:image006.jpg [at] 01CD39D7]

[cid:image007.jpg [at] 01CD39D7]
Razique Mahroua<mailto:razique.mahroua [at] gmail>
24 mai 2012 10:18
Hey,
no you don't need to, the only case where the SSH exchange is mandatory is for the [live|classi] migration

Raz
[cid:image001.jpg [at] 01CD39D7]
Mauch, Viktor (SCC)<mailto:mauch [at] kit>
23 mai 2012 16:31
Another thing:

Is it really necessary to implement password-less ssh login via .ssh/authorized_keys?

For me it works without it.

Viktor

From: Razique Mahroua [mailto:razique.mahroua [at] gmail]
Sent: Wednesday, May 23, 2012 4:28 PM
To: Mauch, Viktor (SCC)
Cc: openstack [at] lists<mailto:openstack [at] lists>
Subject: Re: [Openstack] devstack multi-node tutorial fails

Thanks for the feedback
as for the multi_node mode, no it supposes you spawn a nova-network component on every compute node
Razique



[cid:image002.jpg [at] 01CD39D7]
Mauch, Viktor (SCC)<mailto:mauch [at] kit>
23 mai 2012 16:00
Hi,

I just want so say, that some days ago the stack.sh script hast been changed concerning the rabbit server installation.
The current description for multi node tutorial (http://devstack.org/guides/multinode-lab.html) will fail.

At the moment it is necessary to install the rabbit service on the compute hosts TOO (but of course with the IP from the master node)!!
e.g.:

ENABLED_SERVICES=n-cpu,n-net,g-api,rabbit
RABBIT_HOST=$MASTERNODE
RABBIT_PASSWORD=pass


Otherwise the compute node tries to find a rabbit-mq server on localhost!

There are also some other wrong details in the multi-node toturial.

It must be:

RABBIT_PASSWORD and MYSQL_PASSWORD instead of MYSQL_PASS und RABBIT_PASS

Und the parameter MULTI_HOST=1 has to be change to MULTI_HOST=True (and should only be available on the master node, as I understand it right).


Cheers Viktor

--
Dipl.-Phys. Viktor Mauch

Steinbuch Centre for Computing (SCC)
http://www.scc.kit.edu/

Karlsruhe Institute of Technology (KIT)
Hermann-von-Helmholtz-Platz 1
D-76344 Eggenstein-Leopoldshafen

Phone: +49(0)721 608-28721
eMail: mauch [at] kit<mailto:mauch [at] kit>

KIT - University of the State of Baden-Wuerttemberg and National Research Center of the Helmholtz Association

_______________________________________________
Mailing list: https://launchpad.net/~openstack<https://launchpad.net/%7Eopenstack>
Post to : openstack [at] lists<mailto:openstack [at] lists>
Unsubscribe : https://launchpad.net/~openstack<https://launchpad.net/%7Eopenstack>
More help : https://help.launchpad.net/ListHelp

--
Nuage & Co - Razique Mahroua
razique.mahroua [at] gmail<mailto:razique.mahroua [at] gmail>
[cid:image006.jpg [at] 01CD39D7]

[cid:image007.jpg [at] 01CD39D7]
Razique Mahroua<mailto:razique.mahroua [at] gmail>
23 mai 2012 16:27
Thanks for the feedback
as for the multi_node mode, no it supposes you spawn a nova-network component on every compute node
Razique


--
Nuage & Co - Razique Mahroua
razique.mahroua [at] gmail<mailto:razique.mahroua [at] gmail>
[cid:image008.jpg [at] 01CD39D7]
Attachments: image001.jpg (0.75 KB)
  image002.jpg (0.87 KB)
  image003.jpg (0.87 KB)
  image004.jpg (8.66 KB)
  image005.jpg (1.17 KB)
  image006.jpg (8.67 KB)
  image007.jpg (1.18 KB)
  image008.jpg (9.88 KB)

OpenStack dev RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.