Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: nsp: juniper

DSCP classifier doesn't work

 

 

nsp juniper RSS feed   Index | Next | Previous | View Threaded


jvilla+juniper at correo

Oct 10, 2002, 6:13 AM

Post #1 of 4 (731 views)
Permalink
DSCP classifier doesn't work

Hi,

Iīm trying to configure IP premium services (EF) and the problem is that the
classifier applied to the input interface don't queue the packets to the
apropiate forwarding-class.

This can be achieved through filters and then forwarding to the
corresponding forwarding-class

filter expedited {
term expedited {
from {
dscp ef;
}
then {
forwarding-class expedited-forwarding;
accept;
}
}
}

However through class-of-service classifiers didn't work.
Here is the M10 config

Any idea?. Thanks in advance

--- JUNOS 5.5R1.2 built 2002-09-28 01:43:28 UTC

jvilla [at] SAN-JUN-0> show chassis hardware
Hardware inventory:
Item Version Part number Serial number Description
Chassis 60560 M10
Midplane REV 03 710-001950 HG4489
Power Supply A Rev 04 740-002497 MB11788 AC
Power Supply B Rev 04 740-002497 MA21363 AC
Display REV 04 710-001995 HG7286
Routing Engine REV 05 740-003877 1000340864 RE-2.0
FEB REV 06 710-003310 HG4149 E-FEB
FPC 0
PIC 0 REV 03 750-002977 HD9439 2x OC-3 ATM, MM
PIC 1 REV 01 750-002982 HB1135 1x Tunnel
PIC 2 REV 01 750-005091 HE8064 1x G/E, 1000
BASE-SX
PIC 3 REV 01 750-005091 HA3150 1x G/E, 1000
BASE-SX
FPC 1
PIC 0 REV 01 750-005091 AG6308 1x G/E, 1000
BASE-SX


jvilla [at] SAN-JUN-0# show class-of-service
classifiers {
dscp EF-BE {
import default;
forwarding-class best-effort {
loss-priority low code-points [ af11 af12 af13 ];
}
}
}
forwarding-classes {
queue 0 best-effort;
queue 1 expedited-forwarding;
queue 3 network-control;
}
interfaces {
ae0 {
scheduler-map EF-BE;
unit * {
classifiers {
dscp EF-BE;
}
rewrite-rules {
dscp EF-BE;
}
}
}
ge-0/3/0 {
scheduler-map EF-BE;
unit * {
classifiers {
dscp EF-BE;
}
rewrite-rules {
dscp EF-BE;
}
}
}
ge-1/0/0 {
scheduler-map EF-BE;
unit 0 {
classifiers {
dscp EF-BE;
}
rewrite-rules {
dscp EF-BE;
}
}
}
}
rewrite-rules {
dscp EF-BE {
import default;
forwarding-class best-effort {
loss-priority low code-point be;
loss-priority high code-point be;
}
forwarding-class expedited-forwarding {
loss-priority low code-point ef;
loss-priority high code-point ef;
}
}
}
scheduler-maps {
EF-BE {
forwarding-class best-effort scheduler SCH-BEST-EFFORT;
forwarding-class expedited-forwarding scheduler
SCH-EXPEDITED-FORWARDING;
forwarding-class network-control scheduler SCH-NETWORK-CONTROL;
}
}
schedulers {
SCH-NETWORK-CONTROL {
transmit-rate percent 5;
buffer-size percent 5;
}
SCH-EXPEDITED-FORWARDING {
transmit-rate percent 10;
buffer-size percent 10;
}
SCH-BEST-EFFORT {
transmit-rate percent 85;
buffer-size percent 85;
}
}

[edit]
jvilla [at] SAN-JUN-0# show interfaces
ge-0/2/0 {
gigether-options {
802.3ad ae0;
}
}
ge-0/3/0 {
gigether-options {
802.3ad ae0;
}
}
ge-1/0/0 {
unit 0 {
family inet {
address 10.10.10.1/30;
}
}
}
ae0 {
vlan-tagging;
unit 0 {
vlan-id 1;
family inet {
address 192.168.100.1/24;
}
}
unit 1 {
vlan-id 2;
family inet {
address 192.168.200.1/24;
}
}
unit 2 {
vlan-id 3;
family inet {
address 192.168.201.1/24;
}
}
}


jvilla [at] SAN-JUN-0> show class-of-service interface ae0
Physical interface: ae0, Index: 12
Scheduler map: EF-BE, Index: 47222

Logical interface: ae0.0, Index: 5
Object Name Type Index
Rewrite EF-BE dscp 47964
Rewrite exp-default exp 2
Classifier EF-BE dscp 47964

Logical interface: ae0.1, Index: 6
Object Name Type Index
Rewrite EF-BE dscp 47964
Rewrite exp-default exp 2
Classifier EF-BE dscp 47964

Logical interface: ae0.2, Index: 7
Object Name Type Index
Rewrite EF-BE dscp 47964
Rewrite exp-default exp 2
Classifier EF-BE dscp 47964

jvilla [at] SAN-JUN-0> show class-of-service interface ge-1/0/0
Physical interface: ge-1/0/0, Index: 24
Scheduler map: EF-BE, Index: 47222

Logical interface: ge-1/0/0.0, Index: 24
Object Name Type Index
Rewrite EF-BE dscp 47964
Rewrite exp-default exp 2
Classifier EF-BE dscp 47964

jvilla [at] SAN-JUN-0> show class-of-service interface ge-0/3/0
Physical interface: ge-0/3/0, Index: 23
Scheduler map: EF-BE, Index: 47222

Logical interface: ge-0/3/0.0, Index: 20
Object Name Type Index
Rewrite EF-BE dscp 47964
Rewrite exp-default exp 2
Classifier EF-BE dscp 47964

Logical interface: ge-0/3/0.1, Index: 21
Object Name Type Index
Rewrite EF-BE dscp 47964
Rewrite exp-default exp 2
Classifier EF-BE dscp 47964

Logical interface: ge-0/3/0.2, Index: 22
Object Name Type Index
Rewrite EF-BE dscp 47964
Rewrite exp-default exp 2
Classifier EF-BE dscp 47964


capshaw at juniper

Oct 11, 2002, 6:18 AM

Post #2 of 4 (719 views)
Permalink
DSCP classifier doesn't work [In reply to]

Juan,

Lokks like you forgot to define a classifier for ef....

On Thu, 10 Oct 2002, Juan Villasuso wrote:

> Hi,
>
> I=B4m trying to configure IP premium services (EF) and the problem is tha=
t the
> classifier applied to the input interface don't queue the packets to the
> apropiate forwarding-class.
>
> This can be achieved through filters and then forwarding to the
> corresponding forwarding-class
>
> filter expedited {
> term expedited {
> from {
> dscp ef;
> }
> then {
> forwarding-class expedited-forwarding;
> accept;
> }
> }
> }
>
> However through class-of-service classifiers didn't work.
> Here is the M10 config
>
> Any idea?. Thanks in advance
>
> --- JUNOS 5.5R1.2 built 2002-09-28 01:43:28 UTC
>
> jvilla [at] SAN-JUN-0> show chassis hardware
> Hardware inventory:
> Item Version Part number Serial number Description
> Chassis 60560 M10
> Midplane REV 03 710-001950 HG4489
> Power Supply A Rev 04 740-002497 MB11788 AC
> Power Supply B Rev 04 740-002497 MA21363 AC
> Display REV 04 710-001995 HG7286
> Routing Engine REV 05 740-003877 1000340864 RE-2.0
> FEB REV 06 710-003310 HG4149 E-FEB
> FPC 0
> PIC 0 REV 03 750-002977 HD9439 2x OC-3 ATM, MM
> PIC 1 REV 01 750-002982 HB1135 1x Tunnel
> PIC 2 REV 01 750-005091 HE8064 1x G/E, 1000
> BASE-SX
> PIC 3 REV 01 750-005091 HA3150 1x G/E, 1000
> BASE-SX
> FPC 1
> PIC 0 REV 01 750-005091 AG6308 1x G/E, 1000
> BASE-SX
>
>
> jvilla [at] SAN-JUN-0# show class-of-service
> classifiers {
> dscp EF-BE {
> import default;
> forwarding-class best-effort {
> loss-priority low code-points [ af11 af12 af13 ];
> }
> }
> }
> forwarding-classes {
> queue 0 best-effort;
> queue 1 expedited-forwarding;
> queue 3 network-control;
> }
> interfaces {
> ae0 {
> scheduler-map EF-BE;
> unit * {
> classifiers {
> dscp EF-BE;
> }
> rewrite-rules {
> dscp EF-BE;
> }
> }
> }
> ge-0/3/0 {
> scheduler-map EF-BE;
> unit * {
> classifiers {
> dscp EF-BE;
> }
> rewrite-rules {
> dscp EF-BE;
> }
> }
> }
> ge-1/0/0 {
> scheduler-map EF-BE;
> unit 0 {
> classifiers {
> dscp EF-BE;
> }
> rewrite-rules {
> dscp EF-BE;
> }
> }
> }
> }
> rewrite-rules {
> dscp EF-BE {
> import default;
> forwarding-class best-effort {
> loss-priority low code-point be;
> loss-priority high code-point be;
> }
> forwarding-class expedited-forwarding {
> loss-priority low code-point ef;
> loss-priority high code-point ef;
> }
> }
> }
> scheduler-maps {
> EF-BE {
> forwarding-class best-effort scheduler SCH-BEST-EFFORT;
> forwarding-class expedited-forwarding scheduler
> SCH-EXPEDITED-FORWARDING;
> forwarding-class network-control scheduler SCH-NETWORK-CONTROL;
> }
> }
> schedulers {
> SCH-NETWORK-CONTROL {
> transmit-rate percent 5;
> buffer-size percent 5;
> }
> SCH-EXPEDITED-FORWARDING {
> transmit-rate percent 10;
> buffer-size percent 10;
> }
> SCH-BEST-EFFORT {
> transmit-rate percent 85;
> buffer-size percent 85;
> }
> }
>
> [edit]
> jvilla [at] SAN-JUN-0# show interfaces
> ge-0/2/0 {
> gigether-options {
> 802.3ad ae0;
> }
> }
> ge-0/3/0 {
> gigether-options {
> 802.3ad ae0;
> }
> }
> ge-1/0/0 {
> unit 0 {
> family inet {
> address 10.10.10.1/30;
> }
> }
> }
> ae0 {
> vlan-tagging;
> unit 0 {
> vlan-id 1;
> family inet {
> address 192.168.100.1/24;
> }
> }
> unit 1 {
> vlan-id 2;
> family inet {
> address 192.168.200.1/24;
> }
> }
> unit 2 {
> vlan-id 3;
> family inet {
> address 192.168.201.1/24;
> }
> }
> }
>
>
> jvilla [at] SAN-JUN-0> show class-of-service interface ae0
> Physical interface: ae0, Index: 12
> Scheduler map: EF-BE, Index: 47222
>
> Logical interface: ae0.0, Index: 5
> Object Name Type Inde=
x
> Rewrite EF-BE dscp 4796=
4
> Rewrite exp-default exp =
2
> Classifier EF-BE dscp 4796=
4
>
> Logical interface: ae0.1, Index: 6
> Object Name Type Inde=
x
> Rewrite EF-BE dscp 4796=
4
> Rewrite exp-default exp =
2
> Classifier EF-BE dscp 4796=
4
>
> Logical interface: ae0.2, Index: 7
> Object Name Type Inde=
x
> Rewrite EF-BE dscp 4796=
4
> Rewrite exp-default exp =
2
> Classifier EF-BE dscp 4796=
4
>
> jvilla [at] SAN-JUN-0> show class-of-service interface ge-1/0/0
> Physical interface: ge-1/0/0, Index: 24
> Scheduler map: EF-BE, Index: 47222
>
> Logical interface: ge-1/0/0.0, Index: 24
> Object Name Type Inde=
x
> Rewrite EF-BE dscp 4796=
4
> Rewrite exp-default exp =
2
> Classifier EF-BE dscp 4796=
4
>
> jvilla [at] SAN-JUN-0> show class-of-service interface ge-0/3/0
> Physical interface: ge-0/3/0, Index: 23
> Scheduler map: EF-BE, Index: 47222
>
> Logical interface: ge-0/3/0.0, Index: 20
> Object Name Type Inde=
x
> Rewrite EF-BE dscp 4796=
4
> Rewrite exp-default exp =
2
> Classifier EF-BE dscp 4796=
4
>
> Logical interface: ge-0/3/0.1, Index: 21
> Object Name Type Inde=
x
> Rewrite EF-BE dscp 4796=
4
> Rewrite exp-default exp =
2
> Classifier EF-BE dscp 4796=
4
>
> Logical interface: ge-0/3/0.2, Index: 22
> Object Name Type Inde=
x
> Rewrite EF-BE dscp 4796=
4
> Rewrite exp-default exp =
2
> Classifier EF-BE dscp 4796=
4
>
>
>
>
>
> _______________________________________________
> juniper-nsp mailing list juniper-nsp [at] puck
> http://puck.nether.net/mailman/listinfo/juniper-nsp
>


jvilla+juniper at correo

Oct 11, 2002, 8:23 AM

Post #3 of 4 (696 views)
Permalink
DSCP classifier doesn't work [In reply to]

I don't think it was necessary because I've imported the default dscp
classifier and then reclassifying only the af1x code-points to the
forwarding-class best-effort.

I've also tried to add the forwarding-class expedited-forwarding to the dscp
classifier EF-BE following your advice but don't work.

classifiers {
dscp EF-BE {
import default;
forwarding-class best-effort {
loss-priority low code-points [ af11 af12 af13 ];
}
forwarding-class expedited-forwarding {
loss-priority low code-points ef;
}
}
}

--- JUNOS 5.5R1.2 built 2002-09-28 01:43:28 UTC

jvilla [at] SAN-JUN-0> show class-of-service classifier name EF-BE
Classifier: EF-BE, Code point type: dscp, Index: 47964
Code point Forwarding class Loss priority
000000 best-effort low
000001 best-effort low
000010 best-effort low
000011 best-effort low
000100 best-effort low
000101 best-effort low
000110 best-effort low
000111 best-effort low
001000 best-effort low
001001 best-effort low
001010 best-effort low
001011 best-effort low
001100 best-effort low
001101 best-effort low
001110 best-effort low
001111 best-effort low
010000 best-effort low
010001 best-effort low
010010 best-effort low
010011 best-effort low
010100 best-effort low
010101 best-effort low
010110 best-effort low
010111 best-effort low
011000 best-effort low
011001 best-effort low
011010 best-effort low
011011 best-effort low
011100 best-effort low
011101 best-effort low
011110 best-effort low
011111 best-effort low
100000 best-effort low
100001 best-effort low
100010 best-effort low
100011 best-effort low
100100 best-effort low
100101 best-effort low
100110 best-effort low
100111 best-effort low
101000 best-effort low
101001 best-effort low
101010 best-effort low
101011 best-effort low
101100 best-effort low
101101 best-effort low
101110 expedited-forwarding low /*
DSCP ef (46). Same as default (tos 0xb8)
101111 best-effort low
110000 network-control low
110001 best-effort low
110010 best-effort low
110011 best-effort low
110100 best-effort low
110101 best-effort low
110110 best-effort low
110111 best-effort low
111000 network-control low
111001 best-effort low
111010 best-effort low
111011 best-effort low
111100 best-effort low
111101 best-effort low
111110 best-effort low
111111 best-effort low


Regards


akramsey at juniper

Oct 11, 2002, 8:58 AM

Post #4 of 4 (714 views)
Permalink
DSCP classifier doesn't work [In reply to]

Hi Juan.

Can you give us the input interface? Also, can you send a:

"show class-of-service interface"
"show class-of-service classifier"

Thanks,
Andy

>-----Original Message-----
>From: Juan Villasuso [mailto:jvilla+juniper [at] correo]
>Sent: Friday, October 11, 2002 12:24 PM
>To: Sean Capshaw
>Cc: juniper-nsp [at] puck
>Subject: RE: [j-nsp] DSCP classifier doesn't work
>
>
>I don't think it was necessary because I've imported the default dscp
>classifier and then reclassifying only the af1x code-points to the
>forwarding-class best-effort.
>
>I've also tried to add the forwarding-class=20
>expedited-forwarding to the dscp
>classifier EF-BE following your advice but don't work.
>
>classifiers {
> dscp EF-BE {
> import default;
> forwarding-class best-effort {
> loss-priority low code-points [ af11 af12 af13 ];
> }
> forwarding-class expedited-forwarding {
> loss-priority low code-points ef;
> }
> }
>}
>
>--- JUNOS 5.5R1.2 built 2002-09-28 01:43:28 UTC
>
>jvilla [at] SAN-JUN-0> show class-of-service classifier name EF-BE
>Classifier: EF-BE, Code point type: dscp, Index: 47964
> Code point Forwarding class Loss priority
> 000000 best-effort low
> 000001 best-effort low
> 000010 best-effort low
> 000011 best-effort low
> 000100 best-effort low
> 000101 best-effort low
> 000110 best-effort low
> 000111 best-effort low
> 001000 best-effort low
> 001001 best-effort low
> 001010 best-effort low
> 001011 best-effort low
> 001100 best-effort low
> 001101 best-effort low
> 001110 best-effort low
> 001111 best-effort low
> 010000 best-effort low
> 010001 best-effort low
> 010010 best-effort low
> 010011 best-effort low
> 010100 best-effort low
> 010101 best-effort low
> 010110 best-effort low
> 010111 best-effort low
> 011000 best-effort low
> 011001 best-effort low
> 011010 best-effort low
> 011011 best-effort low
> 011100 best-effort low
> 011101 best-effort low
> 011110 best-effort low
> 011111 best-effort low
> 100000 best-effort low
> 100001 best-effort low
> 100010 best-effort low
> 100011 best-effort low
> 100100 best-effort low
> 100101 best-effort low
> 100110 best-effort low
> 100111 best-effort low
> 101000 best-effort low
> 101001 best-effort low
> 101010 best-effort low
> 101011 best-effort low
> 101100 best-effort low
> 101101 best-effort low
> 101110 expedited-forwarding low /*
>DSCP ef (46). Same as default (tos 0xb8)
> 101111 best-effort low
> 110000 network-control low
> 110001 best-effort low
> 110010 best-effort low
> 110011 best-effort low
> 110100 best-effort low
> 110101 best-effort low
> 110110 best-effort low
> 110111 best-effort low
> 111000 network-control low
> 111001 best-effort low
> 111010 best-effort low
> 111011 best-effort low
> 111100 best-effort low
> 111101 best-effort low
> 111110 best-effort low
> 111111 best-effort low
>
>
>Regards
>
>
>
>
>
>
>_______________________________________________
>juniper-nsp mailing list juniper-nsp [at] puck
>http://puck.nether.net/mailman/listinfo/juniper-nsp
>

nsp juniper RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.