Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: nsp: ipv6

Small cisco boxes doing IPv6?

 

 

nsp ipv6 RSS feed   Index | Next | Previous | View Threaded


mch-v6ops at xs4all

Jan 10, 2012, 7:19 AM

Post #1 of 18 (4081 views)
Permalink
Small cisco boxes doing IPv6?

Hi Guys,

If somebody from Cisco reads this, feel free to contact me off list, but maybe somebody else has something running and can confirm this as well.

We are looking into buying some small routers for some internal training and testing. Primarily this will focus on IPv6, but we also want to cover more generic routing concepts (OSPF, BGP). We are really talking concepts here, having a couple of boxes that exchange a handful of routes, so performance is not that big of an issue. However to make the setup as versatile as possible, we do need the biggest feature set possible.

We are looking at a combination of a couple of 1921s and a 2921, which have hardware specs (port numbers) that match the setup we have in mind. However we got a bit swamped at which software version and licenses we need. The datasheets and feature navigator give most of the answers, but not all :(

In short. the features we want, besides basic IPv6 networking, are:

- OSPFv3
- IPv6 on IS-IS
- IPv6 on BGP (both route exchange and neighbors)
- IPv6 over IPv4 tunnelling (stateful/stateless)
- Support for IPv6 ACL would be nice but won't be a deal breaker

And for reference the IPv4 equivalents of the above, but we assume that backwards compatibility to v4 is less of an issue :) I consider multicast a bonus, but we can live without.

Is there anybody that has this feature set successfully running or tested on the systems mentioned (19xx/29xx) and more important, which version/license do you run.

Thanks,

MarcoH
(RIPE NCC)

PS: for flexibility, we probably will add the security license as well


mtinka at globaltransit

Jan 11, 2012, 12:55 AM

Post #2 of 18 (3979 views)
Permalink
Re: Small cisco boxes doing IPv6? [In reply to]

On Tuesday, January 10, 2012 11:19:21 PM Marco Hogewoning
wrote:

> Is there anybody that has this feature set successfully
> running or tested on the systems mentioned (19xx/29xx)
> and more important, which version/license do you run.

The new generation of Cisco ISR's all use a so-called
universal image, which requires a license to unlock specific
features per your requirements or budget.

This link should help (sorry, we aren't using this type of
code from Cisco yet):

http://www.cisco.com/en/US/prod/collateral/routers/ps10616/white_paper_c11_556985_ps10537_Products_White_Paper.html#wp9000768

Mark.
Attachments: signature.asc (0.82 KB)


mch-v6ops at xs4all

Jan 11, 2012, 1:30 AM

Post #3 of 18 (3977 views)
Permalink
Re: Small cisco boxes doing IPv6? [In reply to]

On Jan 11, 2012, at 9:55 AM, Mark Tinka wrote:

> On Tuesday, January 10, 2012 11:19:21 PM Marco Hogewoning
> wrote:
>
>> Is there anybody that has this feature set successfully
>> running or tested on the systems mentioned (19xx/29xx)
>> and more important, which version/license do you run.
>
> The new generation of Cisco ISR's all use a so-called
> universal image, which requires a license to unlock specific
> features per your requirements or budget.
>
> This link should help (sorry, we aren't using this type of
> code from Cisco yet):
>
> http://www.cisco.com/en/US/prod/collateral/routers/ps10616/white_paper_c11_556985_ps10537_Products_White_Paper.html#wp9000768

Yups, that's why I reached out to this list.

It would make sense to start with the newest version, unless somebody thinks we get better mileage on the old 12.x images because of bugs. That would probably mean combining DATA+IPBaseK9+SECK9 (budget permitting), but I would like to have it confirmed

Also the quotes we have now, look like they are still referring to the old license model.

BTW also got some offline replies from Cisco now, so I think we are on our way to sorting things out.

Marco


mtinka at globaltransit

Jan 11, 2012, 8:10 AM

Post #4 of 18 (3979 views)
Permalink
Re: Small cisco boxes doing IPv6? [In reply to]

On Wednesday, January 11, 2012 05:30:12 PM Marco Hogewoning
wrote:

> It would make sense to start with the newest version,
> unless somebody thinks we get better mileage on the old
> 12.x images because of bugs. That would probably mean
> combining DATA+IPBaseK9+SECK9 (budget permitting), but I
> would like to have it confirmed

From what I know, the newer breed of Cisco's ISR's only run
with IOS 15 as a minimum.

Only the earlier platforms support both IOS 12 and 15.

Mark.
Attachments: signature.asc (0.82 KB)


mch-v6ops at xs4all

Jan 16, 2012, 1:19 AM

Post #5 of 18 (3947 views)
Permalink
Re: Small cisco boxes doing IPv6? [In reply to]

On Jan 10, 2012, at 4:19 PM, Marco Hogewoning wrote:

<snip looking for advice on small boxes doing IPv6>

Hi all,

Received many responses both on and off list, thanks for that.

To summarise the responses, most people are fairly sure we can make it. Also got a lead now on somebody who can probably give us remote access to a 19xx box so we can verify certain things.

Marco


mch-v6ops at xs4all

Feb 13, 2012, 2:36 AM

Post #6 of 18 (3843 views)
Permalink
Re: Small cisco boxes doing IPv6? [In reply to]

Time for a quick update :)

Turned out it is very hard to get a random cisco reseller to confirm wether a specific feature is present or even a simple telling which software version is supposed to be shipped with the box. After a lengthy process finally found a company who at least told us they were willing to help out if the box didn't perform as expected. Unfortunately the rest of the sales people seem to be taking the fire and forget approach, nice if you are past the lab stage and know what you are after but doesn't help if you are trying to find out what to buy.

Can imagine that for a small shop wanting to deploy IPv6 this can be quite a steep hill to walk up. Mistakes are easily made and can seriously eat in your already tiny budget.

If it is of any help, we now have two models running 2921 and 1921 and both the systems were delivered on 15.1(4)M3, which is from december 2011, IPbase and K9 license on the box. I ran a couple of quick tests and confirmed IPv6 functionality on BGP, OSPF and IS-IS. These were no performance tests, but at least I verified the process starts and is capable of exchanging a static IPv6 route. Little disclaimer: this was the first time I ever touched IS-IS, your mileage may vary.

Also setup a quick IPv6 in IPv4 tunnel, during that phase I found some 6RD related commands but haven't came round to testing anything in that area.

Marco


merike at doubleshotsecurity

Feb 13, 2012, 12:16 PM

Post #7 of 18 (3864 views)
Permalink
Re: Small cisco boxes doing IPv6? [In reply to]

On Feb 13, 2012, at 2:36 AM, Marco Hogewoning wrote:

> Time for a quick update :)
>
> Turned out it is very hard to get a random cisco reseller to confirm wether a specific feature is present or even a simple telling which software version is supposed to be shipped with the box. After a lengthy process finally found a company who at least told us they were willing to help out if the box didn't perform as expected. Unfortunately the rest of the sales people seem to be taking the fire and forget approach, nice if you are past the lab stage and know what you are after but doesn't help if you are trying to find out what to buy.
>
> Can imagine that for a small shop wanting to deploy IPv6 this can be quite a steep hill to walk up. Mistakes are easily made and can seriously eat in your already tiny budget.
>
> If it is of any help, we now have two models running 2921 and 1921 and both the systems were delivered on 15.1(4)M3, which is from december 2011, IPbase and K9 license on the box. I ran a couple of quick tests and confirmed IPv6 functionality on BGP, OSPF and IS-IS. These were no performance tests, but at least I verified the process starts and is capable of exchanging a static IPv6 route. Little disclaimer: this was the first time I ever touched IS-IS, your mileage may vary.
>
> Also setup a quick IPv6 in IPv4 tunnel, during that phase I found some 6RD related commands but haven't came round to testing anything in that area.

OK, I see that the 1921 will replace the 1841 which I have at home. It's been running IPv6 fine for a few years :)

Cosmopolitan#sh ha
Cisco IOS Software, 1841 Software (C1841-ADVIPSERVICESK9-M), Version 12.4(6)T, RELEASE SOFTWARE (fc1)

I used to have a few tunnels to varying people but have had eBGP for v6 on it for almost 8 months or so to watch the routing table grow and have native connectivity.

Cosmopolitan#sh ipv6 ro
IPv6 Routing Table - 8076 entries

Granted I only have a /29 and some wireless home stuff for streaming music (probably 12 devices total) and video plus a /48 with all of 5 devices (for now) but the CPU is ridiculously underutilized. I log all ACL exceptions and suffice to say I'm fairly strict with my filtering...more to see the exceptions roll by and see who the heck is knocking uninvited on my door.

I'd upgrade to maybe try some new functionality but I don't think I have a support contract....go native and you'll be fine. The fundamentals have worked for quite a few years :)

- merike


kiwi at oav

Feb 14, 2012, 12:09 AM

Post #8 of 18 (3843 views)
Permalink
Re: Small cisco boxes doing IPv6? [In reply to]

Hi !

(...)

> OK, I see that the 1921 will replace the 1841 which I have at home. It's been running IPv6 fine for a few years :)
>
> Cosmopolitan#sh ha
> Cisco IOS Software, 1841 Software (C1841-ADVIPSERVICESK9-M), Version 12.4(6)T, RELEASE SOFTWARE (fc1)
>
> I used to have a few tunnels to varying people but have had eBGP for v6 on it for almost 8 months or so to watch the routing table grow and have native connectivity.


There is also small boxes that are a bit cool : me3400, they can do ipv6, but also ISIS / BGP / OSPF(v3) as well...

/Xavier


madams at netcologne

Feb 14, 2012, 2:53 AM

Post #9 of 18 (3848 views)
Permalink
Re: Small cisco boxes doing IPv6? [In reply to]

Am 13.02.2012 11:36, schrieb Marco Hogewoning:
> If it is of any help, we now have two models running 2921 and 1921 and both the systems were delivered on 15.1(4)M3, which is from december 2011, IPbase and K9 license on the box. I ran a couple of quick tests and confirmed IPv6 functionality on BGP, OSPF and IS-IS. These were no performance tests, but at least I verified the process starts and is capable of exchanging a static IPv6 route. Little disclaimer: this was the first time I ever touched IS-IS, your mileage may vary.

I did some performance tests on a 1921 with 15.1(2)T4 / security license and
experienced a serious degradation when using PPPoE uplinks.

v6
unidirectional IMIX UDP packets, G0/0 -> G0/1 : 100 Mbit/s @ 20 % CPU
unidirectional IMIX UDP packets, G0/0 -> G0/1 (PPPoE): 50 Mbit/s @ 72 % CPU

v4
unidirectional IMIX UDP packets, G0/0 -> G0/1 : 100 Mbit/s @ 14 % CPU
unidirectional IMIX UDP packets, G0/0 -> G0/1 (PPPoE): 100 Mbit/s @ 26 % CPU

For me it looks like the box has some problems with IPv6 together with PPP. It may also
be a configration issue. So here is a part of the config. The box was not doing NAT or
ipv6 inspect.

no ipv6 source-route
ipv6 unicast-routing
ipv6 cef
no ip source-route
ip cef
!
interface GigabitEthernet0/0
description traffic generator
ip address x.x.x.x 255.255.255.0
no ip redirects
load-interval 30
duplex auto
speed auto
ipv6 address 2001:db8::1/64
ipv6 enable
no ipv6 redirects
ipv6 verify unicast reverse-path
!
interface GigabitEthernet0/1
description Uplink
no ip address
load-interval 30
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1
no cdp enable
!
interface Dialer1
mtu 1492
ip address negotiated
encapsulation ppp
dialer pool 1
dialer-group 1
ipv6 address FE80::CE link-local
ipv6 address autoconfig
ipv6 enable
ppp authentication pap callin
ppp pap sent-username <its-me> password <its-really-me>
no cdp enable
!
ipv6 route ::/0 Dialer1
ip route 0.0.0.0 0.0.0.0 Dialer1


Hints welcome.

Michael


marc at sniff

Feb 14, 2012, 3:04 AM

Post #10 of 18 (3870 views)
Permalink
Re: Small cisco boxes doing IPv6? [In reply to]

Hello Michael,

> Hints welcome.

you have "ipv6 verify unicast reverse-path" configured but not the equivalent for IPv4. Now the reverse-path lookup doubles the CEF lookup which could in worst case double your CPU utilization.

Would be interesting to see how numbers for IPv4 look like with unicast reverse verification enabled.


Regards, Marc



On 2012-02-14, at 11:53 , Michael Adams wrote:

> Am 13.02.2012 11:36, schrieb Marco Hogewoning:
>> If it is of any help, we now have two models running 2921 and 1921 and both the systems were delivered on 15.1(4)M3, which is from december 2011, IPbase and K9 license on the box. I ran a couple of quick tests and confirmed IPv6 functionality on BGP, OSPF and IS-IS. These were no performance tests, but at least I verified the process starts and is capable of exchanging a static IPv6 route. Little disclaimer: this was the first time I ever touched IS-IS, your mileage may vary.
>
> I did some performance tests on a 1921 with 15.1(2)T4 / security license and
> experienced a serious degradation when using PPPoE uplinks.
>
> v6
> unidirectional IMIX UDP packets, G0/0 -> G0/1 : 100 Mbit/s @ 20 % CPU
> unidirectional IMIX UDP packets, G0/0 -> G0/1 (PPPoE): 50 Mbit/s @ 72 % CPU
>
> v4
> unidirectional IMIX UDP packets, G0/0 -> G0/1 : 100 Mbit/s @ 14 % CPU
> unidirectional IMIX UDP packets, G0/0 -> G0/1 (PPPoE): 100 Mbit/s @ 26 % CPU
>
> For me it looks like the box has some problems with IPv6 together with PPP. It may also
> be a configration issue. So here is a part of the config. The box was not doing NAT or
> ipv6 inspect.
>
> no ipv6 source-route
> ipv6 unicast-routing
> ipv6 cef
> no ip source-route
> ip cef
> !
> interface GigabitEthernet0/0
> description traffic generator
> ip address x.x.x.x 255.255.255.0
> no ip redirects
> load-interval 30
> duplex auto
> speed auto
> ipv6 address 2001:db8::1/64
> ipv6 enable
> no ipv6 redirects
> ipv6 verify unicast reverse-path
> !
> interface GigabitEthernet0/1
> description Uplink
> no ip address
> load-interval 30
> duplex auto
> speed auto
> pppoe enable group global
> pppoe-client dial-pool-number 1
> no cdp enable
> !
> interface Dialer1
> mtu 1492
> ip address negotiated
> encapsulation ppp
> dialer pool 1
> dialer-group 1
> ipv6 address FE80::CE link-local
> ipv6 address autoconfig
> ipv6 enable
> ppp authentication pap callin
> ppp pap sent-username <its-me> password <its-really-me>
> no cdp enable
> !
> ipv6 route ::/0 Dialer1
> ip route 0.0.0.0 0.0.0.0 Dialer1
>
>
> Hints welcome.
>
> Michael
>

--
Marc Binderberger <marc [at] sniff>


madams at netcologne

Feb 14, 2012, 4:34 AM

Post #11 of 18 (3869 views)
Permalink
Re: Small cisco boxes doing IPv6? [In reply to]

Hi Marc!

Am 14.02.2012 12:04, schrieb Marc Binderberger:

> you have "ipv6 verify unicast reverse-path" configured but not the equivalent for IPv4. Now the reverse-path lookup doubles the CEF lookup which could in worst case double your CPU utilization.

I forgot to mention I did the test also without "ipv6 verify...". Of course it's having
an impact. Without verifiying the source address the CPU load is about 70% instead of 75%.

> Would be interesting to see how numbers for IPv4 look like with unicast reverse verification enabled.

The CPU load jumps to 34%. But 100 Mbit/s are still no problem.

>> unidirectional IMIX UDP packets, G0/0 -> G0/1 : 100 Mbit/s @ 20 % CPU
>> unidirectional IMIX UDP packets, G0/0 -> G0/1 (PPPoE): 50 Mbit/s @ 72 % CPU

For me the interesting thing is using PPPoE on the uplink is having a very significant
impact on the CPU load and as a consequence on the possible througput. 100 Mbit/s @ 20% CPU
vs. 50 Mbit/s @ 72% means about 7 x less traffic with PPPoE.

regards,
Michael


>
>
> Regards, Marc
>
>
>
> On 2012-02-14, at 11:53 , Michael Adams wrote:
>
>> Am 13.02.2012 11:36, schrieb Marco Hogewoning:
>>> If it is of any help, we now have two models running 2921 and 1921 and both the systems were delivered on 15.1(4)M3, which is from december 2011, IPbase and K9 license on the box. I ran a couple of quick tests and confirmed IPv6 functionality on BGP, OSPF and IS-IS. These were no performance tests, but at least I verified the process starts and is capable of exchanging a static IPv6 route. Little disclaimer: this was the first time I ever touched IS-IS, your mileage may vary.
>>
>> I did some performance tests on a 1921 with 15.1(2)T4 / security license and
>> experienced a serious degradation when using PPPoE uplinks.
>>
>> v6
>> unidirectional IMIX UDP packets, G0/0 -> G0/1 : 100 Mbit/s @ 20 % CPU
>> unidirectional IMIX UDP packets, G0/0 -> G0/1 (PPPoE): 50 Mbit/s @ 72 % CPU
>>
>> v4
>> unidirectional IMIX UDP packets, G0/0 -> G0/1 : 100 Mbit/s @ 14 % CPU
>> unidirectional IMIX UDP packets, G0/0 -> G0/1 (PPPoE): 100 Mbit/s @ 26 % CPU
>>
>> For me it looks like the box has some problems with IPv6 together with PPP. It may also
>> be a configration issue. So here is a part of the config. The box was not doing NAT or
>> ipv6 inspect.
>>
>> no ipv6 source-route
>> ipv6 unicast-routing
>> ipv6 cef
>> no ip source-route
>> ip cef
>> !
>> interface GigabitEthernet0/0
>> description traffic generator
>> ip address x.x.x.x 255.255.255.0
>> no ip redirects
>> load-interval 30
>> duplex auto
>> speed auto
>> ipv6 address 2001:db8::1/64
>> ipv6 enable
>> no ipv6 redirects
>> ipv6 verify unicast reverse-path
>> !
>> interface GigabitEthernet0/1
>> description Uplink
>> no ip address
>> load-interval 30
>> duplex auto
>> speed auto
>> pppoe enable group global
>> pppoe-client dial-pool-number 1
>> no cdp enable
>> !
>> interface Dialer1
>> mtu 1492
>> ip address negotiated
>> encapsulation ppp
>> dialer pool 1
>> dialer-group 1
>> ipv6 address FE80::CE link-local
>> ipv6 address autoconfig
>> ipv6 enable
>> ppp authentication pap callin
>> ppp pap sent-username <its-me> password <its-really-me>
>> no cdp enable
>> !
>> ipv6 route ::/0 Dialer1
>> ip route 0.0.0.0 0.0.0.0 Dialer1
>>
>>
>> Hints welcome.
>>
>> Michael
>>
>
> --
> Marc Binderberger <marc [at] sniff>
>


--
Michael Adams Tel: +49 221 2222 657
Network Engineering & Design Fax: +49 221 2222 7657

NetCologne Geschäftsführer
Gesellschaft für Telekommunikation mbH Dr. Hans Konle (Sprecher)
Am Coloneum 9 Dipl.-Ing. Karl-Heinz Zankel
50829 Köln HRB 25580, Amtsgericht Köln


evyncke at cisco

Feb 14, 2012, 6:30 AM

Post #12 of 18 (3850 views)
Permalink
RE: Small cisco boxes doing IPv6? [In reply to]

Michael

Does your mix include full size packets? Then, those packets are dropped by the router and an ICMP is generated. You may want to set the MTU of the Ethernet link to 1492 as well (assuming that RA will advertize this MTU size).

Does the destination exist? You may be receiving 'backscatter' traffic for IPv6 which would divide throughput by two of course

Else, nothing glaring

> -----Original Message-----
> From: ipv6-ops-bounces+evyncke=cisco.com [at] lists [mailto:ipv6-ops-
> bounces+evyncke=cisco.com [at] lists] On Behalf Of Michael Adams
> Sent: mardi 14 février 2012 11:54
> To: ipv6-ops [at] lists
> Subject: Re: Small cisco boxes doing IPv6?
>
> Am 13.02.2012 11:36, schrieb Marco Hogewoning:
> > If it is of any help, we now have two models running 2921 and 1921 and
> both the systems were delivered on 15.1(4)M3, which is from december 2011,
> IPbase and K9 license on the box. I ran a couple of quick tests and
> confirmed IPv6 functionality on BGP, OSPF and IS-IS. These were no
> performance tests, but at least I verified the process starts and is capable
> of exchanging a static IPv6 route. Little disclaimer: this was the first
> time I ever touched IS-IS, your mileage may vary.
>
> I did some performance tests on a 1921 with 15.1(2)T4 / security license and
> experienced a serious degradation when using PPPoE uplinks.
>
> v6
> unidirectional IMIX UDP packets, G0/0 -> G0/1 : 100 Mbit/s @ 20 % CPU
> unidirectional IMIX UDP packets, G0/0 -> G0/1 (PPPoE): 50 Mbit/s @ 72 % CPU
>
> v4
> unidirectional IMIX UDP packets, G0/0 -> G0/1 : 100 Mbit/s @ 14 % CPU
> unidirectional IMIX UDP packets, G0/0 -> G0/1 (PPPoE): 100 Mbit/s @ 26 %
> CPU
>
> For me it looks like the box has some problems with IPv6 together with PPP.
> It may also
> be a configration issue. So here is a part of the config. The box was not
> doing NAT or
> ipv6 inspect.
>
> no ipv6 source-route
> ipv6 unicast-routing
> ipv6 cef
> no ip source-route
> ip cef
> !
> interface GigabitEthernet0/0
> description traffic generator
> ip address x.x.x.x 255.255.255.0
> no ip redirects
> load-interval 30
> duplex auto
> speed auto
> ipv6 address 2001:db8::1/64
> ipv6 enable
> no ipv6 redirects
> ipv6 verify unicast reverse-path
> !
> interface GigabitEthernet0/1
> description Uplink
> no ip address
> load-interval 30
> duplex auto
> speed auto
> pppoe enable group global
> pppoe-client dial-pool-number 1
> no cdp enable
> !
> interface Dialer1
> mtu 1492
> ip address negotiated
> encapsulation ppp
> dialer pool 1
> dialer-group 1
> ipv6 address FE80::CE link-local
> ipv6 address autoconfig
> ipv6 enable
> ppp authentication pap callin
> ppp pap sent-username <its-me> password <its-really-me>
> no cdp enable
> !
> ipv6 route ::/0 Dialer1
> ip route 0.0.0.0 0.0.0.0 Dialer1
>
>
> Hints welcome.
>
> Michael


gert at space

Feb 14, 2012, 6:49 AM

Post #13 of 18 (3837 views)
Permalink
Re: Small cisco boxes doing IPv6? [In reply to]

Hi,

On Tue, Feb 14, 2012 at 03:30:28PM +0100, Eric Vyncke (evyncke) wrote:
> Else, nothing glaring

My gut guess would be "IPv6 over PPPoE is not CEF-switched".

But of course nobody at Cisco would implement it that way.

Gert Doering
-- NetMaster
--
have you enabled IPv6 on something today...?

SpaceNet AG Vorstand: Sebastian v. Bomhard
Joseph-Dollinger-Bogen 14 Aufsichtsratsvors.: A. Grundner-Culemann
D-80807 Muenchen HRB: 136055 (AG Muenchen)
Tel: +49 (89) 32356-444 USt-IdNr.: DE813185279


mark at townsley

Feb 14, 2012, 7:17 AM

Post #14 of 18 (3836 views)
Permalink
Re: Small cisco boxes doing IPv6? [In reply to]

On Feb 14, 2012, at 3:49 PM, Gert Doering wrote:

> Hi,
>
> On Tue, Feb 14, 2012 at 03:30:28PM +0100, Eric Vyncke (evyncke) wrote:
>> Else, nothing glaring
>
> My gut guess would be "IPv6 over PPPoE is not CEF-switched".

Gert wins a prize.

IPv6 CEF support for "Dialer Interfaces" comes via CSCtk62149 committed to 15.2(3)T - planned to CCO in March.

- Mark


merike at doubleshotsecurity

Feb 14, 2012, 12:31 PM

Post #15 of 18 (3845 views)
Permalink
Re: Small cisco boxes doing IPv6? [In reply to]

I've found the 'show process cpu' or 'show process mem' command to be useful.

Cosmopolitan#show process ?
<1-4294967295> Process Number
cpu Show CPU use per process
history display ordered Process history
memory Show memory use per process
timercheck Show processes configured for timercheck
| Output modifiers
<cr>

FWIW I was never a fan of IMIX and tested individual packet sizes for any performance test. Why? Weird behavior with some packet sizes and not others due to buffer allocations and some things I can't remember. IMIX has its uses but the problem was always 'which mix is the right one' :)

Else I don't see anything new to comment on from what has already been said.

- merike

On Feb 14, 2012, at 6:30 AM, Eric Vyncke (evyncke) wrote:

> Michael
>
> Does your mix include full size packets? Then, those packets are dropped by the router and an ICMP is generated. You may want to set the MTU of the Ethernet link to 1492 as well (assuming that RA will advertize this MTU size).
>
> Does the destination exist? You may be receiving 'backscatter' traffic for IPv6 which would divide throughput by two of course
>
> Else, nothing glaring
>
>> -----Original Message-----
>> From: ipv6-ops-bounces+evyncke=cisco.com [at] lists [mailto:ipv6-ops-
>> bounces+evyncke=cisco.com [at] lists] On Behalf Of Michael Adams
>> Sent: mardi 14 février 2012 11:54
>> To: ipv6-ops [at] lists
>> Subject: Re: Small cisco boxes doing IPv6?
>>
>> Am 13.02.2012 11:36, schrieb Marco Hogewoning:
>>> If it is of any help, we now have two models running 2921 and 1921 and
>> both the systems were delivered on 15.1(4)M3, which is from december 2011,
>> IPbase and K9 license on the box. I ran a couple of quick tests and
>> confirmed IPv6 functionality on BGP, OSPF and IS-IS. These were no
>> performance tests, but at least I verified the process starts and is capable
>> of exchanging a static IPv6 route. Little disclaimer: this was the first
>> time I ever touched IS-IS, your mileage may vary.
>>
>> I did some performance tests on a 1921 with 15.1(2)T4 / security license and
>> experienced a serious degradation when using PPPoE uplinks.
>>
>> v6
>> unidirectional IMIX UDP packets, G0/0 -> G0/1 : 100 Mbit/s @ 20 % CPU
>> unidirectional IMIX UDP packets, G0/0 -> G0/1 (PPPoE): 50 Mbit/s @ 72 % CPU
>>
>> v4
>> unidirectional IMIX UDP packets, G0/0 -> G0/1 : 100 Mbit/s @ 14 % CPU
>> unidirectional IMIX UDP packets, G0/0 -> G0/1 (PPPoE): 100 Mbit/s @ 26 %
>> CPU
>>
>> For me it looks like the box has some problems with IPv6 together with PPP.
>> It may also
>> be a configration issue. So here is a part of the config. The box was not
>> doing NAT or
>> ipv6 inspect.
>>
>> no ipv6 source-route
>> ipv6 unicast-routing
>> ipv6 cef
>> no ip source-route
>> ip cef
>> !
>> interface GigabitEthernet0/0
>> description traffic generator
>> ip address x.x.x.x 255.255.255.0
>> no ip redirects
>> load-interval 30
>> duplex auto
>> speed auto
>> ipv6 address 2001:db8::1/64
>> ipv6 enable
>> no ipv6 redirects
>> ipv6 verify unicast reverse-path
>> !
>> interface GigabitEthernet0/1
>> description Uplink
>> no ip address
>> load-interval 30
>> duplex auto
>> speed auto
>> pppoe enable group global
>> pppoe-client dial-pool-number 1
>> no cdp enable
>> !
>> interface Dialer1
>> mtu 1492
>> ip address negotiated
>> encapsulation ppp
>> dialer pool 1
>> dialer-group 1
>> ipv6 address FE80::CE link-local
>> ipv6 address autoconfig
>> ipv6 enable
>> ppp authentication pap callin
>> ppp pap sent-username <its-me> password <its-really-me>
>> no cdp enable
>> !
>> ipv6 route ::/0 Dialer1
>> ip route 0.0.0.0 0.0.0.0 Dialer1
>>
>>
>> Hints welcome.
>>
>> Michael
>


merike at doubleshotsecurity

Feb 14, 2012, 4:26 PM

Post #16 of 18 (3819 views)
Permalink
Re: Small cisco boxes doing IPv6? [In reply to]

On Feb 14, 2012, at 7:17 AM, Mark Townsley wrote:

>
>
> On Feb 14, 2012, at 3:49 PM, Gert Doering wrote:
>
>> Hi,
>>
>> On Tue, Feb 14, 2012 at 03:30:28PM +0100, Eric Vyncke (evyncke) wrote:
>>> Else, nothing glaring
>>
>> My gut guess would be "IPv6 over PPPoE is not CEF-switched".
>
> Gert wins a prize.
>
> IPv6 CEF support for "Dialer Interfaces" comes via CSCtk62149 committed to 15.2(3)T - planned to CCO in March.

Is there a magic public cheat sheet for features that get punted to cpu for now for IPv6 with roadmap of when they get into cef? I vaguely remember such a beast a few years back. I expect you could find this in varying release notes but a single place to look would be great.

- merike


madams at netcologne

Feb 14, 2012, 11:57 PM

Post #17 of 18 (3821 views)
Permalink
Re: Small cisco boxes doing IPv6? [In reply to]

Am 14.02.2012 16:17, schrieb Mark Townsley:
>> My gut guess would be "IPv6 over PPPoE is not CEF-switched".
>
> Gert wins a prize.
>
> IPv6 CEF support for "Dialer Interfaces" comes via CSCtk62149 committed to 15.2(3)T - planned to CCO in March.

Bingo.

I'll check this in march. Thanks a lot for the hint!

Michael


madams at netcologne

Feb 15, 2012, 12:16 AM

Post #18 of 18 (3814 views)
Permalink
Re: Small cisco boxes doing IPv6? [In reply to]

Am 14.02.2012 21:31, schrieb Merike Kaeo:

> FWIW I was never a fan of IMIX and tested individual packet sizes for any performance test. Why? Weird behavior with some packet sizes and not others due to buffer allocations and some things I can't remember. IMIX has its uses but the problem was always 'which mix is the right one' :)

Hopefully our definition of IMIX matches real customer traffic closely and leads to
satisfied customers :-) But we are also testing with individual packet sizes.

Michael

nsp ipv6 RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.