Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: MythTV: Users

Required development rpms for compiling MythTV Fedora

 

 

MythTV users RSS feed   Index | Next | Previous | View Threaded


mythtv at hambone

Jul 2, 2012, 3:23 PM

Post #1 of 10 (1087 views)
Permalink
Required development rpms for compiling MythTV Fedora

I'm considering compiling MythTV from source and I looked at

http://www.mythtv.org/wiki/Installing_MythTV_SVN_on_Fedora

which seems a little out of date. If anyone on the list using Fedora has
successfully compiled MythTV and satisfied the various dependencies, could
he/she pass along a list of the rpms that need to be installed? I'm
running Fedora 17, if that makes a difference.

I would greatly appreciate it!
Jerry


mythtv at blandford

Jul 2, 2012, 3:30 PM

Post #2 of 10 (1062 views)
Permalink
Re: Required development rpms for compiling MythTV Fedora [In reply to]

On 07/02/2012 03:23 PM, Jerry wrote:
> I'm considering compiling MythTV from source and I looked at
>
> http://www.mythtv.org/wiki/Installing_MythTV_SVN_on_Fedora
>
> which seems a little out of date. If anyone on the list using Fedora
> has successfully compiled MythTV and satisfied the various
> dependencies, could he/she pass along a list of the rpms that need to
> be installed? I'm running Fedora 17, if that makes a difference.
>
> I would greatly appreciate it!
> Jerry

I am assuming you want to compile from source either to learn how to do
it or to apply customer patches.

Either way, I would take a look at the srpm from rpmfusion or atrpms for
mythtv. It would list all of the dependencies necessary.

it might even be easier to just use those rpms and add whatever changes
or patches you want and rebuild.

Michael

_______________________________________________
mythtv-users mailing list
mythtv-users [at] mythtv
http://www.mythtv.org/mailman/listinfo/mythtv-users


mythtv at hambone

Jul 2, 2012, 3:34 PM

Post #3 of 10 (1060 views)
Permalink
Re: Required development rpms for compiling MythTV Fedora [In reply to]

On Mon, Jul 2, 2012 at 6:30 PM, Michael <mythtv [at] blandford> wrote:

> I am assuming you want to compile from source either to learn how to do it
> or to apply customer patches.
>
> Either way, I would take a look at the srpm from rpmfusion or atrpms for
> mythtv. It would list all of the dependencies necessary.
>
> it might even be easier to just use those rpms and add whatever changes or
> patches you want and rebuild.
>
>
That makes perfect sense. I'll go ahead and check that out! Thanks,
Michael.


newbury at mandamus

Jul 3, 2012, 10:10 AM

Post #4 of 10 (1055 views)
Permalink
Re: Required development rpms for compiling MythTV Fedora [In reply to]

On 07/02/2012 06:30 PM, Michael wrote:
> On 07/02/2012 03:23 PM, Jerry wrote:
>> I'm considering compiling MythTV from source and I looked at
>>
>> http://www.mythtv.org/wiki/Installing_MythTV_SVN_on_Fedora
>>
>> which seems a little out of date. If anyone on the list using Fedora
>> has successfully compiled MythTV and satisfied the various
>> dependencies, could he/she pass along a list of the rpms that need to
>> be installed? I'm running Fedora 17, if that makes a difference.
>>
>> I would greatly appreciate it!
>> Jerry
>
> I am assuming you want to compile from source either to learn how to do
> it or to apply customer patches.
>
> Either way, I would take a look at the srpm from rpmfusion or atrpms for
> mythtv. It would list all of the dependencies necessary.
>
> it might even be easier to just use those rpms and add whatever changes
> or patches you want and rebuild.

I wrote the script which is on the wiki page and used it over the
weekend after installing Fedora17.
It is not a minimal list, There are other packages listed which are not
actual myth dependencies, and as of yesterday, it is missing a few
dependencies which master needs but which fixes does not yet require (
no t-shirt for that one...).

And it is missing a number of packages which do not get installed if you
use a liveCD and install from that, as compared to a DVD install.
But it gets you close.

Note that you still need to fix your /etc/ld.so.conf file and install a
mythbackend.service file for systemd to play with.

As Mike noted, the atrpms or rpmfusion spec files will give the minimal
list.

Geoff
_______________________________________________
mythtv-users mailing list
mythtv-users [at] mythtv
http://www.mythtv.org/mailman/listinfo/mythtv-users


mythtv at hambone

Jul 3, 2012, 11:05 AM

Post #5 of 10 (1051 views)
Permalink
Re: Required development rpms for compiling MythTV Fedora [In reply to]

On Tue, Jul 3, 2012 at 1:10 PM, R. G. Newbury <newbury [at] mandamus> wrote:

> On 07/02/2012 06:30 PM, Michael wrote:
>
>> I am assuming you want to compile from source either to learn how to do
>> it or to apply customer patches.
>>
>> Either way, I would take a look at the srpm from rpmfusion or atrpms for
>> mythtv. It would list all of the dependencies necessary.
>>
>> it might even be easier to just use those rpms and add whatever changes
>> or patches you want and rebuild.
>>
>
> I wrote the script which is on the wiki page and used it over the weekend
> after installing Fedora17.
> It is not a minimal list, There are other packages listed which are not
> actual myth dependencies, and as of yesterday, it is missing a few
> dependencies which master needs but which fixes does not yet require ( no
> t-shirt for that one...).
>
> And it is missing a number of packages which do not get installed if you
> use a liveCD and install from that, as compared to a DVD install.
> But it gets you close.
>
> Note that you still need to fix your /etc/ld.so.conf file and install a
> mythbackend.service file for systemd to play with.
>
> As Mike noted, the atrpms or rpmfusion spec files will give the minimal
> list.
>
> Geoff
>

Thanks, Geoff. I'm going to give it a shot over the next few days and see
if I can get started. It's definitely going to be a challenge for me. I
hope to come up with something I can use after I scratch my head a few
times. :)

I appreciate both of your prompt responses! I may have (probably will
have) a few more questions as I get further down the road.

Jerry


monkeypet at gmail

Jul 4, 2012, 12:08 PM

Post #6 of 10 (1045 views)
Permalink
Re: Required development rpms for compiling MythTV Fedora [In reply to]

On Tue, Jul 3, 2012 at 11:05 AM, Jerry <mythtv [at] hambone> wrote:

> On Tue, Jul 3, 2012 at 1:10 PM, R. G. Newbury <newbury [at] mandamus>wrote:
>
>> On 07/02/2012 06:30 PM, Michael wrote:
>>
>>> I am assuming you want to compile from source either to learn how to do
>>> it or to apply customer patches.
>>>
>>> Either way, I would take a look at the srpm from rpmfusion or atrpms for
>>> mythtv. It would list all of the dependencies necessary.
>>>
>>> it might even be easier to just use those rpms and add whatever changes
>>> or patches you want and rebuild.
>>>
>>
>> I wrote the script which is on the wiki page and used it over the weekend
>> after installing Fedora17.
>> It is not a minimal list, There are other packages listed which are not
>> actual myth dependencies, and as of yesterday, it is missing a few
>> dependencies which master needs but which fixes does not yet require ( no
>> t-shirt for that one...).
>>
>> And it is missing a number of packages which do not get installed if you
>> use a liveCD and install from that, as compared to a DVD install.
>> But it gets you close.
>>
>> Note that you still need to fix your /etc/ld.so.conf file and install a
>> mythbackend.service file for systemd to play with.
>>
>> As Mike noted, the atrpms or rpmfusion spec files will give the minimal
>> list.
>>
>> Geoff
>>
>
> Thanks, Geoff. I'm going to give it a shot over the next few days and see
> if I can get started. It's definitely going to be a challenge for me. I
> hope to come up with something I can use after I scratch my head a few
> times. :)
>
> I appreciate both of your prompt responses! I may have (probably will
> have) a few more questions as I get further down the road.
>

Jerry, did you get anywhere with this? I am hoping you can share notes. I
am looking to build from the myth 0.25-fixes branch.


>
>
> Jerry
>
> _______________________________________________
> mythtv-users mailing list
> mythtv-users [at] mythtv
> http://www.mythtv.org/mailman/listinfo/mythtv-users
>
>


mythtv at hambone

Jul 4, 2012, 1:43 PM

Post #7 of 10 (1049 views)
Permalink
Re: Required development rpms for compiling MythTV Fedora [In reply to]

On Wed, Jul 4, 2012 at 3:08 PM, Monkey Pet <monkeypet [at] gmail> wrote:

>
> Jerry, did you get anywhere with this? I am hoping you can share notes.
> I am looking to build from the myth 0.25-fixes branch.
>
>

I haven't had a chance to as of yet. I hope to get to things before the
weekend.

Jerry


monkeypet at gmail

Jul 4, 2012, 10:33 PM

Post #8 of 10 (1033 views)
Permalink
Re: Required development rpms for compiling MythTV Fedora [In reply to]

On Wed, Jul 4, 2012 at 1:43 PM, Jerry <mythtv [at] hambone> wrote:

> On Wed, Jul 4, 2012 at 3:08 PM, Monkey Pet <monkeypet [at] gmail> wrote:
>
>>
>> Jerry, did you get anywhere with this? I am hoping you can share notes.
>> I am looking to build from the myth 0.25-fixes branch.
>>
>>
>
> I haven't had a chance to as of yet. I hope to get to things before the
> weekend.
>

This has everything you need. I was able to compile mythtv using it and
the specs from rpmfusion.

http://www.mythtv.org/wiki/Building_RPMS_from_Source


>
>
> Jerry
>
> _______________________________________________
> mythtv-users mailing list
> mythtv-users [at] mythtv
> http://www.mythtv.org/mailman/listinfo/mythtv-users
>
>


seven at seven

Jul 5, 2012, 3:23 AM

Post #9 of 10 (1026 views)
Permalink
Re: Required development rpms for compiling MythTV Fedora [In reply to]

On 5 July 2012 15:33, Monkey Pet <monkeypet [at] gmail> wrote:

> On Wed, Jul 4, 2012 at 1:43 PM, Jerry <mythtv [at] hambone> wrote:
>
>> On Wed, Jul 4, 2012 at 3:08 PM, Monkey Pet <monkeypet [at] gmail> wrote:
>>
>>>
>>> Jerry, did you get anywhere with this? I am hoping you can share notes.
>>> I am looking to build from the myth 0.25-fixes branch.
>>>
>>>
>>
>> I haven't had a chance to as of yet. I hope to get to things before the
>> weekend.
>>
>
> This has everything you need. I was able to compile mythtv using it and
> the specs from rpmfusion.
>
> http://www.mythtv.org/wiki/Building_RPMS_from_Source
>
>
>>
>>
>> Jerry
>>
>>
From the old rpmfusion src file I used

yum-builddep --nogpgcheck mythtv-0.24.1-5.fc15.src.rpm

This built most of the dependancys but I did have to build afew packages
from source as I'm still runing the old mythdora which is based on fc12

Cheers,

Anthony


peterpf_mitchell at yahoo

Jul 5, 2012, 3:26 AM

Post #10 of 10 (1048 views)
Permalink
Re: Required development rpms for compiling MythTV Fedora [In reply to]

>________________________________
> From: Monkey Pet <monkeypet [at] gmail>
>To: Discussion about MythTV <mythtv-users [at] mythtv>
>Sent: Thursday, 5 July 2012, 6:33
>Subject: Re: [mythtv-users] Required development rpms for compiling MythTV Fedora
>
>
>On Wed, Jul 4, 2012 at 1:43 PM, Jerry <mythtv [at] hambone> wrote:
>
>On Wed, Jul 4, 2012 at 3:08 PM, Monkey Pet <monkeypet [at] gmail> wrote:
>>
>>
>>>
>>>Jerry, did you get anywhere with this?  I am hoping you can share notes.  I am looking to build from the myth 0.25-fixes branch.
>>> 
>>
>>I haven't had a chance to as of yet.  I hope to get to things before the weekend.
>
>
>This has everything you need.  I was able to compile mythtv using it and the specs from rpmfusion.
>
>
>http://www.mythtv.org/wiki/Building_RPMS_from_Source


I guess you guys have the list you need?
Anyway if not I recently upgraded to 0.25.1-fixes based on an FC 16 install and I always build my own using the source. This was a
fresh install using the FC16 livecd to inially install linux and using atrpms to obtain some of the dependencies. The packages I
installed are listed below in the order of installation via
yum install:

Note 1: I would have been installing a few other tools and utilities at the sametime so some packges may be a dependency of
these rather than for mythtv (mplayer, vlc etc...)

Note 2: I tried this with FC17 as well but hit multiple dependency issues betwen atrpms and FC17. I got the impression that
atrpms is currently out of alignment so you might want to look at rmpfusion if installing on FC17 at this time. This was
about a month ago so possibly resolved by now.

Note 3: atrpms appears to pull in QT3 so you will need to switch to QT4

The following is extracted from the notes for my system.


yum install the following:

gcc
libjpeg - not sure if needed
libjpeg-devel
gcc-c++
mingw32-qt-qmake.x86_64
dvb-apps (tools)
w_scan (tools)
v4l-utils (tools)
subversion
git
gtk2-devel
mercurial

Remove alsa-plugins-pulseaudio: yum remove alsa-plugins-pulseaudio

Add the ATRPMS signing key:
rpm --import http://packages.atrpms.net/RPM-GPG-KEY.atrpms
Add ATRPMS Repository using this package from http://packages.atrpms.net/dist/f16/atrpms-repo/
atrpms-repo-16-5.fc16.x86_64.rpm

The above will pull in a lot of packages from ATRPMS.


yum install the following:

alsa-driver (Do we need this??) - cannot install on fc17
alsa-oss (Do we need this??)
alsa-lib-devel

lirc
git
yasm
libmp3lame0
mysql
xmltv
qt4_devel
qtwebkit-devel
mysql-server
qt-mysql
mscore-fonts


for MythArchive burn script:
python-imaging
ffmpeg
dvdauthor
cdw
m2vrequantiser (search fedora 16 M2vRequantiser and install via RPM)

For MythMusic:
libmad
faad2
libcdaudio-devel
cdparanoia-devel
SDL-devel
libvisual-devel
libcdio-devel

For MythVideo:
xvidcore
libdvdcss

for MythArchive burn script:
python-imaging
ffmpeg
dvdauthor
cdw
m2vrequantiser (search fedora 16 M2vRequantiser and install via RPM)

For MythMusic:
libmad
faad2
libcdaudio-devel
cdparanoia-devel
SDL-devel
libvisual-devel
libcdio-devel

For MythVideo:
xvidcore
libdvdcss

For theWeb Interface:
httpd
php
php-mysql
mod_suphp ?
php-process

Cheers

Peter
_______________________________________________
mythtv-users mailing list
mythtv-users [at] mythtv
http://www.mythtv.org/mailman/listinfo/mythtv-users

MythTV users RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.