Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: MythTV: Users

Difficulty with video storage group

 

 

MythTV users RSS feed   Index | Next | Previous | View Threaded


lists at firecloud

May 6, 2012, 12:44 AM

Post #1 of 10 (1125 views)
Permalink
Difficulty with video storage group

About a week ago, I upgraded from 0.24-fixes to 0.25 (using the
Mythbuntu system). Once I switched to a theme that supported 0.25
(Arclight), recording and playback of recordings worked fine.

Today I've been trying to watch a video (as opposed to a recording). I
was told "There are no videos in the database. Would you like to scan
your video directories now?"
I said Yes, and got "A video scan found no files, have you configured
a video storage group?".

I checked the videos directory and it is there, it has content, and
the permissions are OK - all unchanged from when it worked under 0.24.

I went to backend-setup to check the storage groups settings, and found oddness.
Initially the only storage group visible was "Default". No other lines
on the screen, not even "(Create new group)". However, when I pressed
the down cursor, all of the normal groups appeared. I scrolled down to
Videos and pushed Enter, and again saw just one (correct) line.
Pushing the down arrow made a second (correct) directory and "(Add new
directory)" appear.

I tried deleting and recreating the Videos group, but this changed
nothing, and there is still the odd behaviour in backend-setup.

Any suggestions?
Thanks :-)

--
Simon Waldman
swaldman [at] firecloud
_______________________________________________
mythtv-users mailing list
mythtv-users [at] mythtv
http://www.mythtv.org/mailman/listinfo/mythtv-users


lists at firecloud

May 6, 2012, 12:02 PM

Post #2 of 10 (1083 views)
Permalink
Re: Difficulty with video storage group [In reply to]

On Sun, May 6, 2012 at 8:44 AM, Simon Waldman <lists [at] firecloud> wrote:

> Today I've been trying to watch a video (as opposed to a recording). I
> was told "There are no videos in the database. Would you like to scan
> your video directories now?"
> I said Yes, and got "A video scan found no files, have you configured
> a video storage group?".
>
> I checked the videos directory and it is there, it has content, and
> the permissions are OK - all unchanged from when it worked under 0.24.
>
> I went to backend-setup to check the storage groups settings, and found oddness.
> Initially the only storage group visible was "Default". No other lines
> on the screen, not even "(Create new group)". However, when I pressed
> the down cursor, all of the normal groups appeared. I scrolled down to
> Videos and pushed Enter, and again saw just one (correct) line.
> Pushing the down arrow made a second (correct) directory and "(Add new
> directory)" appear.

Update: The vanishing lines in backend-setup seem to be a theme issue
- other themes don't do it. So that's no longer something relevant to
the problem.
The problem still remains that MythTV can't see the Video storage
group. Can anybody offer any suggestions on things to try, or further
info that I could provide?

Thanks!

--
Simon Waldman
swaldman [at] firecloud
_______________________________________________
mythtv-users mailing list
mythtv-users [at] mythtv
http://www.mythtv.org/mailman/listinfo/mythtv-users


mtdean at thirdcontact

May 7, 2012, 4:27 AM

Post #3 of 10 (1075 views)
Permalink
Re: Difficulty with video storage group [In reply to]

On 05/06/2012 03:02 PM, Simon Waldman wrote:
> On Sun, May 6, 2012 at 8:44 AM, Simon Waldman wrote:
>> Today I've been trying to watch a video (as opposed to a recording). I
>> was told "There are no videos in the database. Would you like to scan
>> your video directories now?"
>> I said Yes, and got "A video scan found no files, have you configured
>> a video storage group?".
>>
>> I checked the videos directory and it is there, it has content, and
>> the permissions are OK - all unchanged from when it worked under 0.24.
> The problem still remains that MythTV can't see the Video storage
> group. Can anybody offer any suggestions on things to try, or further
> info that I could provide?

frontend and backend logs with -v file showing a scan.

Mike
_______________________________________________
mythtv-users mailing list
mythtv-users [at] mythtv
http://www.mythtv.org/mailman/listinfo/mythtv-users


lists at firecloud

May 7, 2012, 5:50 AM

Post #4 of 10 (1085 views)
Permalink
Re: Difficulty with video storage group [In reply to]

> Date: Mon, 07 May 2012 07:27:08 -0400
> From: "Michael T. Dean" <mtdean [at] thirdcontact>

>> On Sun, May 6, 2012 at 8:44 AM, Simon Waldman wrote:
>>> Today I've been trying to watch a video (as opposed to a recording). I
>>> was told "There are no videos in the database. Would you like to scan
>>> your video directories now?"
>>> I said Yes, and got "A video scan found no files, have you configured
>>> a video storage group?".
>>>
>>> I checked the videos directory and it is there, it has content, and
>>> the permissions are OK - all unchanged from when it worked under 0.24.
>> The problem still remains that MythTV can't see the Video storage
>> group. Can anybody offer any suggestions on things to try, or further
>> info that I could provide?
>
> frontend and backend logs with -v file showing a scan.

Hi Mike, thanks for taking the time to help.

Frontend log:

2012-05-07 13:32:40.103059 I Beginning Video Scan.
2012-05-07 13:32:40.103110 I buildFileList directory =
myth://Videos [at] myt/var/lib/mythtv/videos/
2012-05-07 13:32:40.103646 I MythVideo::ScanVideoDirectory Scanning
Group (myth://Videos [at] myt/var/lib/mythtv/videos/)
2012-05-07 13:32:40.106117 I SG(Videos): GetFileInfoList: Reading
'/var/lib/mythtv/videos/'

I can't see anything relevant in the backend log, but in case it helps
here's the section around the same time, running from when I started
the frontend to when I killed the backend after collecting the logs:

2012-05-07 13:32:31.418309 I MainServer::ANN Playback
2012-05-07 13:32:31.418323 I adding: myth as a client (events: 0)
2012-05-07 13:32:31.418896 I MainServer::ANN Monitor
2012-05-07 13:32:31.418908 I adding: myth as a client (events: 1)
2012-05-07 13:32:36.717939 I Maximal bitrate of busy encoders is 0 KB/min
2012-05-07 13:32:51.717204 I Maximal bitrate of busy encoders is 0 KB/min
2012-05-07 13:33:01.678228 N MythBackend exiting
2012-05-07 13:33:01.679177 I Maximal bitrate of busy encoders is 0 KB/min
2012-05-07 13:33:01.727956 I Waiting for threads to exit.

--
Simon Waldman
swaldman [at] firecloud
_______________________________________________
mythtv-users mailing list
mythtv-users [at] mythtv
http://www.mythtv.org/mailman/listinfo/mythtv-users


mtdean at thirdcontact

May 7, 2012, 11:28 AM

Post #5 of 10 (1086 views)
Permalink
Re: Difficulty with video storage group [In reply to]

On 05/07/2012 08:50 AM, Simon Waldman wrote:
> From: "Michael T. Dean"
>>> On Sun, May 6, 2012 at 8:44 AM, Simon Waldman wrote:
>>>> Today I've been trying to watch a video (as opposed to a recording). I
>>>> was told "There are no videos in the database. Would you like to scan
>>>> your video directories now?"
>>>> I said Yes, and got "A video scan found no files, have you configured
>>>> a video storage group?".
>>>>
>>>> I checked the videos directory and it is there, it has content, and
>>>> the permissions are OK - all unchanged from when it worked under 0.24.
>>> The problem still remains that MythTV can't see the Video storage
>>> group. Can anybody offer any suggestions on things to try, or further
>>> info that I could provide?
>> frontend and backend logs with -v file showing a scan.
> Hi Mike, thanks for taking the time to help.
>
> Frontend log:
>
> 2012-05-07 13:32:40.103059 I Beginning Video Scan.
> 2012-05-07 13:32:40.103110 I buildFileList directory =
> myth://Videos [at] myt/var/lib/mythtv/videos/
> 2012-05-07 13:32:40.103646 I MythVideo::ScanVideoDirectory Scanning
> Group (myth://Videos [at] myt/var/lib/mythtv/videos/)
> 2012-05-07 13:32:40.106117 I SG(Videos): GetFileInfoList: Reading
> '/var/lib/mythtv/videos/'
>
> I can't see anything relevant in the backend log, but in case it helps
> here's the section around the same time, running from when I started
> the frontend to when I killed the backend after collecting the logs:
>
> 2012-05-07 13:32:31.418309 I MainServer::ANN Playback
> 2012-05-07 13:32:31.418323 I adding: myth as a client (events: 0)
> 2012-05-07 13:32:31.418896 I MainServer::ANN Monitor
> 2012-05-07 13:32:31.418908 I adding: myth as a client (events: 1)
> 2012-05-07 13:32:36.717939 I Maximal bitrate of busy encoders is 0 KB/min
> 2012-05-07 13:32:51.717204 I Maximal bitrate of busy encoders is 0 KB/min
> 2012-05-07 13:33:01.678228 N MythBackend exiting
> 2012-05-07 13:33:01.679177 I Maximal bitrate of busy encoders is 0 KB/min
> 2012-05-07 13:33:01.727956 I Waiting for threads to exit.

From these log excerpts, I can say everything is working properly!

Now, if you post the actual (complete) log files from a single run of
mythbackend and mythfrontend with the -v file argument, we might learn
otherwise...

I.e. I can't see an error that you don't recognize as an error if you
don't show me the whole log. If you were able to actually find the
errors in the logs, there's a good chance you wouldn't need to ask me
for help finding the problem. ;)

Mike
_______________________________________________
mythtv-users mailing list
mythtv-users [at] mythtv
http://www.mythtv.org/mailman/listinfo/mythtv-users


lists at firecloud

May 8, 2012, 9:08 AM

Post #6 of 10 (1055 views)
Permalink
Re: Difficulty with video storage group [In reply to]

> Date: Mon, 07 May 2012 14:28:19 -0400
> From: "Michael T. Dean" <mtdean [at] thirdcontact>

>  From these log excerpts, I can say everything is working properly!
>
> Now, if you post the actual (complete) log files from a single run of
> mythbackend and mythfrontend with the -v file argument, we might learn
> otherwise...
>
> I.e. I can't see an error that you don't recognize as an error if you
> don't show me the whole log.  If you were able to actually find the
> errors in the logs, there's a good chance you wouldn't need to ask me
> for help finding the problem.  ;)

Hmm. Fair point ;-)
Full logs attached.

--
Simon Waldman
swaldman [at] firecloud
Attachments: backendlog.txt (3.91 KB)
  frontendlog.txt (5.79 KB)


raymond at wagnerrp

May 8, 2012, 9:46 AM

Post #7 of 10 (1054 views)
Permalink
Re: Difficulty with video storage group [In reply to]

Does the user 'simon' have rights to access the content in
/var/lib/mythtv/videos?
_______________________________________________
mythtv-users mailing list
mythtv-users [at] mythtv
http://www.mythtv.org/mailman/listinfo/mythtv-users


thomas at mashos

May 8, 2012, 11:02 AM

Post #8 of 10 (1061 views)
Permalink
Re: Difficulty with video storage group [In reply to]

On Tue, May 8, 2012 at 9:46 AM, Raymond Wagner <raymond [at] wagnerrp> wrote:
> Does the user 'simon' have rights to access the content in
> /var/lib/mythtv/videos?
> _______________________________________________
> mythtv-users mailing list
> mythtv-users [at] mythtv
> http://www.mythtv.org/mailman/listinfo/mythtv-users

Mythbuntu/Ubuntu adds the user to the mythtv group, so he may need to
logout and back in before he can access it.

Thanks,

Thomas Mashos
_______________________________________________
mythtv-users mailing list
mythtv-users [at] mythtv
http://www.mythtv.org/mailman/listinfo/mythtv-users


lists at firecloud

May 8, 2012, 12:41 PM

Post #9 of 10 (1054 views)
Permalink
Re: Difficulty with video storage group [In reply to]

> Date: Tue, 08 May 2012 12:46:31 -0400
> From: Raymond Wagner <raymond [at] wagnerrp>

> Does the user 'simon' have rights to access the content in
> /var/lib/mythtv/videos?

Raymond,

Thanks to yourself and Thomas for the thoughts re permissions.

In order to rule out anything of this sort I've just tried setting the
directory to 777 and its contents to 666. It didn't make any
difference.

Thanks though :-)
Simon

--
Simon Waldman
swaldman [at] firecloud
_______________________________________________
mythtv-users mailing list
mythtv-users [at] mythtv
http://www.mythtv.org/mailman/listinfo/mythtv-users


lists at firecloud

May 12, 2012, 12:30 AM

Post #10 of 10 (977 views)
Permalink
Re: Difficulty with video storage group [In reply to]

On Sun, May 6, 2012 at 8:44 AM, Simon Waldman <lists [at] firecloud> wrote:

> Today I've been trying to watch a video (as opposed to a recording). I
> was told "There are no videos in the database. Would you like to scan
> your video directories now?"
> I said Yes, and got "A video scan found no files, have you configured
> a video storage group?".

OK, the mystery is solved - I had the Videos view filtered to only
show watched recordings (and everything in the storage group is
unwatched).
On one hand I feel very silly.
On the other hand, there are a couple of points to raise from this:

1. A little RFE for a more helpful error message that doesn't say
"There are no videos in the database" when there are videos in the
database but they are currently filtered out.

2. A bug report: I can reset the filter to show all, but if I go out
of the Videos screen and then return to it, the filter comes back
every time. It is entirely possible that that filter was set when I
upgraded from 0.24: could it have become "stuck" somehow in the
upgrade?

Let me know if I can help by trying anything, but at least now I am
able to watch videos, albeit with the extra step of turning off the
filter each time :-)

--
Simon Waldman
swaldman [at] firecloud
_______________________________________________
mythtv-users mailing list
mythtv-users [at] mythtv
http://www.mythtv.org/mailman/listinfo/mythtv-users

MythTV users RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.